ART new releases

Unfortunately, It doesn’t fall back to exiftool.
Your exiv2 is 2.7MB instead of 4.3 for the one I build on MSYS2/GCC9.2

Could be due to a difference in the tool chain ( GCC9.2 #GCC8.2…)?

What error are you getting? I have tried to run the bundled exiftool with wine, and it worked…

when I tried with a packaged exiv2 the problem was that it was not raising an exception on error, so exiftool was never called… maybe you are using some build flags that cause this?

When I open a CR3 photo, I don’t get any exif data in ART. So It seems that the exiv2 doesn’t raise the exception.

Maybe the digikam folks found the solution:


Thanks! I’ll try this asap and let you know

Hmmm, if I understand the GCC wiki correctly, this is something that needs to be fixed when compiling exiv2. So, could you try rebuilding exiv2 with something like -fvisibility=default?

@gaaned92 @agriggio I have added the -fvisibility=default flag to the EXIV2 compilation, and generated a new package:

I made a quick test and I have the impression that now meta-data is read from CR3 files:

Could you make some tests on your side and confirm the fix?



I did a quick test and it seems to work fine now, thanks!
Though I still don’t understand why it doesn’t work out of the box… from my quick look at the Exiv2 code, all their public API (including exception classes) seem to be properly annotated…

Yes, working now :grinning:

Thank you @agriggio. This tool is fantastic! very useful and essential :+1: :clin d’œil:

1 Like

New release: 1.3.
No binaries yet, I hope they will follow in a few days.
Thanks to all the people who helped with code, translations, suggestions, and bug reports!


Uploaded at

built with
Exiv2_0.27_cxx_standard2_v0.27.2-255-gc51a8aa8 (AKA 0.27.3 I think)
lcms2_master_lcms2.9-80-gfc0fa79 (generic, skylake and znver2)

great improvments! :grinning:


Thanks! Using the generic build I notice that it has the GTK problem where the lens profile selection (automatic or manual) is disabled.

Could you be more specific with the description of problem : system , meaning of disabled (greyed out no lens displayed…). Provide a raw with pp3 to reproduce. why you think it is a GTK problem?
did you activate “profiled lens correction”?

If you are on windows, locate your options file (I think it’s somewhere in c:\users\USERNAME\AppData\Local\ART and add this (or replace if the entry is already there):


If that works, the next step is to understand what went wrong to make this needed…

Thanks Alberto, that fixed it.

My options file had:


I did not run an installer, just unzipped the Windows generic 1.3 build and started ART.exe.

I must have forgotten to check the profiled lens correction, sorry for causing you trouble.

But what is strange that it is now automatically enabled after I applied Alberto’s suggestion in my options file when I open a previously unedited raw file…

Hello everyone,

THANKS a lot indeed for this release!

Just installed the 1.3 version on Windows 10 (64 bit):
ART_1.3_W64_generic (from today’s builds by gaaned92).

I am stuck with a new option, which is:
Split view (shortcut y)

In short, is it possible to gradually zoom in-out into the 2 images?
I have tried several shortcuts to no avail (e.g. ctr+wheel of the mouse; + - etc)

Is is possible to pan into the images once they are zoomed in?
Zoom to 100% (shorcut z ) works but I don’t know how to pan in the image later on…

Here is my screenshot:

Thanks a lot in advance for any pointer!