ART v1.0 is out

@gaaned92 @agriggio

regarding theinstallerStrip.bmp image file for InnoSetup, the file is actually found but the installer somehow doesn’t like it. If I replace it with the original one from the RT sources, the installation proceeds correctly…

Concerning the config dir name, and more generally the distinction between development and release builds, I must say that the way the RT repository is organized is very convenient from the CI point of view. In their case, they push the code of the official releases to a special “releases” branch. It is therefore easy to instruct the build scripts to treat the packages from the releases branch differently, for example setting a different name for the config folder or give a different name to the output packages.

Would it be possible to do the same for ART?

Hi @srgmro, I’ve just created a dedicated issue on bitbucket:


Can you please try to upload the translation there? Thanks!

Strange, it worked for me when I created the installer. I used the latest version (I believe) of InnoSetup, I don’t know if that makes a difference though…

That can certainly be arranged!

I do not find how to add an attach file in the comment on Bitbucket interface
Sorry

Succeeded !!
SM

1 Like

Can you please help with cr3 in linux? ART CR3 compatibility in linux

@Carmelo_DrRaw what I simply do, is to get the length of the git-version string.
If it is 3 characters, I know it is a stable version . Applicable to Art where the tags are x.y

Just a note from a Windows 10 user, I d/l ART_1.0_W64_Skylake.7z, expanded the 7z on a USB drive - the software starts and works well on a portable drive!

So what’s the motivation/niche for ART? Does it do anything better than Raw Therapee and/or darktable?

Hi,

It’s somewhat explained here.

Yes. But YMMV. :stuck_out_tongue_winking_eye:

Thanks for that link, it explains what ART is about very nicely :slight_smile:

It’s become my go-to app after using both RT and darktable for a while. It really does bring the benefits of RT and darktable together without the clutter. I wanted something more streamlined with the output quality of RT and the local editing of darktable. It’s obviously got fewer features than either of those two, but it’s more than enough for most tasks. Considering this is version 1, it’s exciting to see how it develops with future versions.

3 Likes

Thanks to @Carmelo_DrRaw, we now have an experimental ART AppImage . If you are willing to help, please test it in your distribution. You can grab it from here:

5 Likes

Many thanks to @Carmelo_DrRaw :+1: :+1: :+1:

1 Like

@Carmelo_DrRaw
I just noticed the problem.
In your W64 builds, could you copy in the bin subdir the last version of exiftool.exe?

@agriggio can you indicate in the “compilation instruction” to add exiftool.exe?

and perhaps it needs an update of WindowsInnoSetup.iss.in:
Source: "{#MyBuildBasePath}\exiftool.exe"; DestDir: "{app}"; Flags: skipifsourcedoesntexist ignoreversion

@gaaned92 what do you mean exactly? What’s the problem with the above line?

Ah! sorry, it was already present! didn’t notice it :roll_eyes:

Yes, I will do it.

I quickly tried the appimage on Manjaro, it seems to work fine.
I had this message in the console, though I didn’t see any issues:

/usr/lib64/gio/modules/libgioremote-volume-monitor.so: undefined symbol: g_mount_operation_get_is_tcrypt_system_volume
Failed to load module: /usr/lib64/gio/modules/libgioremote-volume-monitor.so
1 Like

AppImage seems to work fine on Xubuntu 18.04 LTS, I’ll drop a link in the Dutch Ubuntu forum.

1 Like