ART CR3 compatibility in linux

hello,

I have compiled ART in ubuntu 19.10.

I have followed this steps:

Install dependencies, exactly the same ones as RawTherapee but adding exiv2 library.

http://rawpedia.rawtherapee.com/Linux#Ubuntu_.3E.3D16.10.2C_Mint_.3E.3D18.3.2C_elementary_OS_.3E.3D0.4.1

sudo apt update
sudo apt install build-essential cmake curl git libcanberra-gtk3-dev libexiv2-dev libexpat-dev libfftw3-dev libglibmm-2.4-dev libgtk-3-dev libgtkmm-3.0-dev libiptcdata0-dev libjpeg-dev liblcms2-dev liblensfun-dev libpng-dev librsvg2-dev libsigc++-2.0-dev libtiff5-dev zlib1g-dev exiv2

Compilation:

http://rawpedia.rawtherapee.com/Linux#Compilation

I used this URL

cd ~
wget https://bitbucket.org/agriggio/art/raw/master/tools/build-art -O build-art
chmod +x build-art
./build-art

When finished I type

~/programs/art/ART

Working! got the Splash Image

After opening ART CR3 files are not displayed. I went to preferences -> file browser and add the cr3 extension, I guess this is small bug.

But after this still CR3 files are not displayed. I am missing something? Maybe I should have not used the Master branch? I have tried with https://bitbucket.org/agriggio/art/raw/1.0/tools/build-art got the same issue.

Version says is 1.0-3

Any help? thanks.

Hi, does this happen with any cr3 file? It works here… did you try restarting ART after adding “cr3” to the list of file browser extensions?
Can you attach your AboutThisBuild.txt file (should be in the same location ast the ART executable)?

Hello,

WOW Thanks for quick reply.

Yes I did actually add the extension as cr3 and CR3 just in case and yes I have restarted multiple times :s

I have tried with 3 different files, none work, but those I was able to convert them to DNG successfully using adobe DNG converter.

Please see attachment of RAW files and JPEG https://send.firefox.com/download/d1e48445d3a5365d/#F9KaaLPA3ZQG7RM-2DFL2g

This my AboutThisBuild.txt

Version: 1.0-3-gc8ebcc53b
Branch: master
Commit: c8ebcc53b
Commit date: 2020-01-29
Compiler: cc 9.2.1
Processor: x86_64
System: Linux
Bit depth: 64 bits
Gtkmm: V3.24.1
Lensfun: V0.3.2.0
Exiv2: V0.25
Build type: release
Build flags: -std=c++11 -march=native -Werror=unused-label -Wall -Wuninitialized -Wno-deprecated-declarations -Wno-unused-result -fopenmp -Werror=unknown-pragmas -O3 -DNDEBUG -ftree-vectorize
Link flags: -march=native
OpenMP support: ON
MMAP support: ON

Hi @neo22s and welcome!

The link you gave 19 minutes ago has already expired???

Have fun!
Claes in Lund, Sweden

hmmm… as you can see, here it works :frowning:


Here’s what you can try to do:

  • open the options file (should be in ~/.config/ART/options) and set Verbose=true in the [General] section

  • run ART from the terminal in “single file mode”, i.e. something like this:

    $ /path/to/ART /path/to/IMG_8790.CR3 2>&1 | tee ~/ART-log.txt
    

Then attach here the generated ART-log.txt. Maybe that will give me some clue…

Sorry I just checked was limited to 1 download.

Damn xD I really can’t see it hahah, have you tested it in linux by any chance?

Here the last lines with and error:

CacheImageData::load / Error code 4 while reading values from "/home/chema/.cache/ART/data/IMG_8790.CR3.61da7cdf11184657187405be43fe454b.txt": No such file or directory importing metadata for Downloads/test cr3/IMG_8790.CR3 with exiftool terminate called after throwing an instance of 'Glib::SpawnError'

Here the entire log
https://gist.githubusercontent.com/neo22s/1f28eac5bf9256d881bdba74c6aa2b10/raw/f0627ce6858ba250fe58212eab15d281c3d707ec/txt

Hi Alberto!
I see in your screenshot that ART can read CR3 metadata, right?
I can see CR3 files, but with no metadata! How is it possible?
Thanks

@neo22s I have been working (almost) exclusively on Linux for about 20 years now :slight_smile:

Anyway, it seems you have a broken (or maybe too old) exiftool installation. I need to better trap this error in the code, but in the meantime you can try the following:

  • download the latest version of exiftool from http://exiftool.org

  • unpack it somewhere

  • point ART to it, i.e. set the following to the full path of the new exiftool:

@alvamatik: the same should work for you as well to get CR3 metadata.

Let me know if this works!

2 Likes

YES!!! that was the issue :wink: seems all working correctly now! thanks a lot :smiley:

I will do a blog post explaining step by step how to make it work.

THANKS A LOT this will improve my workflow a LOT.

2 Likes

I have done this blog post with the detailed installation, hope helps someone https://garridodiaz.com/canon-cr3-support-in-linux-using-art-rawtherapee-clone/

3 Likes

@neo22s thanks for the post! I’ve added a link to it in the docs section of the home page. One minor point though: ART is a derivative of RawTherapee, not a clone. I say this so that people looking for RT+Canon CR3 won’t get disappointed when they see ART instead…

You are right I have changed clone for Fork , better? and thanks to you!! :wink:

1 Like

I have a strange problem with exiftool.
First if I use the deb package of @Dariusz_Duma it works perfectly, the path to my exiftool program is OK.
Then I use the appimage from @Carmelo_DrRaw (1.1-45) and all is OK I detect data from Raw CR3 files.
If I use my compilation (1.1-45) i only get a partial informationScreenshot_2 Screenshot_1
Where could be the problem ?
Thanks for your suggestion
I must say that it already works in previous versions.
Serge

did you compile exiv2 yourself? there is a known issue there with some compilation flags breaking exception handling

I carefully follow the method of @Morgan_Hardwood :


It woks perfectly for me.
What I noticed recently are new messages during the compilation. See joint fileComp.txt (2.2 KB)
Could it be related to that ?
Thanks
Serge Moreau