Beware: Ubuntu Jammy Jellyfish

Glenn, after years using *Buntu I took the plunge with Sid version of Debian a few months ago, due to the former’s lack of provision of up-to-date packages. I have had zero regrets.

My current uptime is 53 days and change, it is so stable. (I suspend regularly, but a hard reset is a rare thing. Occasionally I will logout and restart my desktop session, but that might be once a fortnight, if that.)

Of course YMMV.

sid could be dangerous. Debian -- The unstable distribution ("sid") says:

“sid” is subject to massive changes and in-place library updates. This can result in a very “unstable” system which contains packages that cannot be installed due to missing libraries, dependencies that cannot be fulfilled etc.

I’m thinking about running Hugin via Ubuntu 20.10 in Docker, if I find no other solution. Also, I may switch to some other distro – the ‘snap’ madness in Ubuntu broke my Firefox, for example. I’ve already set up OpenSuse Tumbleweed in VirtualBox.

1 Like

I have found a somewhat satisfying interim solution: stop down to f22. That give sufficient DOF to render most of my model locomotive parts in-focus through their entire depth, so long as I don’t orient my largest parts too far from the perpendicular… I’m not after photographic excellence, I just need to see small things.

I did install Hugin on my Windows tablet, may at some point figure out their batch tool to run a focus stack. But, my immediate concerns are about how to resin-print very small parts that are to function mechanically…

Working hard to avoid Distro Fever… :crazy_face:

1 Like

You are, of course, correct. That has always been the disclaimer about Sid, and why it is so named after the unstable kid in toy story who likes ripping heads off dolls. My only previous forays into debian have been with the latest stable; however these have never lasted long due to the very conservative nature of what is deemed stable, and thus being no where close to the latest versions of many applications.

Sid’s “instability” however seems more reliable to me than *buntu these days.

…however so could using sudo.

It really comes down to risk management: and what is an unacceptable risk for one person is acceptable to another.

It reminds me of the send-up of TL;DR software agreements of the 1980s: “such flagrant acts as inserting the floppy disk in the drive and installing the software render all warranties null and void.”

@ggbutcher … Rx for Distro Fever: take two beers and revisit Distrowatch in the morning.

1 Like

Backporting kinetic kudu packages was pretty easy

Grab the _orig source tarball and the -debian source tarball
Extract the _orig tarball
Change directory, extract the -debian tarball there

debuild -us -uc
If it complains about missing dependencies, install them. I had no problem with any packages if I started with libvigraimpex

Install the resulting .debs - so far I haven’t installed the libvigraimpex python packages, no problem so far

Hugin seems to build fine so far too - hugin package : Ubuntu

Time to test it - hugin starts but I haven’t stitched anything with it in quite a while - but backporting the kinetic kudu packages is simple (grab the tarball and rebuild) and seems to work so far

1 Like

This repo seems to work (I’ve just installed hugin, and stitched a panorama):

1 Like

I’m personally not fans of repos like that one and ubuntuhandbook that have a whole bunch of other unrelated applications in them - sometimes they are less-than-stable version upgrades of other applications I use.

You can also download the .deb files you need, without adding the repo to your system.

Ran across this article specifically on the topic:

I’m going to do the PPA, to make sure I get the command-line tools…

Ack, nevermind about the PPA, align_image_stack and enfuse not working, need to go mow the lawn… :frowning:

Nevermind #2, can’t mow the lawn, family logistics, so back at the tablet…

Turns out there was path and library confusion with my previous attempts to compile, so I uninstalled all that, re-did the PPA and installed hugin, now it works.

Okay, back to family logistics… :crazy_face:


I am on PopOS 22.04 and I noticed they removed Hugin. I then replaced with Flatpak. But then I run into access issues and had to use Flatseal to resolve it.

1 Like