CA correction issue


#1

Hi all,

This is my first post here, so I am not sure if this is the right way to do.

I have found what I think to be a bug on RT 5.4. I use Windows 10, a Canon 80D and in this case a 10-18 STM lens.

The automatic chromatic aberration correction does not work properly if I select distortion correction at the same time. If I disable distortion correction, the CA correction is ok. Here is an illustration of the problem (the image looks blurry because it has a 200% zoom): https://www.sfrcloud.sfr.fr/web/app/share/invite/bpDYQzhm8E

Thanks in advance for your help.


#2

Hi, welcome!

Can you provide a CR2 photo, that makes the glitch easy to notice? Could be about Lensfun data for this lens. You can upload it here.


#3

Disable CA correction under Lens correction and activate Chromatic Aberration under the RAW tab. This works much better.

grafik

Hint: Never use more then one kind of CA correction.


#4

I think that with the default profile (Auto-matched ISO low?) the raw CA should be enabled anyway.


(Alberto) #5

Hi @Videophile, and welcome to the forum!

As @Jacal wrote, it would be great if you could provide a raw file. I opened a PR a while ago to address this potential problem:


One of the reasons why it was not merged is the lack of evidence that the proposed change gives some benefit… but if it fixes your problem, that might help the cause :slight_smile:


#6

Wow, so many answers in such a short time, I’m really impressed! Thanks to all of you!

@Jacal: here you are https://www.sfrcloud.sfr.fr/web/app/share/invite/DKgybrfRjQ (tick the box at the left of the file name and click “Télécharger” on the top rigth of the screen). This is another image, but the problem seems to be the same with any photo taken with this lens. Look at the leaves at the bottom right of the image. Regarding your second post, I tried the default profile, and it does exactly what TooWaBoo suggests.

@TooWaBoo: thank you, this worked! I have been using RT for several years, and I actually used the settings you suggest in the past. In some situations and with olders versions of RT, it didn’t work well, which is why I changed my settings several months ago. Unfortunately, I don’t remember what the problem was. Anyway, I will now use you method (and check the corners of my photos for security).


#7

@agriggio: if my file can help you in confirming your theory, I’d be pleased! The Canon 10-18 STM has quite strong CA and distortion and as such it is a good torture test for CA correction algorithms. By the way, I tested my Canon 17-55 USM, and I feel the problem is still there, although it is way more subtle.


(Alberto) #8

Thanks @Videophile, I’ve added a comment on github:


#9

Seems much better to me, of course compared to existing lensfun ca correction, and also compared to autocorrection in the raw tab.

If you want to check also xtrans beahviour (where auto ca isn’t avaible, so even more important) some time ago i’ve posted also this: Lensfun Ca Correction

Files isn’t anymore on wetransfer but it’s here:DSCF6036.zip (21.0 MB)

Thank you and keep up the great work.


#10

Found out also a strange thing…

neutral profile + lensfun corrections: problem like in the previous post.

tweaked profile + lensfun corrections: seems ok…

I attach pp3s and screenshots…

neutral + lensfun: DSCF6036-neutrale.jpg.out.pp3 (10.4 KB)

tweaked + lensfun: DSCF6036-profilocorretto.jpg.out.pp3 (11.9 KB)


(Alberto) #11

You have defringing enabled in your ‘tweaked’ profile. That’s what’s helping you here :slight_smile:


#12

thought this too… but also disabling it works. And it was limited to purple tints…


(Alberto) #13

I think you have just been “lucky”…

[LensProfile]
LcMode=lfmanual
UseDistortion=true
UseVignette=false
UseCA=true
LFCameraMake=Fujifilm
LFCameraModel=X-M1
LFLens=Petri Auto Petri 1:2.8 f=28mm

#14

Thank you again, but sorry i don’t understand what’s wrong or right…

I’ve tried again starting the neutral profile, choosing manual correction parameters and choosing the right lens entry

, and i don’t get a good ca correction.


(Alberto) #15

Ok, I think I was misunderstanding. Are you saying that the lens is really a “Petri Auto Petri 28mm f/2.8”? I got confused because RT reports the focal length to be 78mm, so I thought you accidentally picked a wrong lens profile. If that’s not the case, then I have to investigate what is going on… :-/


#16

Yes, it’s really a 28mm (that “nice” 28mm btw :wink: ), and i’ve always choosed that lens in the raw therapee interface.

I know i choosed 78mm in the camera menus, since auto iso implementation is quite poor and else auto iso chooses too long shutter speeds (in fact i choosed 78mm for using 50mm lenses, and i think i’ll never change anymore it in camera since it’s quite complex and time consuming).

Thank you again.


(Alberto) #17

Found something:

No idea why it helps though… I suppose it’s just a chance :face_with_raised_eyebrow:


#18

Also choosing no color profile makes indeed a difference…


#19

I’ve tried to compare lensfun and autocorrection with rt 5.4.524-g3bfd903 (without your latest commit proposal i think).

I have found out that a picture developed with only ca autocorrection version seems less saturated / colorful than the same developed with only lensfun ca removal version. Or better, has different colors.


(Alberto) #20

Unfortunately, that’s a known side effect of RAW auto CA correction – it has a visible impact on colour, especially for underexposed (i.e. “high ISO”) shots. It’s subtle but once you notice it, it becomes annoying IMHO. To the point, in fact, that I don’t use it anymore unless the CA is very distracting