Can I use Raw Therapee with Lumix .RAW2 images?


#1

I have just started to use a Lumix TZ100 camera, and was advised that Raw Therapee is great software for working with the RAW files. I have found that I can open the images in the software, and also make adjustments, but when I attempt to save the results I get a “File saving error” error report. Is it that the software is incompatible with .RAW2 files, or, are there any tips that you can give me to overcome the problem? Many thanks.


#2

@Campbells Welcome to the forum! If you could open and edit the RAW2 files, then RT should be able to handle them properly. I don’t know why you cannot save your results however. I would suggest that you provide a sample file and its pp3 for us to examine.


#3

Thanks for taking an interest. Here is a .RAW2 file and its .xmp sidecar (if I understand this correctly)
I will need to send them in two separate posts apparently, as I am a new member of the forum:
_1010753.RW2 (22.5 MB)


#4

Here’s the sidecar.:
_1010753.xmp (4.0 KB)


(Mica) #5

If the rw2 file opens and looks OK, then it is likely supported, per the RawPedia article.

RawTherapee produces a sidecar file with the extension .pp3, not .xmp.

Are you sure you have write permission to the location where you’re trying to save the image?

Which version of RawTherapee are you using? On which operating system?


#6

Hi @Campbells & welcome!

Your image opens just fine - and can be saved without any problems.
What Operating system are you on?
Exactly what steps do you perform to save a file?

Have fun!
Claes in Lund, Sweden


#7

Looks like it is from Photoshop. We would like a copy of RT’s pp3 sidecar. Thanks.


#8

That’s good news, Claes. I am using RT 5.4 on Windows 10 PC. In attempting to save the file I open, then make a small adjustment in the “Exposure Compensation”, then press Control/S, I accept the name given to the file and have tried saving as .jpeg, tiff and png, but each leads to the error message.
I attach a screenshot of the “save” dialogue box:

I cannot give a pp3 file, as afre requests, because I cannot yet save from RT!
Thanks again for your help.


(Ingo Weyrich) #9

Does it work when you try to save into a different folder (which is not opened in RT file browser)?


#10

A different problem. I downloaded and launched 5.4. I pasted the path of my folder (with the file, from another partition) and RT crashed. Tried again. Same result.


#11

No. It makes no difference.


#12

There is a progress bar at the bottom of the RT Screen called “Ready” that reports "“amaze deomosaecing” (something like that) whilst it is attempting to save the image, and then I get the error message.


(Ingo Weyrich) #13

More informations please. I just pasted the path of my folder Z:/H2/rt54/build/ and RT didn’t crash…


#14

@heckflosse I am not ready to do a backtrace. I tried opening other folders and RT didn’t crash.

Anyway, I just opened the folder without the RW2 and RT crashed. Maybe another file is doing this… I will find the culprit later. Folder contents:

image


(Ingo Weyrich) #15

most likely one of the png files


(Karlheinz Lehmann) #16

The .pp3 is automatically saved in the same folder as your raw file … together with the raw file the developers can try to figure out whats wrong


#17

OK. I understand that RT creates a .pp3 file when you save a processed .RAW file. However, I have yet to be able to save a processed file from RT, so have no .pp3 files to post.
I used to use Adobe Camera Raw, and there were no .pp3 files to be seen, only .xmp files, which I now believe carried the meta-data. (I hope I’m getting the picture)
Anyway. Unfortunately I still cannot save images from RT.
Any other guidance would be gratefully received.


#18

Good morning (local time),

I just downloaded RT 5.4 WinVista_64 onto a
Win 10 Pro 64b partition, then fetched your RW2
into the Download folder, fired up RT, opened
your image and hit Ctrl-S.

RT suggested to save the image as a JPG in the [User]/Pictures folder.
OK.

It worked just fine!
I also tried to change receiving folder to something else, like
…Downloads and I tested to save it as a TIFF as well.
It also worked fine.

Now, how to get out of this soup?
Might you be on a 32bit machine?

Sincerely,
Claes in Lund, Sweden

PS: When you get it all working, play with applying
“Auto-matched curve - ISO Low” and see what nice
effects that setting has.


(David Wilson) #19

Campbells,

No, you still have not understood what is happening. RT creates the ,pp3 file when you open the raw file, in the same directory as the image file. It does that even if you do no editing. You do not “save a processed raw file” at all. Any edits that you make are saved in the .pp3 file that has been opened.

The only explicit “saving” that you do is when you export the raw file as a finished image as a jepg, tiff ect. file.

Do a test, open a new raw file. Then close RT, you will find a filename.pp3 file in the directory. If you examine the .pps file in a text editor you find it lists all the RT defaults settings.

I have the similar TZ110 camera, and I am using it happily with RT.


(Karlheinz Lehmann) #20

Do you mean the protected path in “ProgramData”? Well there RT can’t save a .pp3 file. Put your raw file into “Downloads” or something which belongs to you and then try it again please…

And you don’t need to save a jpeg to get the pp3 …