Captions sometimes saved in raw, sometimes not

Can someone please explain why my captions sometimes are saved for my raw files, but sometimes not? Tags are saved, but the captions sometimes don’t show. Captions are saved for jpegs, of course. Thanks.

Now you see 'em:

Now you don’t:

The same applies to a question:

Are you using the latest version which 6.0.0? It would be helpful to see the terminal output when this is happening. If you write metadata to xmp sidecars please try renaming the sidecar to something like sidecar.xmp.backup and try again.

Yes, 6.0.0

Where do I find the terminal output?

Should I rename the sidecar using Windows Explorer to test this idea? (It’s the only way I know of.)

Thanks for your patience.

On Windows you would need to install DebugView, launch it and then launch digiKam. DigiKam will be printing there everything it is doing similar to the way it does in terminal on linux.

I’ll look into getting DebugView.

But first, isn’t this just a user error? I assume I’m doing something wrong, that perhaps I don’t have a setting checked correctly or something.

Not sure.

Did you group JPG and RAW before adding a caption? In other words, did you add a caption to a single image or to a group of images?

I highlighted jpgs & raws that could share the same caption, typed in the caption in the right pane, then hit Apply. That worked fine for awhile.

I can add captions to some raw files, but not others. I captioned this raw file just now:

If you select both ARW and JPG - right click - group by filename and then click on the group - add a caption. Does digikam ask you whether to apply changes for each file or only to the one which is on the top of the stack?

It doesn’t ask for a choice. It only captions the jpg when captioning the filename group.

This is odd too: I can save a Title for the raw file, but not a caption.

Perhaps I’d better figure out how to use DebugView.

Another piece of the puzzle: in some albums, raw captioning works fine; in other albums, can’t caption (but can title, tag, & star rate).

DebugView is very easy to use.

Hope this was okay, but I cleared the DebugView log, then attempted to write a caption to a raw file in digiKam. So this should just show what happens during a failed caption attempt:

Here is the output for a successful raw caption:

Are these of any help? The Dublin Core description field in XMP is blank in the unsuccessful raw caption, but contains text in the successful raw caption.



And here’s another place that text is not being written to:
IPTC data:

If I open the XMP file in Notepad, and type in:
<rdf:li xml:lang=“x-default”> Ferry view on the way to Shelter Island; eastern Long Island Sound</rdf:li>

the caption shows up in the raw file thumbnail in digiKam. Don’t want to do this for several hundred raw files, though. :frowning_face:

You are using digikam version 6.0.0, right? Just confirming. Have you tried deleting / renaming xmp sidecar and add captions again?