Compiling Luminance HDR in Linux

The script handles compilation and updating git.
Getting the dependencies is up to you.

  1. Download the script:
    wget https://raw.githubusercontent.com/pixlsus/Scripts/master/build-lhdr
  2. Make it executable:
    chmod +x build-lhdr
  3. Run it:
    ./build-lhdr
    Done.
2 Likes

Great script! Thanks for that! (I see now that I’m quite late for this party, but… oh well.)

For fellow gentooer’s, the Qt depencies that I needed (I had nothing from Qt before) were as follows:
dev-qt/qtconcurrent dev-qt/qtcore dev-qt/qtwidgets dev-qt/qtwebengine dev-qt/qtxml dev-qt/qtsql dev-qt/qtsvg dev-qt/linguist-tools dev-qt/qtprintsupport dev-qt/qtdeclarative dev-qt/qtwebchannel dev-qt/qtgui dev-qt/qtdbus dev-qt/qtnetwork dev-qt/qtxmlpatterns dev-qt/qttest

Don’t forget to add the “widgets” USE flag for dev-qt/qtwebengine :slight_smile:

There is a script to compile it from source in our github repo, contributed by @Morgan_Hardwood.

Pull requests are accepted if things aren’t working for you!

Script updated.

1 Like

Script updated, now subsequent re-compilation of a given branch and build-type will be faster.

1 Like

Hi, I’ve tried downloading the script using the instructions above, only for the following error to come up:

brian@Giger:~/Downloads/Graphics/LuminanceHDR$ ./build-lhdr
./build-lhdr: line 7: syntax error near unexpected token newline' ./build-lhdr: line 7:

Not sure whether this is an issue with my system or not. I’m running Ubuntu Mate 17.10

@Brian_Innes

  1. Have you tried starting over?
  2. Which shell are you running?
  3. Paste the sha256 of the file.
    $ sha256sum build-lhdr
    d4992bb73c0fd8e70fc00e33904877c5313fe533ed5d08e31981ce7131ca9afb  build-lhdr
    

Thanks Morgan, I think the script must have got corrupted when I downloaded it as this is the output from the sha256sum:

a91c3456b8d88a36bc26861064f5d5a811e297d017541b38e1e7217d83eac08b build-lhdr

Will redownload!

The script has worked this time. I think the first time I downloaded the script by right clicking on the link on my web browser, rather than downloading via wget.

But redownloading, and I now have a working Luminance HDR 2.5.2-Snapshot*

Thanks again, @Morgan_Hardwood :slight_smile:

2 Likes