Confused with masking settings in 4.6

I just noticed a change in my available masking settings since going from 4.4 to 4.6 (although the upgrade may not be the cause of my issue).

In ColorBalanceRGB, when I try to set a parametric mask, it is now giving me selections for HSV, whereas I am used to Jz, Cz, and hz. I checked the documentation, and Jz, Cz, hz is for scene-referred RBG color space. I checked my main processing settings, and they are indeed set to scene referred.

I am completely unaware of anything I may have done to cause this change. What do I need to do to get my mask selections to go back from HSV to Jz, Cz, hz?

Hmm I get g R G B Jz Cz Hz by default, but if I change the blend colour space (using the hamburger in the blend options) to “RGB (display)” I get g R G B H S L.

1 Like

That fixed it. Like I said, I am unaware that I ever might have changed that setting, but that’s life. Thank you very much.


Any chance you edited that image in the past or with the settings on none in preferences for a time anyway…

If you dont’ have a scene referred processing setting then the masking defaults to display when you start an edit and than might have been carried along from an older edit??

As I said in the top post, I went to my processing settings and it was set to scene referred, as intended.

As to the “carried along from an older edit”, it was a freshly downloaded raw file from this site. And I have always had the mask setting choices of Jz, Cz, and hz, before. I thought something had changed in 4.6 when it presented me with the choices of H, S, and L.

IDK how or why this happened, but it is fixed, now, as I told @elstoc

All good I thought since you mentioned 4.4 there might have been something carried forward from the past but as you say it’s a new edit


Well, maybe not. I freshly downloaded another raw image file, went into ColorBalanceRGB, and started creating a parametric mask. Once again, the choices were H, S, L. Going to the hamburger menu and selecting “RGB (scene)” fixed it again. Processing is still verified to be scene referred.

So I am still lost as to why it is acting this way.

PS - If I select “reset to default blend colorspace”, it will also set itself to “RGB (scene)”.

My mask settings are still always starting as H, S, and L (Display referred) instead of Jz, Cz, hz (Scene referred), even though my Processing in main settings is still set to Scene referred. AFAIK, this never happened until release 4.6, but I really don’t know why it is happening.

Any help or advice on correcting this will be much appreciated.

No chance you have an auto preset running??


Raise an issue on github

My processing Settings are scene-referred. When loading a previous edit, the filmic module kept on defaulting to activated even when I deactivated it in the darkroom. I tried deleting the xmp and again it was activated when reloading the photo. I check the auto preset and it was not running. It was only when I loaded a new photo to edit that the filmic started running as per my setting, deactivated.


Well, not on purpose, but I’ll have to research that and post back.

Hmmm. I was looking to see if any preset was in effect, and there is nothing I could see that indicated that one was. But, in trying to find out to see which if any preset was selected, I clicked on “basic solorfulness: standard”. I still could not see whether any preset was set, but I brought in a new raw file and the ColorBalanceRGB module was now set to scenic and Jz, Cz, hz masking.

Yes, it is entirely possible that I fumble-fingered my way into a different preset sometime in the past. But from what I just went through, there is no feedback from that Presets menu that would let me know the current status of any presets in effect.

Thanks very much for leading me to what appears to be the solution.

This is from the documentation:

preset list
A list of the presets available for the current module. The currently selected preset (if any) is shown in bold and with a small check mark beside it.

Hmmm. I was not seeing that when I wrote the previous post, but now I am. WTH is going on?

Hopefully this is it…you can’t change any of the default presets that come with the install as part of the software but if you just accidentally check auto when creating or editing a preset it might be applied and even can be applied disabled…

You should be able to find any culprits by looking for the check marks in the preferences preset section for any particular module… if so you can just go in and edit that preset and uncheck the auto option… hopefully its something simple like this…

1 Like

The point that I was trying to get across, not too well I’m afraid, was no matter what I did, the filmic module was activated when I loaded a photo for editing again.

Disable filmic in the darkroom
Delete xmp
Disable the auto preset
Revert to “original” in history and reload the photo in the darkroom with no auto preset.

I seemed like once filmic was activated there was nothing that I could do to deactivate it permanently for continuing edits in and out of the lighttable. Only when a new edit was loaded into the darkroom would the filmic, not set to auto, stay deactivated.

I think there may be a bug… I’m only here now so I will build the latest and test…

If preferences are set to scene sigmoid I get sigmoid active and filmic deactivated added… If I have it on filmic I get two instances of filmic…one inactive and one scene default…

I get this if I make a duplicate original or if I compress to original… …

EDIT… I had to scroll off to the right. Two instances of presets were checked I just missed that as the check marks were hidden…

Once I remove them all is normal…maybe check that??

Not sure what you mean by this, sorry!

Anyway, your better at this than I am so hopefully you will figure out what’s happening here. I would like both filmic and sigmoid off by default, so I can choose which one I want.

1 Like

That’s how my setup works, but I don’t know why. I like it that way, too.

1 Like

Well, Tim. Please let us know if you ever do find the “why”.