darktable and RawTherapee both unresponsive in W10 - suspected cause: wacom tablet

Been recommended here, apologies if this is not the right place for this post. Fairly new user to PP software and raw files. I recently installed Darktable 2.6.3, initially for use with GIMP, and later RawTherapee 5.7 to try out. Both initially worked, but I didn’t use them much at first.
Went to play a bit further on the weekend, both programs start (separately) but then I can’t do anything else. The user interface very occasionally responds to a click, but is otherwise completely unresponsive on both programs.
Darktable will start from GIMP and open a raw image. The user interface still doesn’t respond, but it passes the image to GIMP when I close it. It sometimetimes reports a lock file/PID issue.
RawTherapee opens an old jpeg from when it last worked, but i can’t edit.
Running Win 10 Pro with all recent MS updates.
Uninstalled and re-installed latest version of both programs but no change.
Looking for some advice on how to resolve this, or identify known conflicts. Any advice appreciated.

@malcolmbebb Welcome to the forum! Changed the category and added a keyword for you.

Let’s clarify a couple of things first.

1 Where did you download these respectable apps? And how did you install them?

2 Do dt (darktable is spelt without a capital D) and RT run when launched on their own? Does this only happen when you open your raw file from GIMP, which then calls either?


  1. Both downloaded from “official” sites (can’t remember urls) and installed by running the normal installer. All normal.
  2. Initially, both started correctly and worked, started from start menu. dt has been on computer a while, initially 2.6.2 installed around May. installed RT a few weeks ago.
    At weekend, started both from start menu. Think I tried RT first, gave up and tried dt. Then started dt from dos box with same outcome. Then started dt from GIMP, opened selected image but UI unresponsive as above.
    Recently I had installed Capture One (temporarily), Affinity (paid), FastStone and Silkypix, probably in that order, but due to work/hols didn’t really get to really try them out. Failing other ideas I will try uninstalling them of course. Also have PS Elements installed but that was happily coexisting with dt at least.
    (Wasn’t impressed with Elements, planned to use Affinity but doesn’t do raw hence RT, Capture One and Silkypix just to try.)

Check Windows Defender/your antivirus.


– Ignore the registry advice if you don’t know what that is.

– dt and RT both have config or preference folders. If you don’t care about your settings, labeling and database, deleting them may help solve app issues. When in doubt, read the manuals.

What’s your machine configuration?

Did you exit each one before trying another?

@malcolmbebb RawTherapee works fine in Windows 10, so the problem you’re experiencing is likely specific to your machine’s state. I’ve heard of programs locking up when you connect a network drive or external storage (XD card or other) and then remove it, and the mount point remains but the device or location are no longer there - check this, remove those mount points or locations, then try again.

It would help if you recorded a video of the problem.

Machine is <2yr old mid range desktop, 8GB RAM and rarely more than 60% in use. Don’t have full spec to hand. Hardware configuration hasn’t changed since programs worked.
Tried each program separately.

Can you move your mouse around and do other things, include manipulate other programs?

Clutter may be your biggest problem. One to all of these apps may have processes running in the background that you don’t know about from W10 startup onward. Then there is registry hell. All this can cause instability or rob you of the resources you need to run any program, including something as trivial as the calculator, if you aren’t careful!

After a bit more elimination and some luck, the Wacom One tablet seems to be the issue. If I start either application and only use a mouse, they seem to work normally.
If I use the tablet I get some variable results but when it works at all it very quickly stops working. Sometimes I can switch to the mouse, but sometimes it seems to hang the mouse also and I need to restart the program. I had previously tried with the mouse, at least on dt, to no avail.
Appears similar on both (without exhaustively testing) - maybe some common code somewhere? Unclear why I didn’t see the issue earlier.
One possible hypothesis is that I also had an older unused Wacom Graphire tablet connected, which I disconnected very shortly before seeing these issues. Maybe Windows loaded a different driver. It’s tempting, but I guess it should work correctly with this tablet also. Will try replacing it, but that’s it for this evening.
I can’t use the mouse for more than a few minutes due to historical RSI, so I need a resolution but at least I have a way forward.
Thanks for all the support.

It could be Windows trying to find and install the right driver. Sometimes that can slow everything to a grinding halt. It could also be that any number of your apps are trying to communicate to the same device or confused about what the device is supposed to be. Until you find out exactly what the problem is, I suggest that you keep it disconnected and make sure you ejected or disabled it.

I’ve been having serious wacom driver issues on my SO’s Mac as well. Like… The driver doesn’t work well and grinds the whole system to a hault. Bad times.

Ok, further update. Installed the very latest Wacom driver, no difference.
Dug out my elderly Graphire pad and both dt and RT work perfectly with it (unless both are running at the same time).
Same driver, new graphics pad (CTL-672) and old one (ET-0405A-U) both connected, one works, the other doesn’t. But both work in everything else I’ve tried.
Ho hum. Probably leave it there now.