DarkTable: does not detect any external device_importing

darktable

(Matteo Bertolino) #1

Dear all,
I am a new DarkTable user, or at least I would like to be one.
I would want to switch from LR, but with the problem I am encountering I won’t be able. At all.
I am running version 2.4.0 de DarkTable and an iMac with 10.12.6

As simple as this: The program does not detect my external hard drives, none of them. There is no way. I have been googling the issue for some time but there seems not to be any solution at the moment (nor many people talking about this problem, which is also kind of strange!).

The only location it allows me to navigate within is the internal HD of my Mac.

Being this the problem, I cannot use the software, as ALL my images are stored on external hard drives.

Anyone can help? Am I the only one with this issue??

Many thanks in advance.

Best,
M.


(ಚಿರಾಗ್ ನಟರಾಜ್) #2

Oh, are we switching to this post now? I’ll post the same thing here then. Let’s make sure darktable is able to actually open the location where the external disk is mounted.

  1. Use mount to figure out where the external drive is mounted.
  2. Try browsing to that location using the “import from folder” dialog.

If you’re able to access that location, then there’s something weird going on.


(Roman Lebedev) #3

(Matteo Bertolino) #4

:ok_hand:


#5

@LebedevRI You need a bot to automatically correct people :wink:.


(Peter Cripps) #6

Matteo, you should be able to access external drives. I do this all the time from my windows installation of darktable. All my photos are on an internal drive on my Linux machine. The key thing is that the external drive must be mounted. Simply browsing for it won’t work.

At least, that’s what I found after quite a bit of frustration!


(ಚಿರಾಗ್ ನಟರಾಜ್) #7

It is mounted though, that’s the weird thing. Also, it was solved in this thread :slight_smile:


(Karl Liebethal) #8

I installed darktable version 2.4.3 in windows 10 newest release in 64-bit machine and had exactly the same problem. All mein photos are on E:, an internal drive. So I deinstalled the version 2.4.3 and installed version 2.4.2 and look: I can now import files from every drive on my pc. It looks to me, that a part of the code has been lost. Now I hope, that the developer will find the code or what ever the bug may be, because darktable seems to be a very good software to me.
Many thanks in advance.
best, carlo13


(Mica) #9

@carlo13 I believe this is an issue with GTK, the toolkit for darktable. We are waiting for them to fix it.