darktable does not open, please help!

When I press the darktable icon to open it, it does not open, just nothing happens. I tried several things but nothing works. Anyone has an idea of what can be done to solve this; I need it and I can’t use use it, please help. Thanks in advance.

You can take a look at the FAQs section on the website, which details how to find the log on windows. We need that log.

Also the version of darktable, OS, openCL status & hardware.

1 Like

what operating system, what version and was it working before and has now stopped?

1 Like

Bit more context…this happened on its own… or have you recently made any changes to your system updates etc… and of course as the others noted which version of DT and OS etc…

1 Like

I’m in Windows 11 23H2; darktable 4.4.2.

1 Like

I’m not sure, I have Windows updated but I think I have already used darktable after the last update.

I’m remembering something. I think it was the last time I was able to use darktable, I had my external USB drive plugged in and it didn’t open. Because it had already happened, I unplugged the drive, tried again and darktable opened normally.

Please find the log and post it.

1 Like

The log @paperdigits mentions would be the most helpful… you could also backup all the files in your Users\username\appdata\local\darktable folder…keep them safe and then delete them in that folder… try running dt again… if it runs then you have some corruption in your config files. You could try then to restore your original files and try using one of the backups of your database that DT makes maybe the one right before your external drive issue… But the log would be the most informative targeted way to approach it…

1 Like

Maybe darktable won't open; Magick: caught exception 0xC0000005 Access violation · Issue #15686 · darktable-org/darktable · GitHub ?
Also: I can't get Darktable to work anymore

SOLVED! It was as simple as uninstall the OpenCL Compatibility app in Windows, as said in faqs in darktable website. Thanks a lot to all, specially to you.


Excellent, enjoy. And thanks @g-man for the windows FAQ stuff (I think)

1 Like

For darktable 4.6, I think I managed to disable the microsoft GPU by default, so we wont need to do this step.