darktable for Windows

windows
darktable

(fullchromeflex) #241

After some more testing I think Ive just got confused by the look of the popup. So its not a bug. :sweat_smile:


#242

I get this error on start-up.

darktable_bt_6AJ79Y.txt (4.9 KB)

Windows 10, 64-bit, Intel i7-2600, 16 GB ram.


(fullchromeflex) #243

Looks like it fails at using opencl.


#244

I have an AMD Radeon HD 5450. Maybe I was better off with an Nvidia card? Those seem to be favored by shader developers lately…


#245

Please try again with the latest installer, version 2.3.0+1049.


#246

That works perfectly. Thank you.


#247

Would it be possible to remove the older versions of the installer or the links to them from here?


#248

Good idea, I edited all my old posts and removed the links. The installers are all still available in https://pixls.us/files/ and I prefer to keep them there.


#249

Is there any way to see the filenames on top of each thumbnail in the lighttable view (I only see the thumbnail itself, the star rating and the filetype?
I found https://github.com/darktable-org/lua-scripts/blob/master/official/generate_image_txt.lua but as a total noob I really have no idea how this could help/work or what exactly to do.


#250

Have you checked the readme file here: https://github.com/darktable-org/lua-scripts/blob/master/README.md? That describes how to install lua scripts - even for Windows.
BTW that particular lua srcipt won’t work even when properly configured, as it requires an installed exiv2. If you install exiv2, and set the command line option properly, then it will generate the txt sidecar files with file names as intended, but that won’t display the content of those files in the lighttable view


(Gareth Williams) #251

First of all, thanks for a great port. I’m an avid Linux user and have been using DT on it for a few years. However, I find the Windows version far more stable.

I do have a question though. Has anyone successfully managed to use a network share for storing the imported images?

I’m trying to keep my photos on a NAS. I’ve tried by mapping a drive to the share (e.g. P:\ drive) and altering darktablerc to point to it but that failed. I next tried using a directory symlink so that my Pictures folder is mounted on the share, but that failed too.

In both cases I end up with imports going to corrupted path - Darktable$(YEAR)1126_noname instead of Darktable\20171126_noname.

Is this a bug, or am I doing something wrong?


(Peter Cripps) #252

I may have discovered a bug in the output module. Under “storage options” you can click on a folder icon, and then navigate to your desired folder. In my case, what appears is:

C:\users\peter\Pictures\Exports

The backslashes are of course a Windows thing. But attempts to export to this destination fail. The fix I have found is to replace all the backslashes with forwards:

C:/users/peter/Pictures/Exports

This works perfectly.

P.S. I wonder if this has anything to do with Gareth’s problem above?


#253

Thanks. Then I will forget about it.


#254

That was fixed a while ago. Please use a newer installer. Actually, you can try the brand new 2.4.0 rc0.


(Peter Cripps) #255

Thanks, 2.4.0 installed and all is good!


(Marcin) #256

First Run are fine. Let’s test it hard :smiley: Thank you!


(Jason Stainthorpe) #257

Hi, I have a general question about the time it takes to save a raw file to tiff. It takes over 5 minutes to do this, would this be due to the size of the raw file and it being saved as a uncompressed tiff or is it more likely that my system is getting on a bit and isn’t the highest specced out there. It is a HP with a A6 processor and 8gb of ram. I have tried using the compression options when saving to tiff with no difference in the time taken to save. It doesn’t take as long to save as a JPEG but I like to use tiff for further processing in PS if needed. Other than the slow save time Darktable is everything I need and I really like it
Any advice is appreciated

Cheers

Jason


(Mica) #258

@JStain Are you using the latest version: https://github.com/darktable-org/darktable/releases/download/release-2.4.0rc0/darktable-2.4.0rc0-win64.exe


(Jason Stainthorpe) #259

@paperdigits Yup, I actually grabbed that one this morning and installed it. Still takes the same amount of time to export

Cheers

Jason


(Mica) #260

What version of windows and where are you exporting to?