darktable for Windows

windows
darktable

(Jason Stainthorpe) #261

It is Windows 10 64bit and I export to a folder in Pictures


(darix) #262

could you share a raw + xmp file that take so long to export? also more details on your machine would be good. cpu/gpu and so on.


#263

I just tried this briefly and in a VM, but it seem I can confirm that TIFF exports are extra slow.


#264

I am a very happy user of Darktable for Windows (Win 7, 24 GB RAM, i7 3770), but I have run into an annoying difference with the Linux version that I use as well.
I have a large collection of DNG’s (pre 2013) from my old D80, imported back then into Lightroom. Now, Darktable on Linux has no issue to open them, but on Windows I get frequent skulls and glitched images in my lighttable and am unable to open most of the files because “failed to read camera white balance information from …”.

Any idea what might be going on? Is this just me? The behavior occurs even with the recent 2.4.0 build.
Here’s a sample picture that does not load, if anyone wants to test: DSC_0143.dng (7.9 MB) (CC0)

Please let me know if I need to supply more information! Many thanks for any replies :slight_smile:


(Jeff) #265

Thanatomanic it’s not just the windows build. The same issue here unfortunately in Linux build 2.4.0rc0+6~g7a91f41c6 using your sample image.


#266

Oh, ehm, my Linux version is 2.2.5 and I have no issues there. So, some regression happening?
I’ve just tested and the original 2.3.0 Windows version has the same problem.


(Rick Davis) #267

I tried on my Windows 10 pro computer, i5/8 gb memory) which is fairly old, I had no delay in converting to tiffs. Seemed to take about 2 seconds no matter how many bits 8-16-32 didn’t seem to be a problem. DT was quite rapid in the conversion. My camera is a Canon 7d, so not huge raw files.


(Jason Stainthorpe) #268

@darix Sure, the raw files are fuji RAF which are quite large, I have linked to a google drive folder that has the raw and xmp. My PC details are AMD A6 -5400K APU with Radeon HD Graphics 3.60hz, 8gb RAM and is 64 bit windows 10.

https://drive.google.com/open?id=1IGfFP_eLsjjSid_BXTwmJcteW04dfVal

Cheers Jason


(Rick Davis) #269

I downloaded your file, did some minor edits, and had no problem saving it as a 16 bit tiff. Took about 3 seconds.

I don’t know if I’ve read all your posts, but wondered have you tried a delete, reinstall of DT?


(Jason Stainthorpe) #270

@rd52 I had not completely uninstalled previously. I have just done so and deleted anything I could find Darktable related and reinstalled. The results are the same, I am a bit suspicious of my HDD though, I am going to try the laptop and see how that goes

Edit - tried the laptop with exactly the same results, it also is a HP

Cheers

Jason


#271

@JStain Also jumping in. What about your HDDs are you suspicious about? I suppose you could do install an app that divulges some of the drives’ metadata to see if they have enough wear and tear to warrant replacing. Hard drive failure is not enjoyable!


#272

It’s a known regression in rawspeed that is being worked on: https://github.com/darktable-org/rawspeed/issues/100

Until that is fixed you better stay with 2.2.5. And for the future, don’t convert raw files to DNG, that causes problems eventually.


What happend with my Dual ISO files and darktable?
#273

Thanks for the reply, good to know it’s being worked on! I couldn’t find a meaningful issue in the tracker.

And yes, I have seen the error of my ways a few years back and don’t convert to DNG any longer.


#274

It might help if you could add such a file to raw.pixls.us with a CC0 license. That way we will know when it’s being fixed and if it ever breaks again when running automated tests.


(Jason Stainthorpe) #275

Just some things that are starting to happen a bit, like the system locking up, disk running at 100% for unknown reasons. I did run a disk test utility but it timed out because it was taking so long


#276

While OpenCL speeds up darktable noticeably even on a laptop with only the integrated Intel’s GPU, it became unavailable after a Win10 update, that included the graphic driver. Installing the latest driver from Intel’s website made it work again. Just in case …


#277

My integrated Intel HD4600 doesn’t get used by dt. It is used by Capture One or DxO Optics Pro. I’m on Win 8.1, with the last version of Intel drivers for that GPU.


(Rick Davis) #278

On my computer, a W10/ i5/ 64/ 8 GB memory, with a NVidia Geforce 620. When I check the OpenCL option in preferences DT is noticeably slower. Is there any way to speed it up short of a new video card? The NVidia card’s drivers are current. Does anyone have a hint?


#279

Please run the OpenCL test:
"c:\Program Files\darktable\bin\darktable-cltest.exe"

And share the output of that.


#280

@sankos: darktable for Windows