darktable for Windows

windows
darktable

#281

Seems the same for me, Dell XPS 15 with integrated Intel HD630 and Nvidia Geforce GTX 1050. Here’s the output from the cltest:cltest.txt (53.2 KB)

Also, I noticed a bug regarding preview view.
If I watch an image in preview mode (pressing Z) after I have worked on it, the preview got some problems: the image is blurred, or the colors are inaccurate. Otherwise, freshly imported files are visualized in the right way. Any way I can help in that?


(Rick Davis) #282

here’s the file. Let me know if this helps or is what you wanted. Thanks!
turned on-1.txt (27.2 KB)


#283

Right, Intel HD4600 – insufficient memory problem. I need to think of buying a gfx card. Does it matter to dt if it’s Nvidia or ATI?


#284

Hm, it looks like you disabled the OpenCL in the settings? Can you double-check it?
initial status of opencl enabled flag is OFF.


(Rick Davis) #285

Yes, OpenCL had a check in it. I ran the test again, this time with DT open and with the OpenCL option selected.DT check.txt (27.2 KB)


(fullchromeflex) #286

Is there a new build for windows around?


(Mica) #287

2.4 rc0 is the latest and is on the github page.


(fullchromeflex) #288

Thank you. I thought houz would update the link in the first post. But maybe not for RCs.


#289

This looks to me pretty OK, it looks like OpenCL is working with dt on your machine


#290

Right, I added the link to the release announcement to the 1st post.


#291

I have the same output, saying at the end that the geforce card is not utilized; in fact, opening the windows task manager it doesn’t show darktable using the GPU, while for example if I open CaptureOne the latter is listed as using it.

I’ll try to clean reinstall nvidia drivers, since just after doing I got a different output from the opencl test, but then it reverted

EDIT: nothing, same output saying that the graphic card is not utilized


(Rick Davis) #292

I did install the newest Nvidia drivers, did a clean install and there is no improvement. When doing edits without OpenCL used the edits are instant. With it is activated the edits become painfully slow. It is very evident when doing noise reduction at 100% view.
I again ran the OpenCL test again and included it here. I also installed GPU-Z which shows the state of my gpu, I’ve included those results also. You can see by it that OpenCL is active on my computer, but when it is activated in DT it is definitely not an aid to speed. Looking at task mgr. when doing edits, my gpu is using the same amount of resources whether I have OpenCL in DT checked or not.

DT check-2.txt (27.2 KB)


(Christian Kanzian) #293

I had the same with a GT640. I think it is all you can get out of it. Playing around with different opencl settings did not changed anything.

Cheap nvidia cards are simple slow. You will experience that especially with profiled denoise with local means or the equalizer.

Here are some benchmarks with newer cards: https://www.phoronix.com/scan.php?page=article&item=darktable-opencl-gpu&num=3


#294

Hi @rd52 and @Marco.Djallo, that last line of the log is misleading, you can ignore that, check out this place:
https://redmine.darktable.org/issues/11066

All the log is saying that OpenCL is available on your machine, and it has successfully compiled the OpenCL kernels, so in theory it should work.

You can find more information on dt and OpenCL here:
http://www.darktable.org/2012/03/darktable-and-opencl/

if you experience performance problems, I’d suggest to start darktable (not the cltest utility) itself with the following command line parameters (pls enable OpenCL before):
darktable -d opencl -d perf

And try to edit the picture with the module which you have problem with. After that please share the output of the log, which you can find here:
C:\Users\[username]\AppData\Local\Microsoft\Windows\INetCache\darktable\darktable-log.txt


#295

Thank you, as of now I have no issues with modules, I was just thinking that darktable wasn’t using my GPU.

I have issues with previews in lighttable, they randomly appears in low resolution as you can see there

anything I can do to help you debugging this? I’m still not able to understand what conditions cause that


(Rick Davis) #296

Peterbud, ran the command line parameter as you suggested, ran DT with OpenCL selected, but I could not find the log. There was no INetCache folder in either of my user accounts. Looked everywhere I could think of where it might be, just could not find it.

Just seems quite odd that I get much quicker edits with OpenCl off.


#297

What is your OS: Win 10 or Windows 7?


(Rick Davis) #298

Windows 10/64/pro


(Christian Kanzian) #299

Did you start darktable like that?
"C:\Program Files\darktable\bin\darktable.exe -d opencl -d perf"

For me with Win 10/64 the output is written to the place which @peterbud mentioned:

You get what you paid for and your GPU is simple to slow. Usually the new openCl scheduler would/should turn openCl off if the GPU is slower than the CPU. Get something like a Nvidia 1060.


(Rick Davis) #300

Sorry took so long to get back to you Peter, couldn’t find it. Had to de-select the ‘protect files that can harm your computer’. I think this is the file that you’d asked for, thanks for your help, and sorry it took so long. Let me know if it’s OK.

dt check-3.txt (251.7 KB)