darktable for Windows

darktable
windows

#364

Awesome program! I really love Darktable for Windows. But I have the same issue. It takes about 5 minutes to export one RAW file to a TIFF file in Darktable on my trusty old Windows 10 Home 64bit Core i7 XPS15. Affinity Photo exports the same RAW file to TIFF within 5 sec. I use the latest Windows version of Dartable.


#365

Can you provide more information on this scenario:

  • Which TIFF export setting you were using (bit depth, compression)?
  • What was the original filename (path and filename) and what were the export storage option settings?
  • Which modules were applied to the image and with which settings?

Then we would need some perf data to collect:
Step 1: please delete the existing log file. You can find the log file here:
C:\Users\[username]\AppData\Local\Microsoft\Windows\INetCache\darktable\darktable-log.txt
Step 2: start darktable with the following settings:
c:\Program Files\darktable\bin\darktable.exe -d perf
Step 3: export the file in question where the export took so much time
Step 4: Close darktable
Step 5: Send/share the log file

That should contain something like this below, as you see it took 4 seconds to do a TIFF export:

[dev] took 0.104 secs (0.125 CPU) to load the image.
[export] creating pixelpipe took 0.135 secs (0.219 CPU)
[dev_pixelpipe] took 0.000 secs (0.000 CPU) initing base buffer [export]
[dev_pixelpipe] took 0.063 secs (0.000 CPU) processed `raw black/white point' on GPU, blended on GPU [export]
[dev_pixelpipe] took 0.031 secs (0.000 CPU) processed `white balance' on GPU, blended on GPU [export]
[dev_pixelpipe] took 0.016 secs (0.000 CPU) processed `highlight reconstruction' on GPU, blended on GPU [export]
[dev_pixelpipe] took 2.857 secs (0.000 CPU) processed `demosaic' on GPU, blended on GPU [export]
[dev_pixelpipe] took 0.219 secs (0.000 CPU) processed `base curve' on GPU, blended on GPU [export]
[dev_pixelpipe] took 0.094 secs (0.000 CPU) processed `input color profile' on GPU, blended on GPU [export]
[dev_pixelpipe] took 0.609 secs (0.000 CPU) processed `sharpen' on GPU, blended on GPU [export]
[dev_pixelpipe] took 0.125 secs (0.000 CPU) processed `output color profile' on GPU, blended on GPU [export]
[dev_process_export] pixel pipeline processing took 4.155 secs (0.000 CPU)

(Jason Stainthorpe) #366

Hi Peter,

I too experience this issue with exporting TIFF. In step 1 I have no INetCache within that directory. Would the log file be stored in a different locale. I have done a system search for it and it does not come up at all.
Also is there a way I can confirm that Darktable is actually using the GPU on the system, I have a 1GB ATI card that should be being used

Cheers

Jason


#367

Hi @JStain,
There is a directory called INetCache, just Windows Explorer is hiding it very well. Just enter into the Windows Explorer the path, and you"ll see it.

For checking whether your darktable is using OpenCL, see the FAQ: “How does the OpenCL support in darktable work on Windows?”


(Jason Stainthorpe) #368

Thanks Peter, that sorted it out.

Here is a link to a folder on Drive that has the log file and the RAF and xmp that was used to export as TIFF
I exported at 16bit and uncompressed

There is also a file that has the output of the opencl test

https://drive.google.com/open?id=1IGfFP_eLsjjSid_BXTwmJcteW04dfVal

Cheers

Jason


#369

Thanks Jason, it looks like this is good for a repro, Much appreciated.


#370

Sure! Here we go
 Oh, before I start: I have this problem with all RAW files I export as 16 bit TIFF. Oh, yeah! I also start Darktable with the “–disable-opencl” because I get error messages when I use Open CL.

Can you provide more information on this scenario:

Which TIFF export setting you were using (bit depth, compression)?
I used TIFF 16 bit deflate but it also happens with the rest of the TIFF compression settings or no compression. I used Adobe RGB. The rest standard.

What was the original filename (path and filename) and what were the export storage option settings?
Original path RAW:
F:\Canon\171218 Afsluitdijk
Export settings TIFF:
$(FILE_FOLDER)/darktable_exported/$(FILE_NAME)
Path exported TIFF:
F:\Canon\171218 Afsluitdijk\darktable_exported

Which modules were applied to the image and with which settings?
(Damn program is in Dutch have to translate everithing
 How can I get it in English?)

Outgoing color profile
sRGB (web-save)

Sharpening
2 - 0.5 - 0.5 and no masks

Contrast brightness saturation
0.1 - 0.0 - 0.14 no masks

Local contrast
120% - 100% - 100% - 0.2 and no masks

Shadows & highlights
Standard settings

Vibrance
75%

Incoming color profile
standard color matrix
gamma-clipping off

Basic curve
Same as Canon EOS

Orientation
Standard

Demosaic
PGP (fast) - 0.000 - off - disabled

Repair highlights
1.00 no masks

White balance
0.999 - 5320k - R=1.806 - G=1.000 - B=1.682 - preference: camera

Raw black/white point
All 512 except white-point = 11892

The log file after exporting RAW to TIFF:

========================================
version: darktable 2.4.0rc0
start: 2017:12:23 14:00:45

[dev] took 0,253 secs (0,266 CPU) to load the image.
[export] creating pixelpipe took 0,094 secs (0,094 CPU)
[dev_pixelpipe] took 0,000 secs (0,000 CPU) initing base buffer [thumbnail]
[dev_pixelpipe] took 0,000 secs (0,000 CPU) processed raw zwart/witpunt' on CPU, blended on CPU [thumbnail] [dev_pixelpipe] took 0,000 secs (0,000 CPU) processedwitbalans’ on CPU, blended on CPU [thumbnail]
[dev_pixelpipe] took 0,000 secs (0,000 CPU) processed hooglichten herstellen' on CPU, blended on CPU [thumbnail] [dev_pixelpipe] took 0,000 secs (0,000 CPU) processeddemosaic’ on CPU, blended on CPU [thumbnail]
[dev_pixelpipe] took 0,000 secs (0,000 CPU) processed oriĂ«ntatie' on CPU, blended on CPU [thumbnail] [dev_pixelpipe] took 0,000 secs (0,000 CPU) processedbasis curve’ on CPU, blended on CPU [thumbnail]
[dev_pixelpipe] took 0,000 secs (0,000 CPU) processed ingaand kleurprofiel' on CPU, blended on CPU [thumbnail] [dev_pixelpipe] took 0,000 secs (0,000 CPU) processedlevendigheid’ on CPU, blended on CPU [thumbnail]
[dev_pixelpipe] took 0,000 secs (0,000 CPU) processed schaduwen en hooglichten' on CPU, blended on CPU [thumbnail] [dev_pixelpipe] took 0,299 secs (0,266 CPU) processedlokaal contrast’ on CPU, blended on CPU [thumbnail]
[dev_pixelpipe] took 0,001 secs (0,000 CPU) processed contrast helderheid verzadiging' on CPU, blended on CPU [thumbnail] [dev_pixelpipe] took 0,000 secs (0,000 CPU) processedverscherpen’ on CPU, blended on CPU [thumbnail]
[dev_pixelpipe] took 0,000 secs (0,000 CPU) processed uitgaand kleurprofiel' on CPU, blended on CPU [thumbnail] [dev_pixelpipe] took 0,000 secs (0,000 CPU) processedgamma’ on CPU, blended on CPU [thumbnail]
[dev_process_thumbnail] pixel pipeline processing took 0,304 secs (0,266 CPU)
[dev] took 0,000 secs (0,000 CPU) to load the image.
[dev] took 0,000 secs (0,000 CPU) to load the image.
[dev_pixelpipe] took 0,024 secs (0,141 CPU) initing base buffer [full]
[dev_pixelpipe] took 0,022 secs (0,031 CPU) processed raw zwart/witpunt' on CPU, blended on CPU [full] [dev_pixelpipe] took 0,021 secs (0,000 CPU) processedwitbalans’ on CPU, blended on CPU [full]
[dev_pixelpipe] took 0,021 secs (0,000 CPU) processed hooglichten herstellen' on CPU, blended on CPU [full] [dev_pixelpipe] took 0,008 secs (0,125 CPU) processeddemosaic’ on CPU with tiling, blended on CPU [full]
[dev_pixelpipe] took 0,001 secs (0,000 CPU) processed oriĂ«ntatie' on CPU, blended on CPU [full] [dev_pixelpipe] took 0,001 secs (0,000 CPU) processedbasis curve’ on CPU, blended on CPU [full]
[dev_pixelpipe] took 0,005 secs (0,000 CPU) processed ingaand kleurprofiel' on CPU, blended on CPU [full] [dev_pixelpipe] took 0,001 secs (0,125 CPU) processedlevendigheid’ on CPU, blended on CPU [full]
[dev_pixelpipe] took 0,014 secs (0,000 CPU) processed schaduwen en hooglichten' on CPU, blended on CPU [full] [dev_pixelpipe] took 1,050 secs (0,656 CPU) processedlokaal contrast’ on CPU, blended on CPU [full]
[dev_pixelpipe] took 0,000 secs (0,000 CPU) processed contrast helderheid verzadiging' on CPU, blended on CPU [full] [dev_pixelpipe] took 0,000 secs (0,000 CPU) processedverscherpen’ on CPU, blended on CPU [full]
[dev_pixelpipe] took 0,016 secs (0,016 CPU) processed uitgaand kleurprofiel' on CPU, blended on CPU [full] [dev_pixelpipe] took 0,000 secs (0,000 CPU) processedgamma’ on CPU, blended on CPU [full]
[dev_process_image] pixel pipeline processing took 1,207 secs (1,109 CPU)
[dev_pixelpipe] took 0,000 secs (0,000 CPU) initing base buffer [preview]
[dev_pixelpipe] took 0,000 secs (0,000 CPU) processed raw zwart/witpunt' on CPU, blended on CPU [preview] [dev_pixelpipe] took 0,000 secs (0,000 CPU) processedwitbalans’ on CPU, blended on CPU [preview]
[dev_pixelpipe] took 0,016 secs (0,016 CPU) processed hooglichten herstellen' on CPU, blended on CPU [preview] [dev_pixelpipe] took 0,000 secs (0,000 CPU) processeddemosaic’ on CPU, blended on CPU [preview]
[dev_pixelpipe] took 0,016 secs (0,000 CPU) processed oriĂ«ntatie' on CPU, blended on CPU [preview] [dev_pixelpipe] took 0,000 secs (0,000 CPU) processedbasis curve’ on CPU, blended on CPU [preview]
[dev_pixelpipe] took 0,016 secs (0,125 CPU) processed ingaand kleurprofiel' on CPU, blended on CPU [preview] [dev_pixelpipe] took 0,016 secs (0,109 CPU) processedlevendigheid’ on CPU, blended on CPU [preview]
[dev_pixelpipe] took 0,031 secs (0,250 CPU) processed schaduwen en hooglichten' on CPU, blended on CPU [preview] [dev] took 0,000 secs (0,000 CPU) to load the image. [dev_pixelpipe] took 0,016 secs (0,125 CPU) initing base buffer [full] [dev_pixelpipe] took 0,031 secs (0,219 CPU) processedraw zwart/witpunt’ on CPU, blended on CPU [full]
[dev_pixelpipe] took 0,016 secs (0,125 CPU) processed witbalans' on CPU, blended on CPU [full] [dev_pixelpipe] took 0,031 secs (0,031 CPU) processedhooglichten herstellen’ on CPU, blended on CPU [full]
[dev_pixelpipe] took 0,016 secs (0,109 CPU) processed demosaic' on CPU with tiling, blended on CPU [full] [dev_pixelpipe] took 0,000 secs (0,000 CPU) processedoriĂ«ntatie’ on CPU, blended on CPU [full]
[dev_pixelpipe] took 0,000 secs (0,000 CPU) processed basis curve' on CPU, blended on CPU [full] [dev_pixelpipe] took 0,000 secs (0,000 CPU) processedingaand kleurprofiel’ on CPU, blended on CPU [full]
[dev_pixelpipe] took 0,016 secs (0,125 CPU) processed levendigheid' on CPU, blended on CPU [full] [dev_pixelpipe] took 0,016 secs (0,109 CPU) processedschaduwen en hooglichten’ on CPU, blended on CPU [full]
[dev_pixelpipe] took 1,812 secs (2,938 CPU) processed lokaal contrast' on CPU, blended on CPU [preview] [dev_pixelpipe] took 0,016 secs (0,047 CPU) processedcontrast helderheid verzadiging’ on CPU, blended on CPU [preview]
[dev_pixelpipe] took 0,016 secs (0,125 CPU) processed verscherpen' on CPU, blended on CPU [preview] [dev_pixelpipe] took 0,031 secs (0,094 CPU) processeduitgaand kleurprofiel’ on CPU, blended on CPU [preview]
[dev_pixelpipe] took 0,000 secs (0,000 CPU) processed gamma' on CPU, blended on CPU [preview] [dev_process_preview] pixel pipeline processing took 2,015 secs (3,766 CPU) [dev_pixelpipe] took 0,736 secs (1,828 CPU) processedlokaal contrast’ on CPU, blended on CPU [full]
[dev_pixelpipe] took 0,016 secs (0,016 CPU) processed contrast helderheid verzadiging' on CPU, blended on CPU [full] [dev_pixelpipe] took 0,000 secs (0,000 CPU) processedverscherpen’ on CPU, blended on CPU [full]
[dev_pixelpipe] took 0,000 secs (0,000 CPU) processed uitgaand kleurprofiel' on CPU, blended on CPU [full] [dev_pixelpipe] took 0,000 secs (0,000 CPU) processedgamma’ on CPU, blended on CPU [full]
[dev_process_image] pixel pipeline processing took 0,908 secs (2,688 CPU)
[dev] took 0,000 secs (0,000 CPU) to load the image.
[export] creating pixelpipe took 0,097 secs (0,188 CPU)
[dev_pixelpipe] took 0,000 secs (0,000 CPU) initing base buffer [thumbnail]
[dev_pixelpipe] took 0,000 secs (0,000 CPU) processed raw zwart/witpunt' on CPU, blended on CPU [thumbnail] [dev_pixelpipe] took 0,000 secs (0,000 CPU) processedwitbalans’ on CPU, blended on CPU [thumbnail]
[dev_pixelpipe] took 0,000 secs (0,000 CPU) processed hooglichten herstellen' on CPU, blended on CPU [thumbnail] [dev_pixelpipe] took 0,000 secs (0,000 CPU) processeddemosaic’ on CPU, blended on CPU [thumbnail]
[dev_pixelpipe] took 0,000 secs (0,000 CPU) processed oriĂ«ntatie' on CPU, blended on CPU [thumbnail] [dev_pixelpipe] took 0,000 secs (0,000 CPU) processedbasis curve’ on CPU, blended on CPU [thumbnail]
[dev_pixelpipe] took 0,000 secs (0,000 CPU) processed ingaand kleurprofiel' on CPU, blended on CPU [thumbnail] [dev_pixelpipe] took 0,000 secs (0,000 CPU) processedlevendigheid’ on CPU, blended on CPU [thumbnail]
[dev_pixelpipe] took 0,016 secs (0,000 CPU) processed schaduwen en hooglichten' on CPU, blended on CPU [thumbnail] [dev_pixelpipe] took 0,659 secs (0,344 CPU) processedlokaal contrast’ on CPU, blended on CPU [thumbnail]
[dev_pixelpipe] took 0,001 secs (0,000 CPU) processed contrast helderheid verzadiging' on CPU, blended on CPU [thumbnail] [dev_pixelpipe] took 0,002 secs (0,125 CPU) processedverscherpen’ on CPU, blended on CPU [thumbnail]
[dev_pixelpipe] took 0,001 secs (0,000 CPU) processed uitgaand kleurprofiel' on CPU, blended on CPU [thumbnail] [dev_pixelpipe] took 0,001 secs (0,000 CPU) processedgamma’ on CPU, blended on CPU [thumbnail]
[dev_process_thumbnail] pixel pipeline processing took 0,684 secs (0,469 CPU)
[dev] took 0,000 secs (0,000 CPU) to load the image.
[export] creating pixelpipe took 0,094 secs (0,094 CPU)
[dev_pixelpipe] took 0,000 secs (0,000 CPU) initing base buffer [export]
[dev_pixelpipe] took 0,031 secs (0,094 CPU) processed raw zwart/witpunt' on CPU, blended on CPU [export] [dev_pixelpipe] took 0,016 secs (0,016 CPU) processedwitbalans’ on CPU, blended on CPU [export]
[dev_pixelpipe] took 0,016 secs (0,125 CPU) processed hooglichten herstellen' on CPU, blended on CPU [export] [dev_pixelpipe] took 0,328 secs (1,562 CPU) processeddemosaic’ on CPU with tiling, blended on CPU [export]
[dev_pixelpipe] took 0,160 secs (0,703 CPU) processed oriĂ«ntatie' on CPU with tiling, blended on CPU [export] [dev_pixelpipe] took 0,098 secs (0,438 CPU) processedbasis curve’ on CPU with tiling, blended on CPU [export]
[dev_pixelpipe] took 0,266 secs (2,125 CPU) processed ingaand kleurprofiel' on CPU with tiling, blended on CPU [export] [dev_pixelpipe] took 0,063 secs (0,500 CPU) processedlevendigheid’ on CPU with tiling, blended on CPU [export]
[dev_pixelpipe] took 1,080 secs (7,359 CPU) processed schaduwen en hooglichten' on CPU with tiling, blended on CPU [export] [dev_pixelpipe] took 9,916 secs (17,078 CPU) processedlokaal contrast’ on CPU, blended on CPU [export]
[dev_pixelpipe] took 0,297 secs (0,719 CPU) processed contrast helderheid verzadiging' on CPU with tiling, blended on CPU [export] [dev_pixelpipe] took 0,379 secs (2,547 CPU) processedverscherpen’ on CPU with tiling, blended on CPU [export]
[dev_pixelpipe] took 0,503 secs (1,438 CPU) processed uitgaand kleurprofiel' on CPU with tiling, blended on CPU [export] [dev_process_export] pixel pipeline processing took 13,153 secs (34,703 CPU) [export_job] exported toF:\Canon\171218 Afsluitdijk/darktable_exported/_MG_7895_01.tif’

end: 2017:12:23 14:05:36

Hope this helps!


#371

I enebled OpenCL and set my OpenCL settings in Darktabke to Fast GPU and made sure my nVidia Geforce card was used as graphics card in Darktable. Now it took me about 18 seconds for a RAW to export to TIFF. Way faster! :slight_smile: Check below.

========================================
version: darktable 2.4.0rc0
start: 2017:12:23 14:33:11

[dev] took 0,160 secs (0,203 CPU) to load the image.
[export] creating pixelpipe took 0,103 secs (0,109 CPU)
[dev_pixelpipe] took 0,000 secs (0,000 CPU) initing base buffer [export]
[dev_pixelpipe] took 0,791 secs (0,016 CPU) processed witbalans' on GPU, blended on GPU [export] [dev_pixelpipe] took 0,047 secs (0,016 CPU) processedhooglichten herstellen’ on GPU, blended on GPU [export]
[dev_pixelpipe] took 0,599 secs (0,031 CPU) processed demosaic' on GPU, blended on GPU [export] [dev_pixelpipe] took 0,893 secs (0,344 CPU) processedoriĂ«ntatie’ on GPU with tiling, blended on CPU [export]
[dev_pixelpipe] took 0,516 secs (0,094 CPU) processed basis curve' on GPU, blended on GPU [export] [dev_pixelpipe] took 0,223 secs (0,016 CPU) processedingaand kleurprofiel’ on GPU, blended on GPU [export]
[dev_pixelpipe] took 0,255 secs (0,188 CPU) processed global tonemap' on GPU, blended on GPU [export] [dev_pixelpipe] took 1,837 secs (0,547 CPU) processedschaduwen en hooglichten’ on GPU, blended on GPU [export]
[dev_pixelpipe] took 11,042 secs (18,578 CPU) processed lokaal contrast' on CPU, blended on CPU [export] [dev_pixelpipe] took 0,563 secs (0,047 CPU) processedcontrast helderheid verzadiging’ on GPU, blended on GPU [export]
[dev_pixelpipe] took 0,650 secs (0,031 CPU) processed verscherpen' on GPU, blended on GPU [export] [dev_pixelpipe] took 0,328 secs (0,016 CPU) processeduitgaand kleurprofiel’ on GPU, blended on GPU [export]
[dev_process_export] pixel pipeline processing took 17,857 secs (19,969 CPU)

I now have a problem closing the Darktable program. It seems to hang at closure. Nevertheless exporting is way faster now! :slight_smile:


(Jason Stainthorpe) #372

No problems. Looking at that opencl test file the last line says

[opencl_summary_statistics] device ‘Scrapper’ (0): NOT utilized

So I assume that the opencl is there but Darktable is not actually using the GPU, which is named Scrapper, AMD and their naming conventions hey

Edit 26/12 - I have just tested the export as TIFF on my sons Surface Pro 3 i5, 4gb of ram with the export time being 4 minutes 10 seconds

Cheers


(Laurentia Art) #373

Hi,
I think that when opening in the darkroom, several modules automatically apply intrinsically like the sharpness and the basic curve (these modules appear in the history) and the standard matrix is systematically applied even if it does not appear in the history since it is needed for development.
Is it possible that in pipeline order my pre-setting applies before the intrinsic application of the standard matrix and that, therefore, this application appears in the history?
If so, it could be the explanation of this behavior 



(Mica) #374

darktable has a fixed pipline, so you can’t adjust the order in which the modules are applied. You can turn on and off which modules apply when you open an image, there is a preference setting for that.


#375

Hi,
just installed darktable for Windows and I’m trying to get the language into English. Adding ‘ui_last/gui_language=en_EN’ to darktablerc doesn’t work and I’m now trying to find out where to put the “–conf ui_last/gui_language=C” parameter. If I add it to the line in Command Prompt nothing happens
 Can anyone share how to use the parameter? Thanks.


#376

Please read the FAQ here: https://www.darktable.org/about/faq/ or even better the usermanual: https://www.darktable.org/usermanual/en/index.html

You can read there that you should use this form for command line parameter (note the double dashes)
--conf ui_last/gui_language=C

Also the darktablerc way is working, just make sure there is no space between the “=” and the posix language code.


#377

Thanks, the double dashes did the trick in the shortcut. Still no luck with the darktablerc file though.But then I use Dutch locale and English for language on my W10 PC. .


#378

Try ui_last/gui_language=C in darktablerc. Does that work?


#379

No, I tried that and 
=en_EN but neither changed the language.

I used the file “C:\Program Files\darktable\share\darktable\darktablerc” and edited it with Notepad++ using Administrator rights to be able to save it.


#380

So that’s the problem. Please once again, read carefully the FAQ:https://www.darktable.org/about/faq/

You can change this setting in the configuration file itself. Open with an editor the configuration file of darktable C:\Users[[username]]\AppData\Local\darktable\darktablerc, find the line ui_last/gui_language= and modify it to ui_last/gui_language=C. Please use a text editor which can handle Unix line endings, like Notepad++ or similar

Please note the location of the darktablerc


#381

Hey thanks for your time, it works! Bookmarked the FAQ.


(Anton Vakulenko) #382

Hi to all!

I’ve been using dev versions of darktable (windows 7 prof 64 bit) on laptop with i5core (intel hd4000 gpu). All versions in options sad the same: “Activate OpenCL support - not available”. I’ve just installed version 2.4. Still no luck. I’ve tried both Progam Files folder and c:\darktable folder. No luck. Open CL support - not available.

Please, help me!

PS. I have the latest gpu driver available from notebook’s vendor (2014, December).

log.txt (2.2 KB)

Output of darktable-cltest attached.


(Marcin) #383

Hi again
LUA scripts don’t work for me :frowning:
I tried to run the copy script tags, but not working. I edited luarc file on “appdata\local\darktable” folder.
So, who help me with that?
My OS: Win 10 Home
Darktable: 2.4.0 default settings