darktable for Windows

windows
darktable

#384

You can get lua errors printed out to find the reason. Therefore start darktable from the command line with the option darktable.exe -d lua and errors will be printed out there.


#385

Hi Anton!

I am on really thin ice here – but according to your log file, you have two graphic devices, but only one (your Intel HD Graphics 4000) is checked. You need assistance from one of the devs @houz , who hopefully has a better answer than I have.

Good luck,
Claes in Lund, Sweden

PS: Why mix \ and / in the paths (see same log file)?


#386

Hi Anton, I’d suggest to read this pretty comprehensive article on OpenCL and dt:

Reading your log it seems the problem is this line:
allows GPU memory allocations of up to 324MB

dt by default expects at least 768MB GPU memory to use OpenCL. Read the whole article, at the end you can find some further hints and tweaks, it might help you.


(Marcin) #387

So, I run from command line (CMD from windows), not showing any log, errors


#388

The Windows version of dt logs to the following place by default:
Windows 10:
C:\Users\[username]\AppData\Local\Microsoft\Windows\INetCache\darktable\darktable-log.txt

Windows 7:
C:\Users\[username]\AppData\Local\Microsoft\Windows\Temporary Internet Files\darktable\darktable-log.txt

Note to myself: this should be added to the FAQ


(Marcin) #389

Yeah, You should add that to FAQ
So, i have logs, scripts are not compatible with new API.
version: darktable 2.4.0
start: 2017:12:31 14:31:02

LUA ERROR : …s\mrt89\AppData\Local\darktable/lua/Copy_Paste_MDATA.lua:26: Module Copy_Paste_MDATA is not compatible with API 5.0.0

edit:
Working now, I added check for API 5.0.0 and script working now


(Anton Vakulenko) #390

Thanks, just post a massage to @houz


(Anton Vakulenko) #391

Thanks! But when I reduced opencl_memory_requirement from 768 to 300, still get no luck…


#392

Anton, which is your second graphic device (see above)?


(Anton Vakulenko) #393

My laptop has only one - intel hd4000. no other gpu…


(darix) #394

Intel OpenCL is not supported IIRC


#395

My experience with a Win10 laptop and an Intel HD Graphics 520 integrated card is, that OpenCL does work, although not with every version of the driver. The gain is modest and expendable, like 30 %, while, on the other hand, enabling OpenCL can harm the picture, at least in combination with some modules (like colour zones), when blown highlights can become black (also in the exported image).

(Un)luckily I am away from home and the laptop, but I will recheck this and try to make an useful report. It is a combination of hardware, dt version and driver version, so probably not easy to reproduce. In general, OpenCL should be disabled in this case, I believe.

On an old Win7 PC with a HD 7850 (2 GB) card, the difference is noticeable, like 3 : 1. No problems, big improvement.


#396

Seem to be having an issue exporting with Windows 10, 8GB RAM, AMD A12 processor, AMD Radeon R7 Graphics. Only the top part of the image is exported and the bottom portion is black. Works OK on an older Intel i5 laptop. The XMP and jpg files are in bug 11903…not sure if it’s a bug, but seemed the most logical.

Bug 11903

Have not issues with Rawtherapee, but I wanted to give this a shot.


(Anton Vakulenko) #397

Thanks for info


(Gerd) #398

Dear dt-team thanks for your effort to develop dt for Windows! A happy new year and success for the following development steps!!!

Now my question: in my notebook I have two graphic 'systems":

[opencl_init] found opencl runtime library ‘OpenCL.dll’
[opencl_init] opencl library ‘OpenCL.dll’ found on your system and loaded
[opencl_init] found 2 platforms
[opencl_init] found 3 devices
[opencl_init] device 0 Intel(R) HD Graphics 630' supports image sizes of 16384 x 16384 [opencl_init] device 0Intel® HD Graphics 630’ allows GPU memory allocations of up to 2047MB
[opencl_init] device 0: Intel® HD Graphics 630
GLOBAL_MEM_SIZE: 6490MB
MAX_WORK_GROUP_SIZE: 256
MAX_WORK_ITEM_DIMENSIONS: 3
MAX_WORK_ITEM_SIZES: [ 256 256 256 ]
DRIVER_VERSION: 21.20.16.4627
DEVICE_VERSION: OpenCL 2.1

[opencl_init] kernel loading time: 0.0391
[opencl_init] discarding CPU device 1 Intel(R) Core(TM) i7-7700HQ CPU @ 2.80GHz'. [opencl_init] device 2GeForce GTX 1060’ has sm_20 support.
[opencl_init] device 2 GeForce GTX 1060' supports image sizes of 16384 x 32768 [opencl_init] device 2GeForce GTX 1060’ allows GPU memory allocations of up to 1536MB
[opencl_init] device 2: GeForce GTX 1060
GLOBAL_MEM_SIZE: 6144MB
MAX_WORK_GROUP_SIZE: 1024
MAX_WORK_ITEM_DIMENSIONS: 3
MAX_WORK_ITEM_SIZES: [ 1024 1024 64 ]
DRIVER_VERSION: 385.54
DEVICE_VERSION: OpenCL 1.2 CUDA

Which one is active and used during dt, because all cl-module compilings are done for both?


(Gerd) #399

Hi,
I found the answer by myself: GeForce is active! A tool on my notebook shows by GeForce supported programms and dt is listed when I have dt active.


#400

Hi. I am using DT on windows 8.1 on a Lenovo Yoga 2 Pro. I am unable to activate OpenCL. Is there any way to activate that? Scrolling in Lighttable mode is very slow. Is there something I can do to improve performance?
Thanks in advance.


#401

Please read first the FAQ at least:


(Jason Stainthorpe) #402

Hi, I see there has not been much action on here for a while so not sure if this place is active anymore. Anyways just like to say that I have installed the new 2.4.1 for windows and can tell you that there has been a huge change to the export times I am getting when exporting TIFF. I was getting export times of around 5 minutes or more, now it is between 55 seconds to a minutes, so a huge difference. This is without OpenCL using my graphics card which I just can not seem to get to work properly.
If I edit the darktable.rc and change use CPU to true, OpenCL will pick up the CPU and GPU and it looks like it is working when using the opencl test command, but, when using Darktable in general it is really slow with it showing working for ages when I make changes. Probably some confusion between the CPU and GPU. Meh I am happy with the export difference the way it is without using OpenCL
So a huge thank you for the continued development of the great software

Cheers
Jason


#403

Hi Jason, yes, the TIFF export slowness has been fixed, just I believe we forgot to mention in the release notes.

We have added additional debug information to OpenCL initialization. Would you mind running darktable-cltest and share the output?