darktable for Windows

darktable
windows

(Denis Thibeault) #424

Issue resolved …thank you!


(Laurentia Art) #425

Hello,
I have two problems:

  • the first, with version 2.6.0 RC1 that works well on one machine and crashes on the other (production PC with the same version of Windows home 64 1803). Crash at first use after installation.
  • the second with the Map module. The problem already existed with previous versions including 2.4.4: if the tagging by drag and drop works well, the display of an already tagged image is not good. It is always the previous location that is displayed and not that of the selected image. In addition, the search for localization does not work: when you enter a city or an address, nothing happens.
    See joined screencopies.

Crash%20dt%20260rc1


(ph. weyland) #426

Same for me.


#427

The mapping problem: Is this a Windows version specific, which works well on Linux version, or a problem is present on all operating systems?
For the crash, pls share the backtrace. Also the two machines you have mentioned: do they have the same hardware / GPU or different?


(ph. weyland) #428

I cannot say, running only windows.:sweat:
It was aleady broken on dt 2.4.
EDIT: I’ve made a try with darktable -d all but I don’t get anything interesting. However, there is path related to your own machine, several times, like :
17,063400 [sql] D:/Peter/Documents/Development/darktable/src/libs/lib.c:1151, function dt_lib_connect_common_accels() []
darktable-log.txt (268.2 KB)


(Martin Scharnke) #429

IIRC, Problem was due to changes in mapping providers’ API requiring HTTPS rathern HTTP. Certainly has been fixed in 2.5 (Linux) for a while.


(Laurentia Art) #430

Hi,
I indicated my version of Windows in the original post: Windows 10 Home 64 bit v1803 (version 1809 is not yet available at home). And I only use Windows.
For the crash, there is no backtrace. Only this message, the program disappears and there remains a task residue in memory that the task manager does not see. Required to restart to uninstall this RC1.
Although the two PCs do not have the same hardware, one is a laptop with an Intel chipset and the other an old Tower with 12GB ram and a GPU Radeon 7770.
I also answered on another thread that is related to this problem:
https://discuss.pixls.us/t/error-code-launching-darktable/10220/7


#431

Installed Darktable but it won’t run. Complained about .txt file in /temp/ folder of the user/system.

I guess I keep trying with DK & PS.


(Pascal Obry) #432

And do you expect those issue to be magically solved? There is very few people maintaining the Windows port, that’s then expected to see issues. But then the best is to start helping than leaving this kind of message :slight_smile:


#433

No I don’t expect – not at all. That’s why I’ll saty with current. I used LR for years. I wanted rid of it because so fat! But I also found another world :wink:


(Aurélien Pierre) #434

Please help us to help you and fill a proper bug report with the content of the .txt file in your temp folder. Other users may encounter the same issue and the time to fix it is now or never.

Windows ports of darktable have been refused for a long time just because that type of “it doesn’t work but I don’t care to help you” behaviour is typical of Windows users. darktable is a pretty piece of software you get for free, provided you are willing to give back a bit to the community. While we are still in release candidate for 2.6, it’s time to make yourself useful and contribute with your error so it can be fixed for everyone. You are not asked to fix it, just to provide relevant info so that others may fix it for you. Is that too much to ask ?


(ph. weyland) #435

like this one :
image


(evgeny magata) #436

Hey, i tried the 2.6.0rc2 on my Windows 10 v1803 Laptop. It crashes directly on startup with an error message that somebody else pasted before as well.Screenshot_10

I would be totally happy to provide more information and / or proper bug reports, but i dont know how to get that, there is no textfile in /users/username/AppData/Local/Temp on my machine…

All the other binaries (i.e. darktable-cltest.exe) in the bin folder crash with the same message.


#437

I would like to follow up on this issue. I wanted to verify whether rc2 would crash on my pre-AVX2 system, so I downloaded the installer and ran it. It informed me that I had an older version and asked me if I wanted to remove it, to which I said yes.

FYI, the installation directory of the previous dt was set to another partition (not C:). After installing rc2, a darktable-[version] folder remained with a uninstaller app inside. So, I ran that too. It left me with a bin and share. So, same as before. I could manually delete share but bin was impenetrable. This time, bin simply disappeared after a reboot.

I wonder why it gets removed only after a reboot and not instantaneously… It doesn’t happen with other uninstalls. I haven’t tried doing one uninstall only and rebooting to see if everything disappears after that. Right now, I am doing two uninstalls and some manual deleting and then a reboot. Maybe next time…


#438

Ok… installing…


#439

Pls re-install from the github the updated RC2. With the update you should not have this error anymore.


(Aurélien Pierre) #440

Hmm error with Intel OpenCL on RC2 (even if I don’t seem to have it on my desktop):

darktable_bt_3NR4TZ.txt (6.5 KB)

The system is Windows 10 Workstation, Intel Xeon Skylake, Nvidia Quadro M2200.


#441

What is the output of darktable-cltest?


(Aurélien Pierre) #442

I run that in which console ? cmd does not know that command.


#443

It is in darktable\bin.

image