darktable shotcut to toggle mask visibility

Is there a default shortcut in Darktable to toggle mask display while in a module? (ie the same thing one would achieve with the widget in the module header).

If no, can I define it? What is this functionality called in the shortcuts settings?

Click the ‘keyboard’ icon in the darkroom header, then with the ‘crosshairs’ cursor, target the GUI element to which you want to assign a shortcut. Once the cursor is over the UI element, simply press the key comination you want – do not click the element, as that brings up the shortcut editor instead of creating a shortcut.
For me, this results in adding a shortcut for processing modules → blending → tools → display mask and/or color channel.


@kofa : Nice one!

There does seem to be a bug though (can you confirm?):

  • With the shortcut in place
  • Set a parametric in the parametric and drawn mask section (shortcut still works)
  • Now create a drawn mask: shortcut stopped working
  • Toggle polarity (or move slider a tiny bit) in the parametric section → shortcut works again.

A drawn mask on its own also doesn’t seem to work with the shortcut. You can use a workaround, though: Use parametric and drawn instead of drawn and set and the reset a parametric setting.

I dont use maps so I have used M. Seem’s like it works if you use the toggle inside the module as the source and not the header…just at least after a quick couple of tries…

That’s not what I’m talking about (although you are right about that one, just tried).

Have a look here:

Maybe in diffuse… I don’t know I will have to try again I don’t see that I don’t think…my short cut works I think in all cases…I will try to do your specific sequence…

This isn’t specific to the defuse module, I also tried a handful of others to make sure of that.

It’s also seen in both 3.8 and 3.9.

I’m just using the M key and I don’t see this…3.9.0+25~gc4e00c2c2-dirty on Windows


I am just pressing the M key to initiate the toggle…

If I map to m or = or alt = everything works as expected. If I map to alt m it does as shown in the above video.


I was just going to ask that as I noted you use the alt…that must be it…you beat me to it…I had just posted my video in case we didn’t see the same things…

Yeah, there must be something going on with the alt key. Strange, though, that alt = fully works and alt m does not.

I’m assuming for the moment that this is a DM issue (is is often the case with alt and/or meta key, at least with Xfce, which I use, it is) and not a darktable issue perse.

Thanks. For some reason I was unable to assign m (even though I removed it from maps a long time ago), only ctrl-m.