darktable windows insider program 8/14

Here’s the link to the weekly snapshot of darktable 4.1, https://drive.google.com/file/d/1XBeWqbSuOILeAVESongLa0QxD_bwKFJs/view?usp=sharing. The list of latest changes is available at Pulse · darktable-org/darktable · GitHub. Of note this week is the new highlight reconstruction option as well as pipeline processing speedups.

This week I updated to the new universal C run time build tools, so please let me know if there are any problems.


Hi Bill,
I installed this build today, and it’s working fine on my win11 PC so far! How significant are the speedups? It actually seemed a bit more responsive but I haven’t confirmed that I’m not imagining it yet :grinning:

I’ve just ran into a problem. I loaded an image in darkroom, adjusted color calibration, then fiddled with exposure - and it crashed with an ‘unhandled exception’. It seems to be reproducible. If it’s helpful, this the right place to post this? Here’s the backtrace, I can provide the image if it’s needed.
darktable_bt_6GPOQ1.txt (20.6 KB)

Bill quick question… I have had some issues with my build set up so I have ditched it and I am starting from scratch… I will use the new instructions and so install the newer C libraries…

I noted that the instructions sort of mimic the older ones… Should the following references to the the WINGW64 terminal actually be the UCT terminal… in other words were the two references to MINGW64 here not just updated?? Maybe I just don’t understand some nuance between the versions??

See text below from the building instructions for Windows…

<<* From the MINGW64 terminal, clone the darktable git repository (in this example into ~/darktable):

cd ~ git clone https://github.com/darktable-org/darktable.git cd darktable git submodule init $ git submodule update

  • Finally build and install darktable:

mkdir build cd build cmake -G Ninja -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/opt/darktable ../. cmake --build . $ cmake --install .

After this darktable will be installed in /opt/darktable directory and can be started by typing /opt/darktable/bin/darktable.exe in MSYS2 MINGW64 terminal.NOTE: If you are using the Lua scripts, build the installer and install darktable. The Lua scripts check the operating system and see Windows and expect a Windows shell when executing system commands. Running darktable from the MSYS2 MINGW64 terminal gives a bash shell and therefore the commands will not work.>>

Those are errors. It should be the UCRT64 terminal.

Thank you for clarifying…I thought it should be but given the issue I had with my building environment I just didn’t want to introduce any uncertainty moving things to UCRT.

Thanks again…

Ive been building fine in UCRT for a while now. Make sure you run pacman -Syu to update it all.

I think my issue may have been this…on the first install of the libraries I got these messages but didn’t add those…

Where is this added .bash.profile ? other??


It should be in C:\msys64\home\prior

I think you are referring to the bash file…and yes it is there I was more in need of how and where to set this variable(s) as requested…

How fast does it crash? Couldn’t reproduce it quickly on 3 photos. I would retry with yours and in best cast with an exact editing sequence.

I ended up ditching everything and reinstalling MSYS2 from scratch. I switched to the UCRT terminal when it said to in the instructions. Up until that point I used the MSYS2 terminal.

I don’t think it matters what terminal you run git from.

The Lua warning probably needs changed to “use a windows terminal”, but I would say that it was an oversight.

I’ll see if I can recreate with a random image.

Thanks Bill…I am in the process of doing the same…did you get that msg about search path/variables that I posted above… if so could you direct me how to deal with that…where would I add those references…

Todd, I think that’s just a warning/FYI. It should not prevent you from building.

Okay thanks I just thought it might be linked to the crash during building looking for GTK3…which is clearly installed…I will track it down…

I don’t recall seeing that error. To check your setting open a UCRT terminal and do
env | grep XDG
and see what it shows.

Mine shows

If I do it in a MINGW terminal it shows /mingw64/share/ as the first directory

If it’s wrong then to fix it in the terminal do
export XDG_DATA_DIRS="/ucrt64/share/:/usr/local/share/:/usr/share/"

Your a champ thanks so much I will try that when I get home…very much appreciate the hand holding…

1 Like

Thanks Bill. I’ll post the image I was working on when I get a chance, but it might be later today. :neutral_face:

Quite fast. I made a series of a exposure adjustments, up and down, then the familiar error box popped up. I’ll try it again, but it might a while till I get time…
One point I probably should have mentioned is that I had the new build using my 4.0 database (after backing it up). I might try it again on a fresh database…