darktable windows insider program 8/14

I’m also on my “old” database. Even switched several times between 4.0 and 4.1. No problems so far.

Are you running R darktable too? Or another iteration of darktable?

No, not R-dt, but I do have one other build, one of Todd’s builds with the new HR mode, currently installed. But not running at the time (probably obvious!)
EDIT I have dt4.0 (the workhorse) installed too. Forgot to count it.
@wpferguson, here’s the file where it crashed:
(file is licenced Creative Commons, By-Attribution, Share-Alike.) (I hope this is the right licence!)
DSC_6762.NEF (25.0 MB)
DSC_6762.NEF.xmp (892 Bytes)
Not sure whether the xmp is reflective of the edit - I imagine it crashed without saving the adjustments. Not sure though atm.

Played around for some minutes with this, no problem so far. Your XMP is pretty much empty.

Humph… maybe it’s specific to my system? TBH I’m not too bothered… would it be useful to anyone if I keep poking at it? If not I might just let it go at this point. But is there anything anyone wants me to try, or any info you need?

Have you tried the photo with a fresh config/db? You could temporarily rename your AppData\Local\darktable folder to see if the error is coming from there.

I would remove the other iteration of darktable and then try bill version again.

No… I didn’t. If I have time I’ll try that tomorrow - and @g-man s suggestion too. Thanks!

Just to spell out the consequence of this: users on Windows 8.1 or earlier will need to install UCRT separately.

@apostel338 , I tried using Bill’s version with a clean db (I used --configidir - worked well) but it doesn’t make any difference.
@g-man , I uninstalled both my other version of 4.1 and 4.0 too, so Bill’s latest 4.1 was the only dt on the system. Still no difference.
I’ve isolated the problem slightly more, to reproduce: Close dt. Start dt, then open image in darkroom. Make two consecutive adjustments to exposure. It should crash just after the second adjustment.
BUT! If I make one exposure adjustment, then do something else, like a color balance rgb saturation adjustment, then go back to exposure, it works perfectly. What’s more, if I then open a new image, exposure works fine from the start, and the problem doesn’t reoccur. But if I restart dt the problem returns.
The problem is there with RAWs from both a nikon and a sony.
Hope this helps!
I’m going to reinstall 4.0 now… back to work :wink:

Ok. I think this needs an issue in GitHub.

I had some problems with master today on windows (my build). I need to bisect to find the commit that caused it.

OK, I’ll see if I can do a github issue - never done one, but I’m sure I can follow the directions! Thanks all.

Still no “luck” for me. I also tried with a blank AppData folder to exclude that my default module pipe prevents the crash. But everything’s fine so far.

Weird… I’m not using OpenCL as I don’t any decent graphics… are you?

This did the trick :smiling_face:

BT was empty :man_shrugging:

Here are some with content.
darktable_bt_L5LPQ1.txt (33.1 KB)
darktable_bt_OTR2Q1.txt (33.1 KB)
darktable_bt_WLR0Q1.txt (33.1 KB)

Ha good. Sorry I didn’t think to mention my lack of openCL before…
Shall I still go ahead and post a github issue?

Oh, it’s even “working” when I set openCL profile to “Standard”. I normally have it set to “Very fast GPU”.

openCL off = crash
openCL Standard = Crash
openCL Very fast GPU = Stable
At least for me

I think so.

Oh, that’s interesting too. Thanks for going to the trouble - glad it’s not just me seeing it!

@apostel338 can you describe the steps to reproduce? What’s the build number? It seems to be caused by the CPU path vs OpenCL.

We definitely need an issue in GitHub for proper tracking.

PS. This is why doing these builds and testing is important, so we can identify issues early and find a fix for them.

Pretty much the same as @123sg described.

Open a photo, going directly to exposure, making some exposure adjustments, it always crashes at the third input. But it’s not only exposure exclusive.

Crash with exposure, openCL *standard:

Crash with color balance rgb, openCL off:

As mentioned above, I also tried with blank AppData folder. A very short test showed, that it happens with NEF and ARW pretty fast, but takes longer with some old CR2 I have. Nikon and Sony crash within seconds, but I can play a minute in exposure of a CR2, and nothing happens. Switching between the modules and make adjustments makes it still crash at some point.