digiKam 6.3.0 is released

Sun Aug 4, 2019

digiKam 6.3.0 is released

by digiKam Team


Dear digiKam fans and users,

We received a lot of excellent user feedback after publishing the third digiKam 6 release in August 2019. We are now proud to briefly announce the new digiKam 6.3.0, a maintenance version which consolidates this feedback and acts as an important phase of this 3-year-old project.

New GMic-Qt plugin for Image Editor

Since digiKam 6.1.0, we open digiKam to external contributions with a collection of new plugin interfaces, named “Generic” for album items processing and export to web-services, “Editor” to extend Image Editor and Showfoto post processing, and “Bqm” to add new tools in Batch Queue Manager.

With this release, a first official external tool have been ported to digiKam plugin architecture: GMic-Qt. This tool based on GMic library, a processing engine known for its noise removal filters, came from an earlier project called GREYCstoration. G’MIC offers many built-in commands for image post-processing, including basic mathematical manipulations, look up tables, and filtering operations. More complex macros and pipelines built out of those commands are defined in its library files.

G’MIC comes with a Qt-based graphical interface named GMic-Qt, which may be already integrated as a Gimp or Krita plugin. It contains several hundred filters written in the G’MIC language, dynamically updated through an internet feed. The interface provides a preview and setting sliders for each filter.

G’MIC is one of the most popular Gimp plugins, which is now also available officially for digiKam and Showfoto. If you don’t know yet G’MIC, we recommend highly to take a look to this review published on a Pixls.us blog one year ago.


DPlugins Demo Project on GitHub

On GitHub, a new project have been started recently to host a collection of plugins dedicated to document and test the architecture. Source codes of few HelloWorld plugins are available to help future external contributors to write new tools for digiKam and Showfoto.

This project have been voluntary separated of digiKam, and still under development. It needs more time to write code in goal to use whole exported digiKam API with code examples.

Migration to Gitlab

Historically, digiKam has always used the KDE infrastructures to manage the project. We use Git repositories to host source code, Bugzilla to manage reports, Phabricator for pull-requests, and Jenkins for the continuous integration, deployment, and static analysis.

One year ago, KDE team start to search a collaboration with a major developpement Web service to increase the visibility and the accessibility for new contributors to the infrastructure hosting open-source projects. They select GitLab platform for technical reasons. A migration of KDE projects have been started quickly and digiKam have been one of the first to be ready for this kind of move. The KDE GitLab area have been named invent.kde.org.

So the new Gitlab integration with git repositories was completed in end of August and we have now 3 places to host source code:

For the future, we will use step by step the GitLab platform tools.

Website Update

Following the gitlab migration of web-site repository, some important parts have been updated, especially the pages to introduce the application, to present the project overview, and list all main features in details.

Plenty of new screenshots have been added and also the list of features have been in-depth updated. This will help future new users to judge the application before to choice digiKam as main personnal photo manager.

The Final Words

Thanks to all users for your support, and to all contributors, students, and testers who allowed us to improve this release.

digiKam 6.3.0 source code tarball, Linux 32/64 bits AppImage bundles, MacOS package and Windows 32/64 bits installers can be downloaded from this repository.

Rendez-vous in few months for the next 6.4.0 release where we will give details on a project from a student working with us while this summer, about a new clone tool for Image Editor and Showfoto.

Happy digiKaming…

This is a companion discussion topic for the original entry at https://www.digikam.org/news/2019-09-08-6.3.0_release_announcement/

Woo Hoo! Yet another great release by digiKam Team. Thank you!

Congrats to the team!

Fantastic news!!! Thank you for your great work.

Great work as usual. You are always the best.
Without Digikam I’m lost with my photo library on linux

Running Kubuntu I always have problems using the internal MySQL DB i Digikam (DK) and starting DK always gives me error code “Could not start database initializer” (even in DK 6.2). Seems like DK does not play well with MySQL. I have to uninstall MySQL and install MariaDB, but uninstalling MySQL removes a lot of other stuff. Does anyone have a good guide on how to install DK in (K)ubuntu using MySQL? Or how to best use MariaDB? Can MySQL and MariaDB run on the same machine at the same time?

I think @dmpop here might have an article on that.

Hi All,

I’m giving digiKam a fresh try.
Just downloaded 6.3.0 and installed it on my Win 10 64bit pro system (Version 10.0.18362 Build 18362, with all the latest patches)

Installation --> no issues.
First run of digiKam, selected a (test)directory with about a 800 images (TIF, JPG and NEF files), choose SQL-lite and a seperate directory for the database on a SSD drive.
(the test image directory is about 28GB in total size)
And then the wait begins…

After about 10% of processing, digiKam crashes:

Faulting application name: digikam.exe, version:, time stamp: 0x5d6fdfed
Faulting module name: Qt5Core.dll, version:, time stamp: 0x00000000
Exception code: 0xc0000602
Fault offset: 0x000000000032bfe1
Faulting process id: 0x1310
Faulting application start time: 0x01d58143a21110b2
Faulting application path: C:\Program Files\digiKam\digikam.exe
Faulting module path: C:\Program Files\digiKam\Qt5Core.dll
Report Id: a4ccd682-e1af-4b71-a9f6-bf59ab10502e
*Faulting package full name: *
*Faulting package-relative application ID: *

Fault bucket 1585111947967311761, type 4
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: digikam.exe
P3: 5d6fdfed
P4: Qt5Core.dll
P6: 00000000
P7: c0000602
P8: 000000000032bfe1
*P9: *

When I restart digiKam, the processing continues to about 16% and crashes again. :unamused:

I’ve tried a reinstall of digiKam; no effect.
I’ve tried running digiKam as Administrator; no effect.
After about 4 x crash; I got about 50% in the status bar in the lower right side of the digiKam window.
The issue seems to occur immediately, as soon as I use the mouse cursor to click on a subdirectory of the selected image location.

Is there something I might have missed? Is there anything else I could try? Am I doing something wrong?

Thanks for any ideas and/or assistance!

Hello @PanoMeister

I have tried to install Digikam on my Windows 10 (64 bit) system too.
I have encountered your same problems: the application always crashes when you try to open some folder with your pictures.

In the end, I uninstalled Digikam and went back to Picasa - FastStone, which is a pity since digikam looks really interesting, aside from its HUGE size to downoload and install all its components (it looks like you have to install the entire KDE distro components to make it work…)

Guys, please report your crashes here if you have a chance:


I do use digikam on Windows 10 and have never had such problem.

Hello @Andrius,

Guys, please report your crashes here if you have a chance.

My fault for being lazy :frowning:

I have reinstalled Digikam once again (Windows 10 - 64 bit) to report any crash on my system.

The error with Digikam I always got was that the software reported that it was unable to create a new Album (Sqlite database): Setting > Configure Digikam
This occurred as soon as I chose the folder where all my pictures should be opened by Digikam later on.

This error is still present. When It occurs I now restart Digikam.
As by magic, after this restart, the folder is available and I can now open my pictures (NEF, JPEG etc), without any crash.

In the past, I have never experienced any similar bug with the previous versions of Digikam (Windows 10).

To make it short, now everything works fine. I will report for sure any bug-crash, in the KDE bug-tracker, as soon as they reappear. Just testing more in depth this very powerful application :slight_smile:

Thanks a lot for your help!

It seems like you might need to take a look at the NTFS users access rights to the folder.

Please note that the database (which is few *.db files if you use SQLite) does not have to be in the same folder where the pictures are.

Your media (JPS, raw files, video files) is referred to as ‘Collections’.

Your collections can be all over the place (read - local devices, local network) but it is recommended to store your database on a fastest available drive e.g. local SSD.

1 Like

digiKam 6.3.0 seems to running stable… As long as I don’t select a fresh ‘collection’ e.g. a directory which has not been scanned before by digiKam.
As soon as I add a new Local Collection, digiKam starts processing this, you can see the progress bar/percentage increasing at the bottom of the screen.

But when I move the mouse cursor around and try to select any existing Album, I don’t get any response any more and a few seconds later, digiKam crashes… :unamused:
Just before the mouse cursor changed into the hour-glass symbol.

[additional info]:
Any action, while digiKam is processing (?) a freshly added ‘collection’ results in the hour-glass mouse cursor and no response anymore from digiKam. And once clicked anywhere in the Album window --> crash.
You will have to wait until processing has finished; only then digiKam does respond and no crash anymore. But this is very cumbersome.

With the same error message in the event log.

Faulting application name: digikam.exe, version:, time stamp: 0x5d6fdfed
Faulting module name: Qt5Core.dll, version:, time stamp: 0x00000000
Exception code: 0xc0000602
Fault offset: 0x000000000032bfe1
Faulting process id: 0x2518
Faulting application start time: 0x01d582d69971b7d8
Faulting application path: C:\Program Files\digiKam\digikam.exe
Faulting module path: C:\Program Files\digiKam\Qt5Core.dll
Report Id: e4d45037-0681-4e38-91f7-5f3fa53aca15
Faulting package full name: 
Faulting package-relative application ID:

Wow! That was not an easy task. :wink:
I thought, I would use the ‘Report Bug’ function from within digiKam, never realising I first have to create (again) an user account, and then fill in a lot of data, which is already available, or should be available, when using that link. ?!?
But I’ve tried to submit as much data as possible. However I don’t know for sure if I choose the correct module (?)

FYI: https://bugs.kde.org/show_bug.cgi?id=412950

Please spend as much time as you feel comfortable spending on this task. It does not have to be perfect. I usually spend 2 minutes on each bug report.

The developers will correct the selected modules and ask for any missing information if required.


I’ve got some replies to my ‘report bug’ action.
It seems to be a known issue. And should be resolved by:
You can use the pre-release version of digiKam-6.4.0:

So I’ll give it a try, version 6.4.0.

To be continued… :wink:

I’m super stoked about G’MIC being included (just saw in release notes). That’s what I would mainly use GIMP for, now I don’t need to switch between digiKam and GIMP!

A couple of things I’ve run into that may be mentioned somewhere: I run digiKam on Windows 10, and it seems to load files a little slower than it used to. No big deal really, just noticeable. Another thing that kind of flummoxes me is that, in the preview pane, often digiKam is unable to load a preview of the file that I’ve clicked in the thumbnails on top. All I get is a small balloon that says “Unable to load file” or similar. I’ve tried view refresh (which I have to use a lot more than in previous versions to maintain image synchronization), but I generally have to restart digiKam. Anyone else see this behavior?

Hello @TomCunningham

I had no problem as regards the loading of files (Nef, jpeg etc).
In order to better test Digikam I tried to add a new folder, around 5,2 gb of pictures, with plenty of sub-folder inside.
I wish I had never done that…

As soon as I have added this new folder as “new album” all Hell broke loose…
From that moment on, I was unable to work with Dikigam 6.3 (Windows 10 - 64 bit) because it always crashed.
I was not even able to remove this folder because again Digikam crashed again and again:

Here is the error:

warning: digikam.dbengine: Detected locked database file. There is an active transaction. Waited but giving up now.
warning: digikam.dbengine: Database is locked. Waited 0
warning: digikam.dbengine: Failure executing query:
“SELECT COUNT(id) FROM Images WHERE album=:a;”
Error messages: “Unable to fetch row” “database table is locked: Images” “6” 1
Bound values: (QVariant(int, 1))
warning: ASSERT: “!isEmpty()” in file …/…/…/…/…/…/…/…/mnt/data/GIT/6.x/project/bundles/mxe/build.win64/usr/x86_64-w64-mingw32.shared/qt5/include/QtCore/qlist.h, line 363
warning: digikam.dbengine: Database is locked. Waited 250
gdb: unknown target exception 0xc0000602 at 0x66a6bfe1

In the end I was forced to unistall it completely from my Window 10 setup.

Now I have installed the bleeding edge 6.4 version since the 6.3 version was unable to work fine properly with my collections of files…

So far so good with the 6.4 upcoming next version :slight_smile:
No message “Unable to load file” when I open my pictures.

Have you tried opening the task manager and killing all the digikam.exe ghost processes ?

Hello @Andrius,

The 6.3 version was a nightmare on my Windows 10 - 64 bit setup.
I am referring to the option to “import” new pictures into Digikam which was extremely crashy (to say the least).

Now I am running the 6.4 upcoming version which, even though is the “unstable” version yet, is much more stable then the 6.3 version (at least as far I am concerned of course…) . I suppose the Digikam developers have fixed in the meantime the bugs which were plaguing me…