Distro Fever: Memory Loss Edition

It’s January! A new year! And I’ve had enough. My computer is a mess. This is a very old windows installation that I’m running, and it’s showing definite signs of senility. Plus, I’ve now been using Windows for work for a solid year, and I just want to see something different at home.

But Linux is no longer an option on this machine. You see, this is a Hades Canyon NUC, the one with the Intel CPU with an integrated AMD GPU on the same die! A fantastic little piece of kit except for one detail: Intel and AMD hate each other, and released exactly one set of drivers ever, then split up and tried to forget that one-off cooperation ever existed. Leaving me out cold for driver support. For a while, RocM could be made to work, but no longer. And without Rocm, there’s no OpenCL. And without OpenCL, there’s no Darktable. So Linux is not an option.

But as I said, I’ve had it with this computer. So I put it up on Ebay, and order myself a shiny new ZBOX Magnus One, with a fancy 12th gen Intel CPU, and a brand new Nvidia 3060! This is going to be great! And I can even reuse the old NUC’s memory and storage! (And as luck would have it, the GPU market currently is bonkers, so I actually sort of make a profit on trading my old old gaming rig and the NUC for the zbox).

A fresh start! Ubuntu it is! The kernel is a bit old, Nvidia support is a bit patchy. But it works, and it’s beautiful, and Darktable is screaming fast! It’s amazing! Even the Windows install imported without any major issue.

Fast forward a few weeks, and the cracks begin to show. Suspend is less than reliable. Firefox regularly crashes for no apparent reason. Actually, a lot of Gnome software is surprisingly glitchy. Oh well, that’s just what you get on Linux. And anyway, Windows wasn’t much better, so what can you do? Computers just suck a little, that’s how it is. I seem to remember that this wasn’t always the case, but I guess that just means I’m getting old.

Now fast forward again to a few days ago. I need to get things done today. My CV needs touching up, and a few important documents need to be prepared. But my computer lately has been a hot mess. Firefox has become so unstable it rarely makes it a whole hour. Wake from sleep is not just unreliable, it’s actively broken. Even cold booting sometimes takes several tries.

But today things come to a head. The computer freezes and now refuses to boot. In desperation, I write OpenSuse to a USB stick, maybe that’ll work better than Ubuntu. It doesn’t. Something about the Nvidia driver enrollment breaks and it can’t even boot any more on the binary drivers. The Ubuntu USB stick doesn’t even install any longer. Fedora works, thankfully, after a fashion. I feel like I’m going mad! I really should work on these documents today, and prepare my wife’s birthday, and I need that computer for it, gosh darn it!

What a mess. I sleep badly. Why does technology suck do badly these days? Should I not have bought that stupid Zbox with this Nvidia piece of junk GPU? Should I just buy an Apple and be done with it? Then at least I’d have someone else to blame!

But as a very last resort, way past bedtime, I run memtest. And guess what? Within seconds, it’s all red errors. My memory is defective. I. Want. To. Scream. So much anguish. So much stress. For a bank of defective memory. The memory that had probably been the culprit for my previous computer as well.

Today: two new sticks of memory, a fresh install of Ubuntu. No glitches. No crashes. Suspend works.

Thankfully, I’ve kept a continuous and reliable stream of backups, so no data was ever lost. Though I wonder how many files in those backups were silently corrupted along the way. What a mess.


On some motherboards, like mine, Memtest fails, and reports errors, but the machine is stable. Of course, you had all those crashes, which were fixed by replacing the RAM.
Right now, I cannot find the reference where the problem is described.


Today I set up Darktable again, and had a corrupted database for the first time (from the backup written from defective memory).

But Darktable noticed the corruption, loaded its own last backup, and a reimport got all my edits back from the xmp files.

Good job Darktable!


Linux runs the web. It cannot be that bad. When something suddenly goes bad, if there have been no software updates, look at the hardware.

I have seen several people reinstall Gimp just because the battery in their mouse was running out and made the mouse misbehave… which unfortunately is more noticeable with Gimp that with the rest of their applications.

1 Like

Try Linux Mint, rather than the car crash which is Gnome on Ubuntu!

I actually like Gnome. Weird, I know.

What’s your issue with Gnome?

1 Like

Well, the web isn’t exactly running Gnome and Nvidia, though. I mean, you’re right of course. But the tech stack of Linux desktop apps and your usual web server are quite different.

And judging from the volume of expletives I hear from my colleagues, Nvidia on our compute servers isn’t exactly trouble free, either :wink:.

1 Like

Too much zooming icons and windows, and the fact you need to install extensions to get desktop icons and a minimize window buttons… Cinnamon is Gnome done right!

1 Like

For darktable, Nvidia has been rock stable for me since 2014.


That’s good to hear! And perhaps the recent news of Nvidia opening up their kernel driver might mean even better stability and compatibility in the future.

Memory-related glitchiness notwithstanding, my Nvidia GPU so far has more than exceeded my expectations in terms of performance. I actually measured things, and the new 3060 on Linux is on average 10x faster than my old Vega M GH on Windows. (Though part of that is Windows vs Linux, and a bad case of severely outdated drivers)


So, I’ve found some info for the memtest failures: some UEFI BIOS-es fail to correctly mark the areas already in use, which memtest should not overwrite while performing the test. These cases often result in incorrect reports and/or crashes of memtest.
Edit: Here’s the URL: MemTest86 - Freezing and Lockups


Good to know, thank you!

1 Like

Nvidia has been pretty stable for some years now, specially in more stable distros where updates don’t break things so often, even so in arch for 3 years I only had it happen once and the next day it was resolved. After all it is also used in desktop linux in things like davinci resolve workstations and the like. Still their bad rep for closeness and not supporting the open standards is well deserved.

1 Like

By the way, does anyone know how the Nvidia driver is integrated in Ubuntu?

It seems that on Fedora and OpenSuse, installing the driver involved some compilation, required MOK enrollment, and marked the kernel as tainted. But in Ubuntu it seems to be a straight package install.

Which driver? The NVidia one or thre Nouveau FOSS one? By default you get Nouveau. But AFAIK neither requires compilation.

You can use the driver nvidia provides for your kernel version, since it works as a kernel module, the downside is that when you upgrade your kernel you might have some incompatibility problems at times. Since ubuntu works mostly in an LTS fashion this isn’t an issue. In fedora, arch, etc, you get the option of using akmod(fedora) or dkms(arch), which rebuilds the kernel module every time you upgrade your kernel, providing an extra layer of safety. Arch even has two distinct packages for this - ‘nvidia’ and ‘nvidia-dkms’ plus ‘nvidia-lts’ for people who run LTS kernels. Afaik either way will result in a tainted kernel, but it’s nothing to worry about.

Ubuntu also uses dkms.


1 Like

Ah, my bad there! Was under the assumption that since they worked in a more stable model, they didn’t use it.

Ubuntu releases twice per year (it is my understanding that Fedora is similar in that respect). Every 2 years, there’s an LTS release (upon which Mint and KDE neon, and I think many others, are based). The non-LTS releases are referred to as ‘interim’, and they are supported for 9 months.

1 Like

I ran Xubuntu LTS here at home for several years and was very pleased with it. I prefer a more conventional UI, less Mac-like. I mean, I ran FVWM(95) at one point. What can I say…

My current laptop came with Windows, so I’m giving it a shot again but if I end up back on Linux at some point I’ll have to find a suitable distro. From what I’m hearing Ubuntu is going all snappy, which I want no part of (unless it got a lot better than my past limited experience fighting snap apps).

Is Slackware a viable option these days? From what I heard it was off and on, but it was always a pretty clean (if old-fashioned) distro.