Filmstrip blank in darkroom

My filmstrip is completely blank in the darkroom. It shows up in full screen preview mode from the lighttable, but not in the darkroom. I have tried re-enabling it, resizing the window, trying different themes, deactivating openCL… but it’s not appearing at all.
Before I submit a bug report, is there anything else I can try to get it back?

The problem just appeared today on 4.2.0. I upgraded to 4.2.2 but it didn’t solve the issue.
I’m on Windows.

Click on the little arrow at the bottom

What if you press key h
and look for the panels/bottom command?

I’ve tried it, but that’s not the issue. The filmstrip is activated (ctrl F), but there’s nothing in the filmstrip showing. It’s not responsive to clicks. As you can see from the screenshot, there is a grey panel where the filmstrip should be, but no thumbnails on it.

The problem is not related to the bottom panel not viewable. The bottom panel is there, but no thumbnails on it.

Ah, sorry. I misunderstood the problem :frowning:

There once was a problem — check in your darktablerc,
all lines containing filmstrip. What do they say?

1 Like

4.4.2 is the latest I think you could upgrade all the way… I feel like someone else recently reported losing the filmstrip after upgrading… I will have to see if I can find out what was the issue… you could quickly just run it from a new config directory… use–configdir “path” in a shortcut or command line…this will use fresh config files and if it works then perhaps your database file might have an issue… is it just for one folder or film roll or everything??

Thanks, I got it back! This is what I had:


So, I changed the top line to TRUE, and it worked.

So, now I’m wondering how that got changed in the first place, and why Ctrl F wasn’t bringing it back.

1 Like

I regularly encounter the same problem (under linux) which I solve in the same way without understanding why it happens.

Weird little bug it seems, and I’m not sure I can deliberately recreate it. First time it’s happened to me in 5 years.

Thanks @g-man! That’s exactly what happened: the filmstrip vanished after the central panel started rocking from left to right. I actually scanned the issues in github looking for the filmstrip issue but didn’t think of looking for the central panel issue. I just thought that had been a weird graphics driver problem.
Good to know it’s been reported and may see a fix one day.

I faced the exact same issue. I didn’t modify the config file manually and don’t recall seeing any such option in settings.

Thank you for the pointers