For a new darktable, a new script_manager

Merry Christmas! Not only do you get a new release of darktable you also get a new script_manager to go with it.

script_manager sports a new resizable paging interface to replace the long scrolling lists.

script_manager has also moved back to it’s position on the left bottom where it stays out of the way until needed.

closeup_open_10

The scripts buttons now show the state of the script. Clicking the button toggles the script so if it shows as stopped then clicking it starts the script and changes the button to started. Clicking it when the button shows started, disables the script on darktable restart.

The button window is paged. Clicking the < and > buttons pages back and
forth through the scripts. The category drop down selects the different categories of scripts.

closeup_install_update

Choosing the install/update scripts action takes you to a window where you can update the installed scripts, install more script repositories, and if desired disable the scripts.

Updating the script is as simple as selecting which scripts to update from the dropdown, then clicking update.

Installing more scripts is as simple as typing in the URL where the script repository is located (there is a list at https://github.com/darktable-org/lua-scripts#related-third-party-projects), giving the scripts a category name, and clicking “install additional scripts”.

If you decide you don’t want to use the scripts or have them running there is an option to disable them.

closeup_configure

The number of buttons in the scripts window is configurable. The number can be anywhere between 5 and 20. The next 2 screenshots show the difference. The first screenshot showed the default configuration of 10 buttons.

Enjoy and have a Merry Christmas!

Bill

12 Likes

Really nice ! Good job. Merry Christmas.

1 Like

Merry Christmas to you too! And thank you for the awesome job you do.

Fantastic job!
Merry Christimas

1 Like

Could you please give a how-to for installation? Ideally one which is suitable for dummies? I cloned the git, moved script-manager.lua to ~/.config/darktable and renamed it to luarc
DT 3.5. doesn’t show it. Or at least I can’t find it.

DT prompts you on first run of 3.4 to clone the repo.

Great work, looks very nice :smiley:

I’m assuming you’re on linux from ~/.config/darktable so here’s the quick version:

cd ~/.config/darktable
git clone https://github.com/darktable-org/lua-scripts.git lua
echo 'require "tools/script_manager"' > luarc

Start darktable and script_manager should be on the bottom left. If not, start darktable from a terminal with the -d lua argument and see if there are any errors.

Did you compile 3.5 yourself or did you get it from a repository somewhere? If it came from a repository, in a terminal do darktable --version and make sure Lua support enabled, API version 6.1.0 shows up in the output.

Sorry I didn’t answer earlier, but the grand kids were visiting :smile:

2 Likes

Thanks a lot for your quick help, Bill!
Now it works like a charm!
Thank you for your help and for making script manager available!

1 Like

Hi Bill,
I tried several ways to update my script_manager.lua file.
It seems it is not working as it is either running the old version or darktable not even starting showing an error message.
Using Windows 10.
Any idea or guidance?
Thanks anyway!

The easiest way is open an command prompt and do the following:

cd %LOCALAPPDATA%\darktable\lua
git pull
cd ..
echo require "tools/script_manager" > luarc

Start darktable and it should be working

cd …LOCALAPPDATA…/darktable/lua
=> is working

git pull delivered
=> Already up to date.

echo require “tools/script_manager” > luarc
=> did work as I can find a new luarc file

starting darktable
=> 7,333049 LUA ERROR : C:\Users\Harald\AppData\Local\darktable\luarc:1: syntax error near ‘tools’

Is this a slash vs. backslash topic here?

Could be. So, let’s do

echo require "tools\script_manager" > luarc

and see if that fixes it

no fix, same error message. The luac file has changed but same syntax error.

Argh! It’s a windows quoting error. Should be

echo require 'tools/script_manager' > luarc

Sorry about that

sorry to tell you, but again not fixed

do a type luarc and post the results please

entering ‘type luarc’ is followed by
=> bash: type: luarc: not found

the luarc file itself contains only

‘require tools/script_manager’ (no quotes)

You are on windows 10, but you are using a bash shell? So, the correct echo for a bash shell is

echo ‘require “tools/script_manager”’ > luarc

When you run darktable from the command line, you should run it from a windows command prompt otherwise the scripts will detect windows and send windows commands to the shell. If the shell is bash, then all the windows commands will fail.

I have no idea …

I use GIT Bash here

12282020_190802

and enter the following to launch darktable

I am doing this for a couple of years now and it worked all the time.