GIMP AppImage (continuous integration)

Hey @Carmelo_DrRaw, almost, but no cigar!

Ahhrgh!!! Which RAW plugin did you try to use? Darktable or Photoflow?

Could you share a screenshot of the Preferences → Image Import dialog?

Also, could you send me a copy of the terminal messages produced by the AppImage?

Thanks for checking!

I tried PhF and it launched ok, but then gave the error message.

Should I try with DT?

You’ll need to remind me how to launch in terminal…

Ok, so if I understand correctly, the PhF interface was opened and the error occurred when closing PhF and sending back the image to GIMP? Which version of PhF are you using? If you can, please post the output of the following command on the terminal:

photoflow --version

Yes please, to see if at least DT works as expected…

Start your preferred terminal application, go into the folder in which you downloaded the AppImage, and type the following commands:

rm -f $HOME/.config/GIMP-AppImage/2.9/pluginrc
chmod u+x GIMP_AppImage-2.9.5-20170611.glibc2.15-x86_64.AppImage
./GIMP_AppImage-2.9.5-20170611.glibc2.15-x86_64.AppImage >& log.txt

and then post or send me the contents of the log.txt file…


New version of the GIMP 2.9.x AppImage for testing:

It now also provides nuFraw as RAW processor.

G’MIC-qt is still not included, but it is the next item on the list…

1 Like

I have updated the links to the standard and CCE GIMP AppImage packages in the “Community built software” page.

Please let me know if you encounter any issues with those new versions.

The new Qt-based G’MIC plug-in is missing from the AppImages, as I am still working on that…

Hello folks,

Hope this is the right place to ask.

I wanted to test the 2.9.5 version but i’ve an odd problem, that is i can’t paint at all. The only thing that is leaving a stroke on the canvas is the calligraphy tool. The brush, pen, mypaint brush, airbrush, healing tool, clonig tool aren’t working. Some other tools are working but not the ones i’m needing. I checked the opacity, mode, layer lock ect but everything was ok.

I’m using it in Fedora 26, XFCE desktop, all up-to-date.

If someone has an idea, i’m all ears.


Are you getting this problem only with the AppImage, or with the standard gimp as well?

no problem with the standard gimp 2.8

It would be nice if somebody could verify the same with a GIMP 2.9.5 version from a PPA or compiled from sources… maybe @Elle or @patdavid or some other gimp expert could help?

I can test later tonight.

I’ve never encountered any problem painting with default GIMP 2.9.5, except for a couple of odd bugs (nothing like described in this post) that most people wouldn’t ever encounter, and that have all been fixed.

For GIMP 2.9.5 compiled and updated this AM, and checking just now, all the brush tools work just fine. This is on OpenSUSE Tumbleweed, running Plasma 5, and sometimes IceWM, as the desktop.

I do have a problem with GIMP 2.9 occasionally crashing on Tumbleweed when using the Plasma 5 desktop. But this crash isn’t related to painting.

This is my home-spun appimage based on 'buntu 16.04 ppa gimp 2.9.5~127-0a4~ppa~3b19166 from two days ago.

Everything working fine. top to bottom: airbrush, paint, pencil, ink, mypaint, clone & warp

Curses, A quick look at the ppa and it looks like a new version is on the way. More work for tomorrow.

Ok i’m ashamed, i just figured it out. It was a stupid thing but i’ve never encountered it so it took me time to realize. I had to chose a brush form. There is 2 blank forms called “clipboard image” and “clipboard mask” and by default the brushes are set to the “clipboard image” form and nothing happen. When i choose the other ones it works again.

Sorry for the disturbance.

Next time i’ll try to be a bit more useful:slightly_smiling_face:

Thanks all for your answers.

Hmm, I’ve done the exact same thing after making a completely new install, just didn’t think about this odd “new install” behavior.

I think this “defaulting to the clipboard” might even be considered a bug. Why does the brush default to the clipboard the first time you use GIMP from a new install? And why are there two clipboards? Does anyone know? Should a bug report be filed?

Nope, it is equivalent to a greyscale brush and takes the foreground colour.

example Gimp 2.9.5 feature

Well, I know people do use the clipboard brush, and I’ve seen some nice examples of using this brush (I think @Americo has some on his blog). Obviously I don’t ever use these brushes myself, because until just now I didn’t even notice that one says “brush” and one says “mask” (not such good eyesight :slight_smile: ). So that explains why there are two clipboard brushes.

The proposed bug report would be about having the brush not default to the clipboard brush for new installs, as the brush defaulting to clipboard does seem a bit difficult to pinpoint for a new user trying to get the brushes to work. Filing a bug report isn’t high on my “to do” list unless other people really do think the current behavior causes predictable issues for new users/first-time installations.

Should I consider the issue as solved?

On a side note, and since we are discussing brushes: are there additional mypaint brushes that you would suggest to add in the package?


I would encourage any further problems be spun out into their topics, as it makes it a bit easier for newcomers to the thread to get caught up on specifics (there’s over 400 posts in this topic! :smiley: ).

Having been “surprised” by that default clipboard brush more than a few times, I went ahead and filed a bug report about having the default GIMP brush be something other than the clipboard:

The default GIMP brush should not be a clipboard brush