GIMP AppImage (continuous integration)

Not a bad idea, but before you do :wink:


Comments on your appimage. Is this the latest? gimp-2.9.5-20170702.glibc2.15-x86_64.AppImage Big file 200 MB This in Kubuntu 16.04 Tried to get everything in one.

Nothing to do with your appimage but nufraw stops svg files from opening. I actually like nufraw for the very occasional RAW images I take. However, I keep it away from my appimage in a separate plugins folder with permissions off until needed.

Additional MyPaint Brushes. Any of them, the full collection or extras, can always be enabled by adding a folder to the search path.

Just a note about the clipboard brush. Might come as a shock but most questions on Gimp forums do not concern photography. Plenty beginners have problems with paint does not work / as expected.
Top causes:
A tiny active selection.
Empty clipboard brush, because they have Save tool options on exit enabled.
Opened an Indexed image and do not know what ‘Indexed’ is.

I’ve recently discovered a tutorial on this site on using g’mic in gimp to clone out tripod / sky from the nadir / zenith on 360x180 degree panoramas: Panography - Patching the zenith and nadir

Certainly a heck of a lot quicker than doing it all by hand using the clone tool in Gimp!

1 Like

@Carmelo_DrRaw, Thank you very much for this appimage package! This works well in Kubuntu 14.04. Unfortunately PPA stop building Ubuntu 14.04 packages. But your appimage package save me. I hope you can continue to create GIMP appimage packages from time to time, for example current 2.9.7 :slight_smile:

Just to make it clear, there is no 2.9.7 release. It’s the name for the work in progress master branch. So 2.9.7 packages would merely be git snapshots, and calling them 2.9.7 would be confusing.


If using 'buntu 16.x best solution is upgrade, however do give up hope entirely. The otto-meier page Gimp at the edge : “Otto Meier” team updated their gegl and babl packages yesterday. I think these are backward compatible but as yet no Gimp 2.9.7 package for 'buntu 16.x

On the off-chance I ‘assembled’ an appimage and it looks like it works. Very definitely not extensively tested, this in a Stock Ubuntu ‘Yakkety’ VM

I’m really glad the package is working and useful for you! I am constantly updating the package when time allows, although not on a very regular and predictable basis :wink:
Anyhow, here is a fresh new package from the current git BABL/GEGL/GIMP code. I have also update the link in the Community built software page. From now on, the link will directly point to the packages hosted on GitHub.

Indeed, but still I believe that putting in the package name the official version number as reported by GIMP allows to better identify the version of the code provided by the package…

Just for information, did you test the AppImage I am providing? Do you have issues with it?

The reason I am asking is the following: I started to discuss with the GIMP developers the possibility for them to use my scripts for automating the AppImage creation process from their side (maybe to provide nightly snapshots in AppImage format), therefore any feedback about success or failure to run the package on different systems are very welcome!

@Carmelo_DrRaw, Thanks!. New appiamge package also works. Just a question. Here mention integrated WebP plugin in 2.9.6 release:

Is it just this same plugin?

@houz, Yes, periodic git snapshots builds is what I was really interested in, it is what the PPA does.
Regarding the name of the file to avoid confusion, perhaps “git” word could be added somewhere, for example “git-20170907” or something like that.

@rich2005, That’s right, here’s the explanation about why no more packages for Trusty and the problem is for a few months already:

About upgrading the distro, well, I have a very customized KDE 4 to my needs on 14.04, and I do not intend to switch to kde plasma 5 for now :slight_smile:

Is it just this same plugin?

I would say the version in GIMP is based on the plugin from nathan-osman but then extended.

When creating the AppImage, I am using 14.04 and I am building many of the dependencies, including GLib, from sources, in order to have up-to-date libraries not provided by the distro. The compiled packages get installed in a special prefix together with GIMP, and then bundled in the AppImage.

This would never be possible with a PPA, because too many packages apart from GIMP depend on GLib and would be broken. This shows one of the major limitations of the PPA paradigm, and why I decided to put efforts on AppImages…

So, to compile with WebP plugin, specify some flag is needed? Or did they include the plugin only for 2.9.6 release?

@Carmelo_DrRaw, WebP plugin is not included in appimage package, right? or am I looking in the wrong place?
Regarding you using 14.04, how do you do with qt5 stuff? Is it possible to install qt5 libraries in 14.04 to compile G’MIC Qt for example?

The new GMIC plugin is indeed still an issue I have to solve.

As for WebP, it might simply be that the development headers and libraries are simply missing on my system. I will look into that.

I’m sure you will solve it sooner or later. The current g’miclessness of the appimage is a problem for very spoiled users, many of us camping here. Thank you very much!


Hello, I have downloaded GIMP 2.9.5 AppImage. It works wonderfully on my version Linux Mageia 6. Also, my GIMP 2.8.22 installation continues to run in parallel. What does not work on GIMP 2.9.5 AppImage is the plug in Gmic. I have not found it in the package even though it is described:
“G’MIC plug-in version 1.7.5” is already included in this test version.
Ciao. Ernesto

Could you try the latest version from here? Currently the latest package is this one.

It works (2.9.9-20180315 plus gmic)! Thanks for your help :slight_smile: Ciao.Ernesto

1 Like

I happened to try this version an hour ago, on Ubuntu Studio 17.10 though, GMI’C worked fine and also updated the filters and external data without problems.

1 Like

Hi Carmelo_DrRaw, I already work now without problems with the version GIMP 2.9.9. applmage plus gmic that you linked to me. Is there the same package in version 2.10? Sorry I’m a bit unsure because there are so many versions now. :frowning: Ciao. Ernesto

@ernesto You can get a 2.10.1 package from the same release page: gimp-git-2.10.1-20180428.glibc2.15-x86_64.AppImage.
The development packages (those with a gimp-git- prefix) are build on a weekly basis, typically on Thursday evening, so you can have a look there regularly for updates…

I have some troubles building some of the plug-ins for the official 2.10.0 release (it is a known problem), so I am waiting for the first bugfix version to make a new release package.