GIMP AppImage (continuous integration)

(Joan Rake) #322

it was a problem with the file itself; i re-downloaded it, marked it as executable and the problem is fixed. gimp is installed. the only problem i have is with g’mic and any command i run with it beyond the first one though that’s a g’mic issue. this might actually be an issue with conflicts between the version in the appimage and the newer one which i have locally-installed.

(Carmelo Dr Raw) #323

If you still have a gmic plug-in in the




folders, could you please try to remove it and see if things work better? The AppImage is not supposed to run with local binary plug-ins. On the other hand, python-based plug-ins might still work properly…

(Joan Rake) #324

funnily enough, now it crashes straightaway, saying: Plug-in crashed: "gmic_gimp_gtk" (/tmp/.mount_wZwxi6/usr/lib/gimp/2.0/plug-ins/gmic_gimp_gtk)

i’ll reinsert the newer g’mic binary already tried and failed, obtaining the same error as before. it’s a case of replacing whatever’s within the appimage itself, but for that i’ll need peazip or something similar. with that, i’ve run into another problem: dependencies - namely having to download thousands of them it turns out that i’m wasting my time given that i can’t even use peazip to open it.

the strange thing here is that i was able to extract its contents manually before.

(Carmelo Dr Raw) #325

No, this you should not do… instead, we should understand why gmic crashes in your case, and eventually fix the problem and produce a new package.

Can you send the full terminal output after the gmic crash? That’s the starting point to understand what is going on…

(Joan Rake) #326

well now g’mic doesn’t even appear to be showing up in the menu. i’ve redownloaded both the appimage and g’mic 2.0.0. my only explanation is the package installs i’ve been doing; my machine has had at least two thousand packages installed today.

(Mica) #327

@Carmelo_DrRaw I am also on Ubuntu Mate xenial (16.04) and G’MIC crashes as well, my terminal output is here:

(Carmelo Dr Raw) #328

Thanks @paperdigits… I must admit that I am totally lost here… This is my latest GIMP appimage running G’MIC under an Ubuntu Mate Xenial Live CD:

Does G’MIC fail on a specific filter in your case, or immediately when started?

(Mica) #329

@Carmelo_DrRaw Some filters seem to work, and some don’t. Sometimes I can run a filter, but when I invoke G’MIC again, it won’t run. It is a bit perplexing.

(Joan Rake) #330

same here; it’s particularly my favourite filters such as ‘dream smoothing’.

(Carmelo Dr Raw) #331

I’m more and more puzzled, particularly because I have run the dream smoothing filter repeatedly on one image with the appimage under Ubuntu Mate Xenial, and never got any crashes… could it be a question of image size and/or memory?

(Mica) #332

My machine is a two year old core i5 with 16gb of ram. I opened a new image that was maybe 1000x1000px and drew some black lines with the paint brush… So I don’t think its my system.

(Carmelo Dr Raw) #333

Did GIMP crash while drawing? Or is the appimage generally stable except for the G’MIC plug-in?


(Mica) #334

It seems generally stable to me, though I haven’t pushed this particular version, only gmic crashes randomly, and not every time for me.

(Joan Rake) #335

it crashes or freezes every time i issue a second command for me.


I can reproduce that with gimp-2.9.5-20170310.glibc2.15-x86_64.AppImage in Kubuntu 16.04

Apply a filter. - that is ok Apply a second filter to the output and it fails.


A fix is take the output to a new file to apply the second filter. No shortcuts here, outputing gmic to a new file will fail.

edit: A better way is New from Visible then apply the second filter. That works here.


It might be the way the plugin is compiled, I asked David about it but understandably he is very busy.


Might be one of the 'buntu libraries to blame.

(Carmelo Dr Raw) #337

Really strange… the g’mic shipped with my appimage is compiled with cmake, so it doesn’t seem to be the root source of the problem. You say that you observe the same kind of odd behaviour when you compile yourself G’MIC with the standard Makefile in the src sub-folder?

Thanks for investigating!

(Joan Rake) #338

back on debian sid; i’m trying to install the appimage like i did on xubuntu but it’s not working, with the same errors that i originally had.

(Joan Rake) #339

why has nobody thought about fixing the issue on debian? i can’t install from source or from the ubuntu ppa.

(Mica) #340

You should not use PPAs for Ubuntu on Debian. This will certainly lead to breakage.

(Joan Rake) #341

noted; it did just that.