GIMP "sees" darktable, doesn't show plug-in


(Elle Stone) #1

With GIMP 2.9 updated and compiled today, and darktable 2.2.5 installed from Gentoo portage, GIMP 2.9 “sees” darktable, but in Preferences doesn’t provide an option to use darktable. Here’s a snippet from the GIMP terminal output:

[file-darktable.c] trying to call 'darktable'
[file-darktable.c] stdout:
this is darktable 2.2.5
copyright (c) 2009-2017 johannes hanika
darktable-dev@lists.darktable.org

compile options:
  bit depth is 64 bit
  normal build
  SSE2 optimized codepath enabled
  OpenMP support enabled
  OpenCL support disabled
  Lua support disabled
  Colord support disabled
  gPhoto2 support disabled
  GraphicsMagick support disabled
  OpenEXR support enabled

[file-darktable.c] have_darktable: 0

Does “have_darktable: 0” mean that for some reason GIMP can’t actually use darktable even though clearly GIMP detects darktable?

If it’s relevant, I used a “use flag” that told portage to compile darktable using ImageMagick instead of GraphicsMagick.


(Mica) #2

There taking about roughly the same thing for RawTherapee over here: Gimp gimp gimp !! :o)


(Elle Stone) #3

I did see that thread, but didn’t want to hijack the rawtherapee-oriented thread to ask about what might be a darktable build issue. The other thread seems more about how to use the RT plug-in, and in the past I’ve used both RT, darktable, and also PhotoFlow plug-ins without any problem.

The problem that I’m asking about is not “how to use the darktable plug-in” but rather "why does GIMP “see” that darktable is installed, but doesn’t show darktable as an option under “Preferences/Image Import”

But if someone wants to move my question to the other thread, that’s fine with me.


(Roman Lebedev) #4

I would bet that is at least partially the problem


(Elle Stone) #5

Thanks! I forgot about “lua”, though unfortunately there doesn’t seem to be a “lua” flag in portage for darktable.


(Roman Lebedev) #6

https://bugs.gentoo.org/show_bug.cgi?id=618104
https://bugs.gentoo.org/show_bug.cgi?id=592052

gentoo is fun, isn’t it


(Elle Stone) #7

Hmm, sometimes not so much, same is true of other distributions (ask me about my recent experiences with Debian and OpenSUSE, oh, wait, please don’t!).

Thanks! for the links. I guess the next step is to build darktable and graphicsmagick in the GIMP prefix.

Unless there is a way to build darktable from source without using graphicsmagick, and still have the GIMP plug-in work?


(Roman Lebedev) #8

i don’t see how graphicsmagick has anything to do here, only lua and exr are required. (IIRC)


(Elle Stone) #9

Hmm, you are right. I had already set this in CMakeLists.txt:
option(USE_GRAPHICSMAGICK “Use GraphicsMagick library for image import.” OFF)

But the build process still stopped with a complaint about GraphicsMagick, I’m guessing because I didn’t delete the original build folder. Sigh.

After installing lua from portage, and then deleting the darktable build folder, and then building again, now darktable is installed in the GIMP prefix, and GIMP sees darktable, and the darktable plug-in works - yeah! Thank you!


(darix) #10

And i just wanted to ask if you are using the opensuse package or self built :wink:


(Elle Stone) #11

Hmm, I think I didn’t express myself very clearly. I’m not being critical of OpenSUSE OR Gentoo. There are problems and issues with all operating systems, that might or might not affect any given “user+hardware” combination.

On OpenSUSE, darktable installed from OpenSUSE Tumbleweed worked perfectly with GIMP 2.9 compiled in a prefix. And I’m sure darktable compiled from source also would have worked perfectly.

On Gentoo, darktable compiled from source works perfectly. But using darktable from portage, there is a problem with the GIMP plug-in because of lua: currently Gentoo does supply lua 5.3, but looking at the Gentoo bug reports (and considering the lack of a lua use flag), darktable from Gentoo portage apparently hasn’t been updated to use Gentoo lua.


(Elle Stone) #12

For the record, Debian and OpenSUSE are two of my favorite Linux distribution. Currently I have Debian Sid on my laptop and OpenSUSE Tumbleweed on a machine in our office.

For my image editing workstation, I’ve run Debian, Ubuntu, OpenSUSE, and Gentoo, each for several years, starting with Debian back in 2007. Despite switching versions of Linux every few years, I’ve always used IceWM as my “desktop”, regardless of which version of Linux I happen to be running. Recently I switched my editing machine from Gentoo back to OpenSUSE, but I couldn’t get IceWM to work properly, so I switched back to Gentoo.


(darix) #13

hehe just wanted to point you to the master snapshot packages we have for darktable.