G'MIC Align layers, need help to get it work

Hi,

i try to use Align layers to align three misaligned photos, but i can’t get it to work.

Here is my workflow

  1. Load pictures as layers
  2. Open G’MIC QT -> Layers -> Align layers
  3. Set smoothness at minimum
  4. Input layers -> All
  5. Everything else left on default
  6. Preview shows aligned image
  7. Click OK, then there is processing for 5 seconds
  8. No aligment on my images

I try do do similar thing as Auto align layers in Photoshop does.
I also tried align_image_stack from Hugin, and it’s working perfectly. But i want to use one software if it’s possible.

So my question is, why is this plugin not working ? Is there some bug, or is there something what i need to do before or after this plugin is used ?

GIMP 2.10.12 , G’MIC 2.8.1 on Debian Testing

Thank you very much

Martin

That’s a quite old filter, maybe it needs revision.
Is it possible to have access to your images (maybe downscaled versions) ?

Thanks for your reply.

Here they are.

They are only for my testing, that’s why every image has different WB and is intentionaly misaligned. That way i can see if they are aligned when i set layer opacity to 50% :slight_smile:

Thanks

Martin

Thanks, that’s interesting.
When reducing the resolution (to 1024 px width) for a quick test, I got acceptable results with this filter. When I let the original resolution (6000 px width), it doesn’t work anymore.

I’ll check this later, but this seems to be a bug in this quite old (2010) filter.

Interesting :slight_smile:

Ok, i appreciate your help.

Thanks

Hello @David_Tschumperle

Just tried myself this plugin (G.MIC 2.8.0 with Gimp 2.10.14 on Windows 10).
I can not get it working either.
From its name I suppose I should get a new layer (or image) with all my layers aligned (stacked on top of each other)

Here is a Dropbox link with a ZIP folder with 3 jpeg images to align in case you need them for some more testing:

@David_Tschumperle

Btw, should i fill the bug report, or do you let me know when it will be fixed ?

No need to fill a bug report, I’m aware of the issue now :slight_smile:
Anyway, can’t say when it will be fixed.

Ok, no problem, just please let me know when it will be fixed.
Thanks

That should be fixed now, at least for the rigid alignment
(which is a bit misnamed, because it actually only manages translations, not scaling).

If you are using G’MIC 2.8.0+, just try the ‘Update filters’ button, and see if that works for you.

1 Like

Hi,

yes, now it’s perfect.

Thank you very much for such a quick work.

1 Like

Dear David, it does not work for me, also after the update. GIMP 2.10.14, G’MIC 2.9.0 on Windows. Preview shows the right alignment, but the output layers are not aligned.

Hello @Wladimir_K

Just out of curiosity, I have just tested myself this filter.
I also run G’MIC 2.9 with GIMP 2.10.18 (on Windows 10).

To test this filter I have downloaded the ZIP with 3 jpeg images: see 3° message of Komodo Martin, on this same thread, where he posts his link on Nextcloud (GMIC-Align).

On my setup it works.
In that all 3 layers are correctly aligned.

@Wladimir_K Welcome to the forum!

Sometimes update doesn’t work. Try again later.

Please tell us where you got GIMP and G’MIC from. Usually the source, how you downloaded and installed it, plus the OS, makes a difference.

I downloaded the G’MIC from this site: https://www.fosshub.com/GMIC.html?dwl=gmic_2.9.0_gimp2.10_win64.exe

GIMP was downloaded from the gimp.org

It was just normal windows installation

I have win 10 x64

Maybe I’m doing smth. wrong. I’he tryed all possible setups, Rigid, Non-Rigid, smoothness from 0 to 1, it does nothing. The resulting layers are just equal to the input layers, their position did not change.

Just to be sure : have you set the Input mode to All layers for this filter ?
One could easily forget it and get no result at all.

Hello @David_Tschumperle

Just tested on:
Windows 10 (64 bit)
GIMP 2.10.18
tested both G’MIC 2.9 and G’MIC 2.8.4

I have downloaded the GMIC_ALIGN zip file from this same post in order to have a commun base to check the 3 jpeg images within this folder.

With both 2.9 and 2.8.4 G’MIC versions the 3 layers (jpeg of the zip) are not cropped.
When you check with GIMP the result, the 3 layers look aligned though (but are not cropped to make them fit).
In the past I recall they were also cropped to fit them.

I’he set input mode to “all visible layers”.
I found also an interesting issue, the alignment works sometimes for images which was previously edited by Hugin’s software.
If I take the *.jpg images directly from my camera, the alignmet doesn’t work. Here you can try my set: https://drive.google.com/open?id=1p__ckKxdzL6yYpssZx-oPKg01meJOXWm

Thanks @Wladimir_K for providing me the data to reproduce the bug.
It seems the phase correlation method I’m using for registering the images doesn’t work quite well with large images. I’ve made a fix, and currently generating the filter update with it.

Maybe you could check in a few minutes (10-15 maybe), by refreshing your filters, and try the filter again, with the rigid mode.
Waiting for your feedback :slight_smile: