G'mic for Gimp 2.10


(Edward Ingram) #1

Are there plans to make G’MIC able to run on gimp 2.10? I’ve tries copying the plugins for 2.8 into 2.10. No good.


(Mica) #2

Yes, there are plans, but the plans have not been executed yet.


(Lyle Kroll) #3

Samj’s portable contains G’MIC and works great (she actually includes both gtk and qt versions). Do have a question, though. I know that G’MIC can handle higher bit depth, but, does G’MIC translate the result to 8 bits or does it recognized the bit precision and passes the higher bit depth level result to GIMP accordingly? Just curious.


(David Tschumperlé) #4

@samj is about to provide a new compiling environment for Windows, so yes, if everything goes well, I should be able to compile the G’MIC plug-in for GIMP 2.10 (on Windows) by myself in a few days/weeks :slight_smile:
There are already versions of the plug-in for 2.10 existing anyway on these pages :
https://www.partha.com/
and
https://github.com/dtschump/gmic-community/blob/master/compilation/plug-ins_GMIC_GIMP_GTK_for_GIMP-2.10.0_20180430.7z


(David Tschumperlé) #5

Good news, thanks to @samj, I’ve been able to compile the G’MIC plug-in for latest version of GIMP 2.10, for Windows users (64bits version).
Installer and .zip archive are available here : http://gmic.eu/download.shtml

I’ve tested it quickly along with the official GIMP 2.10 installer, and it seems to work (see screenshot below).
Feedback appreciated !


(Lawrence Gray) #6

I have been unable to successfully open G’mic in Gimp 2.10, on my machine after using the installer package under windows 7-64bit. On Gimp startup I keep getting an error

“procedure entry point ‘g_getenv’ not located in libglib-2.0-0.dll”

Only after deleting the G’mic installation and unpacking the zip package into the same directory that the installer used did G’mic operate in Gimp. I have never needed to use the zip package before to install G’mic, so I was surprised to see that a different set and reduced number of files are used. Even the offending file above was not present.

Is there a problem with the installer? I was surprised that no one else had reported this up till now. And why is there a different set of files for the zip package?


(samj) #7

Bonjour,

Here are the files to run both versions of G’MIC with Gimp 2.10.0 Win-64:

└───plug-ins
    ├───gmic_gimp_gtk
    │       gmic_gimp_gtk.exe
    │       libfftw3-3.dll
    │
    └───gmic_gimp_qt
        │   gmic_gimp_qt.exe
        │   libfftw3-3.dll
        │   libicudt61.dll
        │   libicuin61.dll
        │   libicuuc61.dll
        │   libpcre2-16-0.dll
        │   Qt5Core.dll
        │   Qt5Gui.dll
        │   Qt5Network.dll
        │   Qt5Widgets.dll
        │
        └───platforms
                qdirect2d.dll
                qminimal.dll
                qoffscreen.dll
                qwebgl.dll
                qwindows.dll

That’s all …

:o)


(Lawrence Gray) #8

Yes, thank you for the reply. This is what I now have and G’mic works fine after using the zip archive.

But these are not the files that the executable installer provided. Am I the only one to have a problem with the installer?


(David Tschumperlé) #9

@lhgray, I suspect you have an old version of the plug-in somewhere that is maybe considered prioritary by GIMP. The installer works for me, and create the gmic_gimp_qt folder, exactly as @samj showed.
Please tell us where your plug-in is located and what files related to G’MIC are there.


#10

Hello,

Seems that the issue come from the default path in the installer :
It copies the files to C:\Users\Name\AppData\Roaming\GIMP\2.10\plug-ins\gmic_gimp_qt

while plug-in folder for 2.10 is C:\Users\Name\AppData\Roaming\GIMP\2.10\plug-ins


(samj) #11

Bonjour,

The organization is given in this message :

It is necessary to have the directory ‘gmic_gimp_qt’ to conform to the new organization of Gimp 2.10 plugins.


(Rick Taubold) #12

Hoping for a 32-bit version soon?


(David Tschumperlé) #13

Yes, probaby :slight_smile:


(Lawrence Gray) #14

Yes, I did have a version of 2.9.8 with gmic installed as well. After removing this, I can confirm that the installer works and installs the correct files exactly as @samj showed. ( without the gmic_gimp_gtk folder )


(Jason ) #15

@David_Tschumperle Hi there, is Gmic working on gimp 2.10 for Ubunutu 18.04?

I have tried everything to install it but my Gimp simply cannot find the plugin?

numerous removal of files and re installs, I’ve used the PPA and even re installed 18.04 incase that was the problem but no luck.

could you advise please?


(David Tschumperlé) #16

Actually I cannot say.
I’ve not tried to compile it for GIMP 2.10 on Linux right now (had no time for that).
All I can say is it was working fine with GIMP 2.9 from the gimp-edge PPA, a few months ago.
When I’ll have a bit more time, I’ll give a try.


(Jason ) #17

no problem thank you for your help. Someone on the internet claims to have got it working with no problems. he’s the only person I have spoken to who has said this.

claims he did it using the sudo apt get method… where would this repository be? the PPA?


(Jason ) #18

@David_Tschumperle if it helps I see this - gimp is already the newest version (2.10.0+om-1ubu18.04.1~ppa).
gimp set to manually installed.
gimp-gmic is already the newest version (1:2.2.1+om-ubu18.04.1~ppa).


(David Tschumperlé) #19

Unfortunately no, latest stable version is 2.2.2, and I think 2.2.1 will not be updated anymore with new filters and fixes (but is still working anyway).


(David Tschumperlé) #20

OK, I’ve just installed GIMP 2.10 on Ubuntu 18.04 Bionic (LTS), using the PPA from otto06217 : https://launchpad.net/~otto-kesselgulasch/+archive/ubuntu/gimp

The good news is that with that configuration, the “old” G’MIC plug-in (compiled for 2.8) works out of the box. I just had to copy the gmic_gimp_qt file in $HOME/.config/GIMP/2.10/plug-ins/, and after I run GIMP, I see the latest version of the G’MIC plug-in working as expected (see screenshot below, with G’MIC verion 2.2.3_pre development version).

As the title bar of the plug-in says, this is the plug-in initially for GIMP 2.8. But I got no issues with it on GIMP 2.10. If you are running another OS or version or Ubuntu, this may be different anyway.

I’m now trying to compile the plug-in binary from the current state in the git repo, so specifically for GIMP 2.10. I’ll tell you if that is working or not.