G'MIC OFX plugin not showing in Sony Vegas Pro 13


#1

I downloaded the OFX from reduxfx/Tobias_Fleischer, and followed the instructions, but for some reason, I cannot see the G’MIC plugin files anywhere. I even
copied the folder to the folders that relates to OFX/plugins both from Program Files and Program Files (x86) Can you please help me get them to appear in Vegas? Thanks. I also sent my problems to reduxfx via email. I wanted to post it here just to be safe if Tobias is inactive mostly, or if there’s a chance someone knows how to it.

P.S. I also added the effects on After Effects but it crashed on me at the startup.


(Mica) #2

I think it is @Tobias_Fleischer.


#3

I know. Do you mean he’s more active on pixls.us than reduxfx?


(Tobias Fleischer) #4

Hi guys,
I will take a look at this issue tomorrow and get back to you.
Cheers,
Toby


#5

Thanks.


(Tobias Fleischer) #6

I found and fixed some bugs in the OFX implementation. I don’t have Vegas anymore, but tested the OFX with Natron. This is still beta, so more/other bugs might occur, but at least I could use the plugins.
You can get the latest Windows 64bit binaries of the G’MIC plugins in OpenFX and After Effects plugin format from here: http://reduxfx.com/gmic/20190218_gmic_ae_ofx.zip

Just copy the appropriate folder to the plugin folder (or point to it) in your host application. You will also need to make sure that the libcgmicstatic.dll (also included in above download) is somewhere in your path and that there is only one instance of this DLL on your system.

Let me know how it goes with this release.

Cheers,
Toby


#7

I still don’t see it in Vegas. Maybe you can install Vegas to fix the bug to make it easier for you. Also, can you please be specific where does the DLL go, and what’s the default plugin name in the Vegas effects list? Thanks. Maybe it’s the fact that the OFX needs the .gmic files? Also, AE crashed on me again.


(Tobias Fleischer) #8

I will try to install Vegas in the next days and test with that.
The OFX plugin does not need any .gmic files. If the OFX file is loaded by the host, about 400 seperate G’MIC plugins should appear in the host’s plugin section.
As for libcgmicstatic.dll, just put it in a folder that is also listed in the PATH environment variable, or extend the path with a new folder and put it there.


#9

Okay then. Also, AE CC 2019 crashed on me again.


(Tobias Fleischer) #10

Working fine here with AE CC2019. Maybe you still have an older DLL in the path somewhere?


(Tobias Fleischer) #11

Just tested with the trial version of Sony Vegas Pro 13, and the G’MIC plugins are recognized immediately. They load up fine and all parameters are accessible, however they don’t seem to render on the video. Not sure if this is a limitation of the Vegas demo version or if there is still something wrong in the renderer, but at least the plugin loading seems to be fine here.


#12

Odd, mine doesn’t show up. How did you manage to add the plugins? Was there something missing like Natron? Plus, that’s render bug is not the trial limitation. You just need to fix that bug.
image


(Tobias Fleischer) #13

It seems Vegas 13 has problems with some OFX in general, even the standard OFX example plugins don’t work there (they work fine in Vegas 15) - same behaviour, no rendering. Debugging showed that the rendering function is not called at all in these plugins, so it is at the moment this is not a fault with the G’MIC plugin. I will further investigate, but this could take a while.


(Tobias Fleischer) #14

So as suspected, Vegas 13 has a very poor implementation of the OFX standard with many bugs, even with the test plugins that come with the OFX SDK. I managed to work around most of them now, I think.
Here is a new release: http://reduxfx.com/gmic/20190218_gmic_ae_ofx.zip

@MKdmn: I think the issue you are seeing is not related to that, as the plugin should have been showing up in the list regardless of the render issues already. Probably there is an issue with the libcgmicstatic.dll. Try the following steps:
Search your hard drive for any existing libcgmicstatic.dll occurences and delete/rename those files.
Then run a command prompt (“cmd”) and type “path”. It will list all the directories in the path variable. Put the libcgmicstatic.dll from the archive linked above into any of the directories listed (just the DLL directly, not in a subfolder)


#15

The good news that they appeared, the bad news that I can’t see the effecst.


At least only some worked but it made the video upside-down.

Also, can you please add an option to go beyond the slider intensity for me?

On the other hand it worked well in AE, even though a bit have problems.

Plus, Do you know how to make them faster in processing?


(Tobias Fleischer) #16

The upside-down video thing is a flag, will look into it.
No idea what slider intensity you are talking about, but I can’t influence the UI components and values, they are read from the G’MIC library and sent to the host for displaying.
Some plugins might not work correctly, yes.
And concerning the speed, this is as good as it gets at the moment. A test branch with multithreading is also available, but causes problems in some hosts that are not compatible with multithreaded OFX plugins (like Vegas). Under advanced options you also have the possibility to reduce resolution or change the mode to inline, which will help with some plugin to make them faster.
All in all, it is still very experimental and beta, and I hardly have time to work on it, so progress will be slow.


(Tobias Fleischer) #17

Another day, another version:
http://reduxfx.com/gmic/20190220_gmic_ofx.zip

This one fixes many bugs and is much faster. Archive only included OFX for Windows at the moment.

Cheers,
Toby


#18

Still blank for some reason.
At least it’s not upside down anymore. And I can see some more effects shown like Cartoon and Frame cube.


(Tobias Fleischer) #19

Certain effects might use a new syntax that requires the presence of the latest (2.5.0pr) G’MIC standard library (which is still in pre-release state at the moment).
So for example for G’MIC Edges to work again, please download this file:
http://reduxfx.com/gmic/gmic_stdlib.gmic
And put it in the G’MIC ressources path (the folder where G’MIC also puts its updated scripts and external files it needs). Usually this is c:\Users\[USER]\AppData\Roaming\gmic
When restarting the host and plugin, it should then use the latest definitions from this file.
I just tested it and edges work using this approach.
I will also compile this into the binary at some point, once it is out of pre-release.


#20

Some effects got mixed up where 3d elevation is Truchet, but hey, at least it finally works, even the rendering (which took slow for almost 10 mins)


At least this little thing helps me what effect it actually is.
image

What would be nice is to have the effects stop going random every time I go on the same frame. That would help with the RAM preview.


and fix these too, please.
image

I think you could do make a team to create a fully functional plugin through collaboration.

Also, the film presets are here, but they don’t work at all, even in AE.

Plus, when ever I undo something, this comes up.

It switches back to the original non-switched effect or removes it.