Help test RawTherapee on Retina/4k etc HiDPI monitors.



!!! You must use a TooWa… theme for testing.


Yep, just got that piece of info. Actually, I still think of you as TooWaBlue…


Fine, @HIRAM seems to be happy with my present dumping method.
So: I’ll just go a-dumping.



6 dumps mailed to @HIRAM
TooWaBoo theme
Editor in 3 res
File Browser in 3 res

Have fun!
Claes in Lund, Sweden


Can you tell us your system dpi settings, please?




This is the screen resolution. All your screenshots look like 96dpi. We need to know your dpi setting.

An 192dpi example on Windows.


macos 10.14.2
27-inch (5120 x 2880); imac 5k <-- 2560 retina HDPI mode

edited to specify display mode

(Jean-Christophe) #29

@chroma_ghost The icons on your screeshot are pixelated (upscaled), that was unexpected :frowning: . Is it possible to start RT from a command line and past the debug output here ? Also, what is your system wide DPI / Scale settings (don’t know how it works on MacOS) ?

(Jean-Christophe) #30

Here is a post that explain what how to test the hidpi-icons branch.

(Morgan Hardwood) #31

When testing, please:

  1. Ensure that you are using a build from the hidpi-icons branch and not from dev, and that you’ve set RawTherapee to use a TooWa* theme and restarted it afterwards.
  2. Tell us your DPI setting, screen size and current screen resolution, or paste the output of:
    xdpyinfo | grep -B2 resolution
  3. Tell us which display system you’re using (X11, Wayland, Mir, etc.) .
  4. Test the items listed in @Hombre’s post.
  5. If uploading a screenshot, do not crop it, do not resize it, do not remove the window frame or titlebar.

In a nutshell, you’re testing whether the elements of the RawTherapee window (text, buttons, etc.) are of the same size as those of the rest of your system (compare to e.g. a web browser). RawTherapee’s icons, thumbnails and the main preview should be sharp.


dimensions: 1920x1080 pixels (508x286 millimeters)
resolution: 96x96 dots per inch

screen #0:
dimensions: 3840x2160 pixels (1016x572 millimeters)
resolution: 96x96 dots per inch


Try setting dimensions to 3840x2160 and resolution to 144dpi, please


I always use the 2560 HDPI mode (corresponding to the dumbed down “Default for display” in the System Preferences Pane), the computer is more responsive and I can actually read.

Nevertheless, bumped to 5120 x 2880

10pt font

RT_out10.txt (652 Bytes)

14pt font (with RT restart)

RT_out14.txt (652 Bytes)

In the terminal I ran the rawtherapee binary within the MacOs folder
Theme TooWaGrey Dark


Why don’t you use 5120 x 2880 and change the 72dpi to 144dpi?


Honestly never crossed my mind. Is it better (both IQ & responsiveness wise), do you use that on your imac, can you really tell the difference? How would I go about it? :mag: :eye:


I don’t have a Mac but to get the best and clearest image you have to use a monitor in its native resolution. With dpi you can control the size. I don’t know how to set it on a Mac.


Reading back…

Why don’t you use 5120 x 2880 and change the 72dpi to 144dpi?

I think ( makes more sense to me) your question probably is why don’t you use 2560 at 144dpi? No?

If so that’s what AFAIK (quoting myself now, basically an ostrich with head inside butt) the

{…} 2560 HDPI mode (corresponding to the dumbed down “Default for display” {…}

is doing. If yes we’re on the same page, if not lets have a beer or three first ,-) :beers:


Here they are:


(Jean-Christophe) #40

@chroma_ghost Maybe I missed something, but you say that the native resolution is 2560, what do you mean by “bumped to 5120 x 2880” ? Upscaled ? And why is your jpeg 6300px wide then ?