horrible red frames around all elements and way huge icons in dt 2.4.4


(Stefan Schmitz) #1

Howdy,

I just upgraded to ubuntu 18.04.1 and now - when opening dt, there is a red frame around every element and all icons are very big. Way too big. dt looks like some prep-school toy.

When I start dt in a terminal, I get this:

stefan@outpost:~$ darktable

(darktable:6632): Gtk-WARNING **: 22:25:37.077: Theme parsing error: gtk.css:27:35: Junk at end of value for background-color

(darktable:6632): Gtk-WARNING **: 22:25:37.077: Theme parsing error: gtk.css:40:48: Junk at end of value for background-color

(darktable:6632): Gtk-WARNING **: 22:25:37.077: Theme parsing error: gtk.css:48:46: Junk at end of value for background-color

(darktable:6632): Gtk-WARNING **: 22:25:37.077: Theme parsing error: gtk.css:59:58: Junk at end of value for background-color

(darktable:6632): Gtk-WARNING **: 22:25:37.077: Theme parsing error: gtk.css:66:28: The :prelight pseudo-class is deprecated. Use :hover instead.

(darktable:6632): Gtk-WARNING **: 22:25:37.077: Theme parsing error: gtk.css:70:46: Junk at end of value for background-color

(darktable:6632): Gtk-WARNING **: 22:25:37.077: Theme parsing error: gtk.css:77:35: The :prelight pseudo-class is deprecated. Use :hover instead.

(darktable:6632): Gtk-WARNING **: 22:25:37.077: Theme parsing error: gtk.css:81:58: Junk at end of value for background-color

(darktable:6632): Gtk-WARNING **: 22:25:37.163: Theme parsing error: darktable.css:21:14: Using Pango syntax for the font: style property is deprecated; please use CSS syntax

(darktable:6632): Gtk-WARNING **: 22:25:37.163: Theme parsing error: darktable.css:36:26: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(darktable:6632): Gtk-WARNING **: 22:25:37.163: Theme parsing error: darktable.css:206:28: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(darktable:6632): Gtk-WARNING **: 22:25:37.163: Theme parsing error: darktable.css:371:50: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(darktable:6632): Gtk-WARNING **: 22:25:37.163: Theme parsing error: darktable.css:372:37: The :insensitive pseudo-class is deprecated. Use :disabled instead.

(darktable:6632): Gtk-WARNING **: 22:25:37.164: Theme parsing error: darktable.css:442:30: The style property GtkWidget:wide-separators is deprecated and shouldn’t be used anymore. It will be removed in a future version

(darktable:6632): Gtk-WARNING **: 22:25:37.164: Theme parsing error: darktable.css:443:30: The style property GtkWidget:separator-width is deprecated and shouldn’t be used anymore. It will be removed in a future version

(darktable:6632): Gtk-WARNING **: 22:25:37.164: Theme parsing error: darktable.css:444:31: The style property GtkWidget:separator-height is deprecated and shouldn’t be used anymore. It will be removed in a future version
dt_gui_gtk_init: error parsing /usr/share/darktable/darktable.css: darktable.css:21:8not a number

what am I up against and how can I kill it?


(Stefan Schmitz) #2

all good - I removed dt, did an autoremove and installed dt again. Now things look like they should and there are no more errors


(Mica) #3

It was the gtk theme, it looks like.


(darix) #4

also check if you dont have a darktable.css in your ~/.config/darktable/ dir


#5