How do I convert Black&White results to alpha mask use?

this png need to download to see clean.

I found this Removing the background color without chroma key (Luma matte/alpha) - #2 by El_Director

He say “Set the mask to the red channel and it should work”

but my merge node doesn’t have Color.R.

At first I used Z depth in two exr and then converted to Black&White, but this shows that it only has RGB channels,it alpha channel is all white.

I tried using “chromakey” node to make black transparent but not working.

I need to change to alpha to use as a mask… How can I do this?

Thank you all first.:slightly_smiling_face:

You can use the ‘shuffle’ node, and copy the Alpha channel to the red channel.

Hi! but my alpha channel is all white now,copy the Alpha channel to the red channel,can work?!

sorry…My brain is now in chaos…

The result of my attempt is this,it RGB channle now like this, but it alpha channel is still all white.

From what i see in your first screenshot, it’s working.
The color bars are merged according to the mask input.
What do you want to do exactly ?

Sorry, I may not express well.

I want to turn Black&white into an alpha. I want let black area turn transparent.

like this image,this image is alpha channel in exr,but this is not the same file as the B&W image.

and first screenshot, it’s not working. left is not my screenshot,right is.

It is in RGB channel, not in alpha channel,my alpha channel is all white.

Plug the black and white image to the merge mask input, and select ‘red’ in the mask Channel

But this is my problem too,I don’t know why…the mask channel only has “None” Option.

If nothing is plugged into the mask input, it displays ‘none’.
As soon as you plug something to it, you get a choice

I will try again.

Oh, my god… I may be too confused, because I have been trying to find a solution for a long time, and there is an answer in the original answer…

I always use the B channel as a mask channel.

No wonder there is nothing in my mask channel.

Thank you again :slightly_smiling_face:

You’re welcome :slight_smile: