I can't get Darktable to work anymore

Darktable 4.4.2
Windows 11
I’ve tried reinstalling last version, reinstalling current version, I’ve rolled back windows updates, deleted the entire Darktable directory, made sure no Smart app protection is on.
I used Darktable 4.4.2 for a few days no problems.
Went to open it as usual today and it doesn’t.
Nothing happens at all, after doing all of the above.
When the previous version that I’ve used for a year or so doesn’t do anything.
I’ve turned off antivirus.
I’m at a stand still now.
What can I do?
I’m sure it’s a Windows thing, but can’t figure out what it is

Try to start darktable from the command line. See faq | darktable section “Windows” how to do that. Post the log here, so someone can have a look.

if you once started darktable 4.4.2 successfully, older versions won’t start since they can’t read the new database structure.
That’s logged to the log file you can find in


Maybe rename


to something different so darktable run with clean settings…

Most software originating from Linux stores its configuration and data in a directory, which is not removed when the software is uninstalled (there is no registry like in Windows). Darktable is the same in this regard. Reinstalling darktable rarely helps (only if the software itself gets damaged, e.g. due to a hard disk failure).
As @MStraeten said, this directory is C:\Users<username>\AppData\Local\darktable; if you rename that directory (e.g. to darktable.backup), it will be re-created with default settings.
The log he mentioned, C:\Users<username>\AppData\Local\Microsoft\Windows\INetCache\darktable\darktable-log.txt, is in a hidden directory; either paste C:\Users\<username>\AppData\Local\Microsoft\Windows\INetCache\darktable directly into your Explorer (replacing <username> with your user name), or configure your Explorer to show hidden files (View hidden files and folders in Windows - Microsoft Support).
That log file can be opened in e.g. Notepad, and may contain details about your issue.

I did all as instructed… Renamed the directory, and file.
Even deleted both, after installing DT.
Then, reinstalled it.
Still the same.

Just now…
I deleted the above mentioned Darktable directories.
And, any mention of Darktable from the registry.
Reinstalled, and the same results.

Can you post the log files?


Without seeing the logs, it’s like poking in the fog…
Start darktable from the command line with debug option -d common or -d all to hopefully get meaningful output to the log file.

That means:

  1. press [Windows key + R] → type cmd, press Enter
  2. type "c:\program files\darktable\bin\darktable" -d common, press Enter (or -d all instead of -d common)

The logs will be in C:\Users<username>\AppData\Local\Microsoft\Windows\INetCache\darktable\darktable-log.txt.

If your Windows is not English, the paths may be different. For example, instead of Program Files, it could be many other translated paths (Program Files - Wikipedia).

1 Like

After everything, completely fresh install of windows, no updates.
The log file contains the same line as previous:
"Magick: caught exception 0xC0000005 “Access Vision”. …Magick: caught exception 0xC0000005 “Access Vision”…

At this point, I’m pretty disgusted with the whole thing… I’ve spent the last year learning DT, and loved it.
Looks like I’ll have to scrap it.

Joe, run these commands. You have nothing to loose by doing so.

chkdsk /f /r C: (assuming that C is your O/S drive)


Have you tried this… create a new shortcut for DT… add to the command line… --configdir “path” in the quotes provide the name of a new empty folder… And now try to run DT using this short cut…

Doe it work?? if so your config files in the normal locations might have an issue… I am running on Win11 and touch wood have had no issues…

EDIT any change you have a gamepad loading…one user reported this issue and it was fixed by uninstalling the gamepad drivers… For sure this has been reported before searching this forum and the github site might turn up something…

Not Access Vision, but rather Access violation.

Image Magick is an external tool darktable uses for some formats. If it’s OK with you, I’ll add a comment to that issue. The developers will be able to support you, but it will take some time and patience.

I’ve opened this for you, but I cannot supply a log file or details:

Before you throw away everything you’ve learnt, you could also try the latest development build (which will become darktable 4.6, come Christmas). Maybe it has already been fixed, maybe not.

If you could post the log file here (attach it as a .txt), I could attach it to the bug report I created. Of course, if you have / are willing to create a GitHub account, you could do that yourself, as well.

Here’s that log file… thank you all for any help.

darktable-log.txt (171 Bytes)

Is that with -d all?

no. just the regular txt file… I’ll try to figure how to run the way that you said, but I have to apparently be in the same directory to run it… It just says it’s a bad command.

Please try the alternative shortcut using clean config files. You have installed reinstalled etc etc. This could still leave a residual mess. Running using new config files in a new location might reveal if there is an issue or that you have some residual corruption floating around in your system… ignore these comments if you have tried this and I missed it

Todd, he has already tried that.

And also I can't get Darktable to work anymore - #10 by Joe_Sabo