I need help with G'MIC preview error

I’m using Gimp Appimage 2.10.21. When I open many filters with the preview box checked, I get an error message. In this case it’s the Dream Smoothing filter. What do I need to do to avoid this? It’s not obvious to me. Video tutorials on Youtube don’t address this,. (None that I have looked at .) Could someone point me in the right direction? Thanks in advance!

I don’t get an error but a timeout because my system takes too long, and no problems for smaller images.

I tried scaling down to 800x665 pixels. Same result.

Same error message for your smaller image? It seems to suggest that the image timed out but I don’t get an error regarding apply_timeout, just a notification that the process timed out.

Did you have this issue before? Could be your app image, or your installations of GIMP and/or G’MIC.

I haven’t used G’MIC in quite a while. The previews used to work but I honestly can’t recall how many years ago that was.

My suggestion would be to uninstall and reinstall both. Quite often when people follow this advice, it works again. Other than that, it could be the AppImage…

It is the version of gimp_gmic_qt that comes bundled with the appimage-with-tools. I use the with-tools version, it is up to 2.10.23 now. You can see from the screenshot the plugin is 2.9.2 and dated 03 July '20 , the filters are updated to the current 548. Lots of changes to to gmic code since July. Get an up to date plugin, put it in ~/.config/GIMP-AppImage/2.10/plug-ins/ and it should supercede the appimage version.

Running a 2.10.21 appimage in kubuntu 18.04 and gimp_gmic_qt I compiled a couple of days ago looks like this.

Depends on your version of linux. See what works from those on the gmic website. No good using an installer, get the plugin and put in the Gimp profile.

I updated the Appimage to 2.10.23 with plugins. The G’MIC version is G’MIC-Qt for Gimp 2.10 - Linux 64 bits - 2.9.2_#pre200703 and filters are updated showing 548. Still the same result.

BTW, I’m using Ubuntu Studio 20.04.

That is because the version of gimp_gmic_qt is still - 2.9.2_#pre200703 ie. 3rd July 2020 It has not been updated in the automatic builds for some time
Get this one https://gmic.eu/files/linux/gmic_2.9.2_gimp2.10_ubuntu_focal_amd64.zip dated 3 Sept 2020
Unzip it. Should already be executable but check anyway. Put it in ~/.config/GIMP-AppImage/2.10/plug-ins/
It should supercede that older version in the appimage.

I tried that and G’MIC does not appear in the filters menu. So I removed it, G’MIC is back and I’m back to the same error message.

I know, already been checking. Why is nothing straight forward with 'buntu 20.04 (rhetorical)
Had to fire up my (home) office desktop with kubuntu 20.04 / Appimage 2.10.23 as a check and the gmic file does not even show.
Best I can offer is this, my gimp_gmic_qt from a couple of days ago.
https://u.pcloud.link/publink/show?code=XZH045XZOYVuwkWpIU7sCfyWt99Jbj6Y6rwV unzip put in Gimp profile
Working here:

1 Like


Ta Daaa…
@rich2005 That works! Thanks so much!

@rich2005 delivers as usual. :slight_smile:

Another potential trick is renaming the file. Sometimes that works for me.

1 Like

Yes, he sure did! Some of the filters timeout but most I have tried work fine. Having the preview is so time saving compared to changing a setting, running the filter and hoping the outcome will be better than the last one. :relieved:

This is a bug in a dark theme in GMI’C:

Switch to the default theme in the GMI’C settings and everything works fine.

2 Likes

@s7habo Thanks for the tip!