Import pictures from Canon 80D

Hi there! I’ve been using LR many years but decided to jump into Darktable. At least I try. Because it stops right from the beginning: I can’t import pictures. I’ve been watching several tutorials on Youtube, but things look different there. I’ve tried three different PCs, both Windows Seven and 10, but with the
image
same result. Darktable regognizes 80D, but now files are shown. Clicking on wether “add to library” or “copy & import” have any result. Thanks for help. Ron from Norway.

Take a print screen of how it looks after you pressed copy and import. Btw, is it possible to press Mount camera?

image
image

I see. Do you have a card reader also?

Hi Peter! If I press on “mount camera” I get this message:


But that message have I got on all computers.
Thanks for helping!

No, not on this PC at my job… :grinning:

Never tried from camera. Only card reader. No problem to move the files in Windows into the right folder?

At home I can import files with the original Canon software, store them and then import them, but I can’t do it at my job. And besides that: in all the tutorials isn’t that a problem at all.
And it is obvious that Darktable regognizes my camera, but after that…?

Same problem here https://www.reddit.com/r/DarkTable/comments/perupv/need_help_mounting_camera/

:grinning: I saw that one also, but there seems to be no solution. :face_with_monocle:

What if you unmount from Windows?
https://docs.darktable.org/usermanual/3.6/tethering/overview/

Sorry Peter, I had to join a meeting yesterday. I have tried tethering, but Darktable answers that there isn’t a unit mounted which is usable.
I have also tried my Ipad and Iphone with the same result. Darktable regognizes the units, but nothing more than that. I have downloaded Darktable on my private PC and I’ve got downloaded the software on my job PC by our own data support. Nothing is functioning.
The firmware on my Canon 80D is quite new also. I am really getting mad.:sob:

Did you unmount/eject 80D from Windows first before you tried to mount in darktable?

I have tried, but I am quite unsure if I really have understood how to do that. At least I have changed the setup, which enables the Canon software automatically to connect the camera. But nothing has changed.

Will try later to check myself, both in Ubuntu and Windows 10 in a VirtualBox.

I have also tried to follow the troubleshooting meny. But the commands written there doesn’t give me a meaning. env lang=c gphoto2 --auto detect- and the others.

I don’t know how to use those commands.

In Swedish about gphoto2 Byt upphovsmansnamn i din Canon – Kameratrollet

Hope you speak Norwegian and not just living in Norway.

Gphoto2 is for Linux and OS X so I don’t know if that is your main problem.

I am lucky speaking english, norwegian, german and dutch. I can read swedish and danish. No problem with that :grinning: It seems that this swedish information is used in Linux. My PC doesn’t react on the short command Ctrl-Shift-T. But I have changed the writer information in my camera. But that doesn’t help.
I was thinking that it is a problem with norwegian (because we have som letters which are unusual øæå) and that Darktable somewhere gets n trouble with that, but that is unlikely. I have set that there is a Facebook site on Darktable and there are people from Norway.

this might be useful too How to Take a Screenshot on Windows 10? (2021 Guide) | Geek's Advice

The reason that i used my Ipad to take pictures, is because I am having this dialog on my Ipad and are having Darktable on my job PC. There are some restrictions in use of my job PC. :blush:

1 Like