Is gimp-separate plugin working in 2.10?


(farid) #1

Has anyone managed to use the gimp-separate plugin in GIMP 2.10?


(Mica) #2

I haven’t tried. Is it throwing errors?


(farid) #3

Getting this (translated from portuguese):

Plug-in with problems: "separate"
(/usr/lib/gimp/2.0/plug-ins/separate)

The plug-in may have compromised the internal state of the GIMP upon dying. You may want to save your images and restart GIMP for security.

(Mica) #4

Oh, that is not informative!


(farid) #5

yeah, from the terminal i only get:

munmap_chunk(): invalid pointer
/usr/lib/gimp/2.0/plug-ins/separate: fatal error: Aborted


#6

This is in linux kubuntu 16.04 Gimp 2.10.2 flatpak

Tried a couple of times to compile separate+ for Gimp 2.10 without success. Far beyond my capabilities, more error messages than enough.

Using the separate+ plugins from linux Gimp 2.8 in Gimp 2.10

Applying separate does bring up that error. However you can get a CMYK out by decomposing to CMYK, then a little fiddling to get the separate+ export to work.

Just for interest, a short video 3 minutes demo

Edit: Another day, a try in a Win10 VM and Gimp 2.10.2 - no good here. Save your time.


(Alex Prokoudine) #7

In the meantime, you can use CMYKTool.


#8

Yep, but same as me, just a bit on the old side. Remember both Separate+ and CMYKtool are what? 2010 for the latest.

As it happens I have CMYKtool in kubuntu 16.04, just got to hunt out the old libtiff.so.4 which is a dependency.

Win10 & Gimp 2.10.2 is another matter. CMYKtool - too many dependencies to harvest. Life is too short.

Another try at Separate+ The old files I kept around failed, however I remembered a samj 64 bit version. Separate+ still crashes but the export ‘hack’ mentioned in the video works.

Probably the best bet for Windows users is Krita. Big application just for the conversion but at least you see what you are getting.


(Alex Prokoudine) #9

I am confused.

Win10 & Gimp 2.10.2 is another matter. CMYKtool - too many dependencies to harvest.

Dependencies to harvest on Win10???


#10

I am sure you know exactly what I mean.

You might start off with

add those and more are required…because…from source.

And that about sums it up, Gimp 2.6 or earlier.

Still, there are other options but not for Gimp 2.10 at the moment, hopefully someone will write a new plugin.


(Alex Prokoudine) #11

Too bad, because I don’t. Now I do.


(farid) #12

It has been ages since I managed to run that. I used it a lot back in the days. :confused:


(farid) #13

Hey @prokoudine, is there any thing in the short term planned to have separate or a similiar alternative? We have downgraded to 2.8 for now.


(Elizabeth Hayman) #14

Hey sorry to jump in, but oh wow that explains so much! (like why I can’t just download a 2.10 straight without having huge issues!) So I guess I need to go for the next lowest as well, which I assume is the 2.8? Oh well :slight_smile: - thanks for unintentionally enlightening me!! :slight_smile: (NO, really!!) :wink:


(farid) #15

Technically there is no issue in 2.10, the problem is the Separate+ plugin which needs to be ported. By downgrading we encountered one issue though, that 2.8 is not recognizing the #software:gmic plugin anymore. Oh, well. :man_shrugging:


#16

Never used Separate+ before. What can it do that GIMP 2.10 cannot?


(Mica) #17

Separate+ brings CMYK to GIMP.


#18

Just wondering. In GIMP, decompose and recompose would be enough for me.


(Mica) #19

For image manipulation, yes, but if you’re doing traditional or digital offset printing, you need CMYK.


(farid) #20

@paperdigits Do you know if I can find an AppImage or Flatpak of Gimp 2.8 with the Separate plugin?