Is NVIDIA Corporation GP108 [GeForce GT 1030] supported by DT for OpenCL (resolved)

I have installed a NVIDIA Corporation GP108 [GeForce GT 1030] into a desktop computer which I am running on Linux Mint. I had hoped it would be a useful computer for DT edits, but the OpenCL options are greyed out. I presume I am out of luck with this graphics card. Any suggestions would be appreciated.

You’re likely using the open source driver, which doesn’t support open CL. You’ll need to install the proprietary driver.

I started to google it, but it looks like sort of a mess.

1 Like

1 Like

This is so true of many searches to fix computer problems. I hope Tony’s suggestion to download official drivers works.

@TonyBarrett thanks for the suggestion. I downloaded the driver and it feels like I need to be a computer engineer to install it. I have spent the last few hours trawling the web forums for suggestions on how to install the driver. Tried a few ideas. It looked promising until I got an error message that I appeared to be running an x server: please exit X before installing. Feeling a bit overwhelmed by it at the moment. Any suggestions would be appreciated?

Have you checked that Nvidia proprietary drivers aren’t directly provided by Mint’s repos? Mint is based on Ubuntu, and Ubuntu has those drivers on the official repository.

So now I have the latest driver installed, but still no opencl in DT. Any ideas anyone? Thanks

I’m lost really, but maybe worth trying deleting/renaming the dt config folder? I think dt searches for available GPUs on initial startup - probably wrong :smile:

Ubuntu, and I believe Mint, which is based on it, have NVidia drivers in the repo.

Have you checked the output of the darktable-cltest tool?

The driver itself is not enough, there are also some OpenCL files, which may not be installed by default.
Here are the packages I have installed:

ii  libcudart11.0:amd64                                         11.5.117~11.5.2-1ubuntu1                             amd64        NVIDIA CUDA Runtime Library
ii  libnvidia-cfg1-525:amd64                                    525.85.05-0ubuntu0.22.10.1                           amd64        NVIDIA binary OpenGL/GLX configuration library
ii  libnvidia-common-525                                        525.85.05-0ubuntu0.22.10.1                           all          Shared files used by the NVIDIA libraries
ii  libnvidia-compute-525:amd64                                 525.85.05-0ubuntu0.22.10.1                           amd64        NVIDIA libcompute package
ii  libnvidia-compute-525:i386                                  525.85.05-0ubuntu0.22.10.1                           i386         NVIDIA libcompute package
ii  libnvidia-decode-525:amd64                                  525.85.05-0ubuntu0.22.10.1                           amd64        NVIDIA Video Decoding runtime libraries
ii  libnvidia-decode-525:i386                                   525.85.05-0ubuntu0.22.10.1                           i386         NVIDIA Video Decoding runtime libraries
ii  libnvidia-egl-wayland1:amd64                                1:1.1.10-1                                           amd64        Wayland EGL External Platform library -- shared library
ii  libnvidia-encode-525:amd64                                  525.85.05-0ubuntu0.22.10.1                           amd64        NVENC Video Encoding runtime library
ii  libnvidia-encode-525:i386                                   525.85.05-0ubuntu0.22.10.1                           i386         NVENC Video Encoding runtime library
ii  libnvidia-extra-525:amd64                                   525.85.05-0ubuntu0.22.10.1                           amd64        Extra libraries for the NVIDIA driver
ii  libnvidia-fbc1-525:amd64                                    525.85.05-0ubuntu0.22.10.1                           amd64        NVIDIA OpenGL-based Framebuffer Capture runtime library
ii  libnvidia-fbc1-525:i386                                     525.85.05-0ubuntu0.22.10.1                           i386         NVIDIA OpenGL-based Framebuffer Capture runtime library
ii  libnvidia-gl-525:amd64                                      525.85.05-0ubuntu0.22.10.1                           amd64        NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii  libnvidia-gl-525:i386                                       525.85.05-0ubuntu0.22.10.1                           i386         NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii  nvidia-compute-utils-525                                    525.85.05-0ubuntu0.22.10.1                           amd64        NVIDIA compute utilities
ii  nvidia-dkms-525                                             525.85.05-0ubuntu0.22.10.1                           amd64        NVIDIA DKMS package
ii  nvidia-driver-525                                           525.85.05-0ubuntu0.22.10.1                           amd64        NVIDIA driver metapackage
ii  nvidia-kernel-common-525                                    525.85.05-0ubuntu0.22.10.1                           amd64        Shared files used with the kernel module
ii  nvidia-kernel-source-525                                    525.85.05-0ubuntu0.22.10.1                           amd64        NVIDIA kernel source package
ii  nvidia-modprobe                                             515.48.07-1                                          amd64        utility to load NVIDIA kernel modules and create device nodes
ii  nvidia-opencl-dev:amd64                                     11.5.2-1ubuntu1                                      amd64        NVIDIA OpenCL development files
ii  nvidia-prime                                                                                   all          Tools to enable NVIDIA's Prime
ii  nvidia-settings                                             510.47.03-0ubuntu1                                   amd64        Tool for configuring the NVIDIA graphics driver
ii  nvidia-utils-525                                            525.85.05-0ubuntu0.22.10.1                           amd64        NVIDIA driver support binaries
ii  screen-resolution-extra                                     0.18.2                                               all          Extension for the nvidia-settings control panel
ii  xserver-xorg-video-nvidia-525                               525.85.05-0ubuntu0.22.10.1                           amd64        NVIDIA binary Xorg driver
ii  clinfo                                                                                   amd64        Query OpenCL system information
ii  ocl-icd-libopencl1:amd64                                    2.2.14-3                                             amd64        Generic OpenCL ICD Loader
ii  ocl-icd-libopencl1:i386                                     2.2.14-3                                             i386         Generic OpenCL ICD Loader
ii  ocl-icd-opencl-dev:amd64                                    2.2.14-3                                             amd64        OpenCL development files
ii  opencl-c-headers                                            3.0~2022.05.18-1                                     all          OpenCL (Open Computing Language) C header files
ii  opencl-clhpp-headers                                        3.0~2022.05.18-1ubuntu1                              all          C++ headers for OpenCL development

I believe the packages nvidia-opencl-dev, ocl-icd-opencl-dev, opencl-c-headers, opencl-clhpp-headers are only needed if you compile darktable yourself.

Do you have anything in /etc/OpenCL/? I see /etc/OpenCL/vendors/nvidia.icd. When I display the contents of that file, I get locate tells me that matching files are in:


dpkg -S /usr/lib/x86_64-linux-gnu/ reveals that the file is provided by the package libnvidia-compute-525, included in the list above.

There are a lot more qualified people already responding in this thread. FWIW, I’m running Ubuntu 22.04 and very occasionally OpenCL used to be greyed out. I would switch to another driver and back again and that would bring it back, typically. Will have a look at my PC when I’ve got a moment this morning though I’m near clueless on the technology and so others will be better equipped to help. Sorry

@kofa thanks for your reply. I am trying to digest and understand the info you have supplied. Linux is a very strange beast for an ex-windows person so I am struggling but trying to google for answers and etc.

Edit: I have found the etc folder and it contains a single file in OpenCL/vendors for nvidia.icd

Any reason why using mint? It is no longer a distro I would recommend to a new Linux user.

Then most probably the NVidia OpenCL files are installed. You can confirm that using dpkg from the command-line:
dpkg -l | grep ^ii|grep -i nvidia and dpkg -l | grep ^ii|grep -i opencl
(Probably there are better commands, but those are the ones I use. dpkg is the package manager, -l means ‘list’, | means ‘send the output of the previous command to the next’; grep allows you to filter files (or the output of a program) for text, ^ means ‘match from beginning of line’, ii is a marker used by dpkg for installed packages.

Also (and perhaps more importantly), what is the output of darktable-cltest?

@123sg @kofa @g-man @guille2306 @TonyBarrett @paperdigits

Problem resolved. It was very painful for a person not very familar with Linux, but I managed to install the lastest driver and it did not solve the problem. I then uninstalled Darktable and reinstalled it and it now has open CL so hopefully much improved performance. I feel installing DT after the Nividia driver was the secret. Thanks for all your effort today.


Hmmm… I don’t see how that could be the case (unless you removed the config files as well).
With darktable (and other cross-platform open-source software used on this forum) reinstalling pretty much never works, because (unlike native Windows apps) config data is not removed when the software is uninstalled.
But anyway, I’m glad it works now.

1 Like

You are probably right as you have understanding of this than me. I tried installing darktable from the software manager and it installed v3.0 with OpenCl. So I thought uninstall v4.2 and reinstall and it then had OpenCL. BTW, when it wanted to re-install DT 4.2 it picked up that it needed to install a nividia file as well. At least after a long day it is working. Again thanks for your help.

I have my problem solved, but I wonder why you do not recommend Mint. My wife is a real crash test dummy for computers, when I asked her to do a right click she asked me what a wrong click is. I switched her from Windows to Mint and she had no trouble. It seem a nice distro to me but I am genuinely interested in which distro you recommend. I eventually want to break free of Adobe and Microsofts stranglehold on my computers.

1 Like

Everyone one has an opinion about distros and if they dont like something, they will just create a fork. There is a thread around distros to look at.

Linux mint is nice but I dont like the direction ubuntu is taking (eg snaps). I think there are also issues with building dt on 22.10.

I’ve been using Fedora KDE spin in my workstation.

I don’t like snaps, either, but for now, I was able to get rid of them completely.
I build darktable on 22.10 without issues.

OBS fails:. Show graphics:darktable / darktable - openSUSE Build Service