issue with Natron 2.3.11 (SOLVED)


(Walter) #1

Hi to all,
i explain the issue,I have installed Natron in Ubuntu 16.04, i upgraded Natron to 2.3.11 with NatronSetup, when i run Natron i get an error about boost version (boost 1.67 is required) so i downloaded the 1.67 boost package’ i compiled it and installed it. And this is fine. But when i run again Natron i get this error instead:

./Natron
Natron Version 2.3.11
Copyright © 2013-2018 INRIA and Alexandre Gauthier-Foichat

Use the --help or -h option to print usage.<<<
/home/walter/Natron2/bin/Natron: symbol lookup error: /home/walter/Natron2/bin/Natron: undefined symbol: PyUnicodeUCS4_FromString

Maybe some python package missed to install?
Any of you had this issue?


(Walter) #2

probably the issue is related to the python version i used to build boost library, in project-config.jam i have:

# Python configuration
import python ;
if ! [ python.configured ]
{
    using python : 2.7 : /usr ;
}

should i compile boost with python 3.5 version?


(Walter) #3

Installing Natron 2.3.11 from the online installer downloadsolved the issue. Not understood what went wrong with the update system. If you need i can post the log file of Natron update process.


(Frédéric Devernay) #4

You shouldn’t need to install any external package. The proper version of boost is included with Natron.
Is the LD_LIBRARY_PATH set ? Open a terminal and type echo $LD_LIBRARY_PATH


(Walter) #5

Thank you for your answer @devernay.
This i my printing:

echo $LD_LIBRARY_PATH
/usr/local/browndeer/lib:/usr/local/lib64:/usr/local/cuda-3.0/cuda/lib64:/usr/local/cuda-3.0/cuda/lib:/home/walter/powerVR_sdk/SDKPackage_OGLES2/Builds/OGLES2/LinuxX86/Lib

What lib path i should set in your opinion?


(Frédéric Devernay) #6

never set LD_LIBRARY_PATH when launching Natron.
try
env LD_LIBRARY_PATH="" /home/walter/Natron2/bin/Natron

Setting LD_LIBRARY_PATH globally in your environment in generally a bad idea. Only set it when you really need it. My guess is that there is a boost library installed somewhere in these directories, and maybe also other versions of the libraries shipped with Natron.