LensFun data not being used by RawTherapee

lensfun

(Paul Bleicher) #1

I am new to RawTherapee and trying to get lens distortion correction working with a RAW image from a Fuji XT-1. Using Manual, I get a limited list of Fuji cameras which doesn’t include any of the XT cameras (as shown).
Lenses

When I select lenses for any of the camera, I just get two (as shown).
Cameras
Here are steps I have taken:

  1. I have checked the Lensfun database, and the XT-1 should be found, along with many other cameras. There should be a large number of lenses available as well.
  2. I downloaded Lensfun and installed it both in the /usr/share directory as well as the .local directory. The XML files include the XT-1 camera.
  3. I have updated the lensfun data
  4. I have updated the rawtherapee package.

The cameras and lenses available seem to correspond to the DCP folder in rawtherapee directory in /usr/share.

I am on Ubuntu 16.04, RawTherapee 5.4-1dhor~xenial and version 1 of the lensfun database.

Can someone tell me how to get the lensfun data working?


(Sebastien Guyader) #2

Have restarted Rawtherapee after installing and updating lensfun? Have you selected Fujifilm X-T1 in the camera list, before looking for the lenses?


(Paul Bleicher) #3

Yes, I have restarted Rawtherapee. And, I have rebooted the computer, just in case. As you can see from the screenshot, the XT-1 doesn’t even show up on the list of cameras. (Actually, I realize the screenshot is cut off - the only other camera that appears is the XPro-1. There is no XT camera listed). Further, when I chose ANY Fuji camera first, you only get the two lens choices. It appears to be pulling from the original lensfun data from the /user/share/lensfun folder and not the version_1 subfolder which came down by updating lensfun.

If I copy the XML files in the version_1 subfolder and paste/replace into the main lensfun folder, I get no cameras or lenses at all.

I think this is a major bug. The instantiation of lensfun within RawTherapee doesn’t recognize the update process of lenfun. It continues to pull only from the original list of cameras/lenses.


#4

Could you please try to rename ~/.config/RawTherapee (or -5, i don’t remember the exact name), restart Raw Therapee, and see if there are differences?


(Paul Bleicher) #5

I just renamed the config file and restarted. Got the same result.


#6

Hi @pbleic and welcome,

a) Have you updated lensfun?

b) I have an X-T1 and rt has no problem identifying it:

Screenshot_2019-01-01_19-34-28

Have fun!
Claes in Lund, Sweden


(Ingo Weyrich) #7

That might be a bug in RT 5.4. Please try RT 5.5


(Paul Bleicher) #8

I have updated lensfun. Yes, after that original post, I realized it was unrelated to the DCP profiles.


(Paul Bleicher) #9

Thanks so much. Updating to 5.5 fixed it!