Local Lab build


(Desmis) #161

@dngimage
I’ll look but “en vacances” :slight_smile:

@Morgan_Hardwood
I just merge “dev” in locallabgtk3
thank you :slight_smile:


(Desmis) #162

@dngimage
I found a bug in “blurr and noise”…In some cases ==> crash !
I’ll solve it (probably)

Merci


(Desmis) #163

I just push a change that solve bug in Blurr (normal and inverse [crash in some cases] )

Now for add noise, radius blurr must be > 1


(dngimage) #164

I found a bug in “blurr and noise”…

Good to know.

In some cases ==> crash I’ll solve it (probably)

It never crashed on me. It just wouldn’t save some of the CPs coordinates to the mip file.

Merci

Merci à toi. Vous devriez vous préparer pour les vacances :slight_smile:


(dngimage) #165

With:

RawTherapee_locallabgtk3_5.0-r1-gtk3-14-g33f02d43_WinVista_64.zip

From here:
https://drive.google.com/drive/folders/0B2q9OrgyDEfPS2FpdDAtMVI1RG8

I am getting this:

The only way out of this is ending the task.

Also in the previous version, the Windows key + M doesn’t minimize RT’s window.


(Desmis) #166

Hello

I have done several small changes…between tennis, films, cards, etc.

Now for “Blur and noise” all seems to work :slight_smile:

For problem above, I don’t think it’s specific to locallab.

jacques


(dngimage) #167

@jdc,

For problem above, I don’t think it’s specific to locallab.

I’ll wait for the next build and see if it goes away :slight_smile: It doesn’t happen with the previous version. I’ve never had this pop-up dialog window before.


(Morgan Hardwood) #168

@jdc it’s not a problem with your branch.


#169

@dngimage

I think that clicking many times on continue will permits to go on.
Do you have a removable drive on G:?
It seems that there is a problem with gtk3.22.7 see https://github.com/Beep6581/RawTherapee/issues/3544
I am trying a workaround.
Could you test locallabgtk3_5.0-r1-gtk3-19-g0b9b74bc
that is uploading now?


(Morgan Hardwood) #170

Commit 88985c hopefully fixes this problem. That means that this problem will be fixed in the locallabgtk3 branch when the dev branch is next merged into it. @jdc would you like to do that, or should I?


(dngimage) #171

@gaaned92,
locallabgtk3_5.0-r1-gtk3-19-g0b9b74bc took care of the problem. Thanks! :slight_smile:
Have a great day!


(todd) #172

Is this a known issue with local lab? I haven’t tried the LL build in a while but had never seen this before… Looks like this in RT too, but even more black blob in the LL area. It starts as soon as I turn on Tone Mapping or any of the other contrast increasing options… It doesn’t happen on all images either… Seems to come and go, but I haven’t used it enough yet to notice any specific pattern… Just thought I’d start here thinking this is probably a known bug… thanks


(todd) #173

On a positive note, not getting any No Disk errors with ‘locallabgtk3_5.0-r1-gtk3-19-g0b9b74bc’ and left my SD card in the slot with it enabled… :grin:


(Desmis) #174

Hello Morgan
Could you merge ?
Thank you

Jacques


(Desmis) #175

Hello Morgan
Can you merge for me :slight_smile:

Thank you


(Desmis) #176

@todd
The passage from the algorithms of full image to local, is not obvious … It is obvious that the taking into account of a reference point (hue, chroma, lightness) brings deep differences of behavior, of course without speaking of the remainder of the shape detection alogorithm.
Without going into detail, there are several ways to deal (beyond the settings themselves):

  1. by choosing “global quality”, which will notably take into account the impact of chroma noise
  2. scope that treats the extent of hue
  3. the 2 cursors: threshold and iterations

In the case of “Tone mapping”, one can not have everything and its opposite. In some cases, and this is not a bug, but the algo that does what it is asked, it will be necessary to reduce either “threshold” or iterations, and possibly to set them to zero.

View more details “Rawpedia”


(Morgan Hardwood) #177

@jdc merged and pushed.

I made a quick test, it changed a lot since I last tried it!

I found these bugs:

  • The .mip files are stored in the wrong place. The console says
    mip files in=/home/morgan/.config/RawTherapee/profiles/amsterdam.pef.mip
    but they should be in cache not in config! So the correct path should be
    /home/morgan/.cache/RawTherapee/mip/amsterdam.pef.mip
    (maybe change the folder name from “mip” to “locallab”? I don’t know what mip means).
  • Each mip file should include a hash of the photo file in the filename, so that you can have more than one identically named photo in different folders. For example
    /home/morgan/.cache/RawTherapee/mip/amsterdam.pef.02e621096401cccf3badfefa78.mip
  • When the LocalLab curves are dragged they create hundreds of history entries.
  • Right-clicking on the Local Lab sub-tools, such as Color & Light, does not work - it should expand the clicked tool and collapse the others, same way as with Wavelets for example.
  • The sub-tools should be collapsed and turned off by default.

Enhancement requests:

  • Rename “Shape” to “Settings”
  • Put the “Control points” slider into “Settings”
  • Make “Settings” collapsible (MyExpander) so that we don’t always have to see it.

(todd) #178

Thanks for this. I was also experiencing memory leak with this branch/build last night unlike with the master, and wonder if that also contributes or is related to the LL behavior… The enhancements to LL since the last time I had tried it are awesome though!


(Desmis) #179

Hello Morgan
I change the GUI “expander”, but we cannot collapse by default, as I have already said above…(as wavelet !)

Why “mip” ? why not ? why pp3, why rtti, etc.
Mip = M ult I ple Parameters

For history entries I don’t know how to do !
For locate in cache I don’t kmow how to do!
Where are and what is “hash” ?
Remember, I am not a computer man, I am a scientist
For me above, is cheneese, or egyptian :slight_smile:
Jacques


(Morgan Hardwood) #180

Hey @jdc

That’s fine, as long as right-click works to do all the work for us.

Well, PP3 = processing profile version 3.
rtti I guess means rawtherapee thumbnail image (I’m guessing).
I had no idea what “mip” stood for. Now I know :slight_smile:

I will copy the points to github so that others maybe can help.

We must have a beer.

Kind regards :slight_smile: