Mac RT advanced feature test metadata-exiv2

1. WHO - macOS RawTherapee 5.9+ advanced feature testers

2. WHAT - A new folder with macOS .dmg containing a build of the metadata-exiv2 branch

3. WHEN - Currently

4. WHERE - In this shared iCloud folder: :link:

5. WHY - Metadata for many new and various camera and imaging equipment (eg. CR3) is now recognized in metadata-exiv2
6. HOW - This branch changes the way metadata is read by RT under the hood.
  1. Caveats: lensfun works ok, with reasonable limitations. For example, exiv2 can read that this is from an R7, and is stating which Sigma lens is on, but the equipment is still too new for lensfun, which did not match anything automatically.

photo by Dave Goldberg


I installed this version on my Mac M1 running latest macos ventura.
It crashes on startup.
See attached crashdump.
CrashDump.txt (11.2 KB)

Thanks @jhmnieuwenhuis I am going to generate a new one in a Few Minutes \small^{TM} and see if I can resolve that missing library issue.

@jhmnieuwenhuis You may have a try at this latest build in the same folder, replaces previous.
OHH WAIT-- -you have two copies of RawTherapee in the Applications folder, that causes an error unfortunately, you will have to swap them so only one exists inside the folder at a time. Thanks…

Ok, This one runs.
I opened files from my R5 ( Cr3) and the exif data is available.
Great job !!

I will do some more testing tomorrow.


1 Like

I have to log in with apple id to download, is that how it’s supposed to work?

Mmmhmm…Are you in some sort of Hackintosh situation up there, @nosle?

nope, at work… thought I could do some testing whilst editing some work photos.
When I click your link 4. WHERE I get forwarded to an icloud page saying I need to log in to mount the shared folder.

Since it’s a work computer the appleid situation is a bit strange. Not really a mac guy and trying to make sure I won’t become one :slight_smile:

I had to login using my apple ID to download.
To connect to iCloud drive.

I also had to log in to Apple ID to upload to my iCloud Drive.

@HIRAM, is this version still available? I get an error in iCloud that the user stopped sharing the folder? Hope this works for my R5 and RF100-500 :slight_smile:

Both builds have been updated last night. Please have a test if you are able.

Version: 5.9-260-gc557b320c
Branch: metadata-exiv2

Have tried to make it crash on M1 Ventura 13.5 but it’s looking very stable - nice :grinning:

However, still can’t get the external editor command to function:

open -b “com.adobe.Photoshop” opens Photoshop in Terminal, so it’s the correct syntax.

Tried with NC checkbox ticked and unticked - not functioning either way - really irritating that this still isn’t fixed.

I have the same issue.
Photoshop will not open from Rawtherapee.

Can you start RT from the command line and provide any output about this issue?

Hi, tested starting Rawtherapee on the commandline.

No output when i try to open image in Photoshop.
Only the normal startup output when starting rawtherapee.
hn@JhmnMac1 MacOS % ./rawtherapee

(rawtherapee:6620): GLib-GObject-CRITICAL **: 19:26:21.384: invalid cast from ‘GtkMenuBar’ to ‘GtkWindow’

(rawtherapee:6620): Gtk-CRITICAL **: 19:26:21.384: gtk_window_add_accel_group: assertion ‘GTK_IS_WINDOW (window)’ failed

(rawtherapee:6620): Gtk-WARNING **: 19:26:22.299: Could not load a pixbuf from /org/gtk/libgtk/theme/Adwaita/assets/bullet-symbolic.svg.
This may indicate that pixbuf loaders or the mime database could not be found.
Error: Directory Image, entry 0x935c has invalid size 7161803041; skipping entry.
Error: Directory Image, entry 0x935c has invalid size 1200361124
1; skipping entry.
Error: Directory Image, entry 0x935c has invalid size 4476128841; skipping entry.
Error: Directory Image, entry 0x935c has invalid size 984747240
1; skipping entry.

I know the newer macOS versions have some pretty restrictive software in place for things like disk access, are you sure RT all the permissions?

Slight correction.
I am a bit rusty on Rawtherapee.
When i use the down arrow to the right of the pallet, nothing happens.
When i click directly on the pallet there is a message on the cmd window

** (rawtherapee:6686): CRITICAL **: 19:32:31.962:
unhandled exception (type Glib::Error) in signal handler:
domain: g-io-error-quark
code : 15
what : Creating an app info from a command line not currently supported

Mica - RT 5.9 public release has the old style external editor command line setup.
open -b “com.adobe.Photoshop” does indeed open the image from RT into Photoshop 2023 just as it should.

Removing all traces of 5.9 public release totally from the system, and replacing with any of the dev builds using the NEW external editor command line setup - no dice, nil, nada, no export.

Remove the 5.9dev build and replace with 5.9 public release - it all works again.

Same machine, same OS, and same Photoshop installation.

So, seeing as the “old way” works and the “new way” does not, logically, it’s more likely the new RT is at fault here.

Have you installed the cli from the download folder Hans? Just a thought…!