Maya 2022 and ACES to Natron

I need some help to get the new ACES 1.0 Viewtransform and linear ACES EXR files working.
I cant match what i see in the Arnold RenderView.

Has someone done this?

Would like to help, but your question is pretty unclear.

Hi thanks for your help.

I try to load an exr from Maya2022 in Natron but im not able to get the same look as in the Arnold Renderview.

The new Maya version is using OCIO 2 with ACES and a Viewtransform called ACES 1.0 SDR.

If needed i could provide those EXR files.

Not exactly sure what you are after but from my limited 3D experience with Maya you won’t get it to match properly. I have heard some other people having issues with the 2022 color model and exr. The default from what I understand is for video. You probably want to change your render profile to linear rec. and the viewport profile to un tone mapped or the unity tone map profile.

Not sure if this will fix your issue but it seems to have been a common problem. From my understanding it is more a Maya is setup wrong more so then a compositor software issue because what you see in Maya is wrong.

what ocio settings you are using in natron?

What we see in maya isnt wrong.
This the untonemaped EXR in linear ACES.

But as you can see the version in Natron is more saturated.

Fixed it with the OCIO file maya is using.

great you found a solution! Working with aces is amazing :heart_eyes_cat:

Its only half the solutiom. I need to apply the right view transform now.

If i manage to get it working i update the thread here.

This node looks fine to me.

But i cant get it to work.

But it did look right in the viewer before. Didn’t it?
What colorspace you plan to output?

The image above is untonemapped.
I like to us the new Viewtransform “ACES 1.0 SDR-video” like in the Arnold Renderview.

Like in the first image in this thread.

Not exactly sure what you are after but from my limited 3D experience with Maya you won’t get it to match properly.

This fortunately isn’t correct, both should absolutely be able to be matched… That’s kind of the point of colour management! If your colours aren’t matching in a colour managed workflow something is wrong with what you’re doing or what the software is doing and should be sorted out. In this case I think the issue is on your end so with some settings tweaks we should be able to make it work! :smiley:

I don’t know what you (or anyone else who stumbles upon this) are already familiar with so I’ll just try to explain the whole process, pay attention to parts that concern and don’t concern you accordingly!

Firstly, I’d recommend using the official OCIO config for both programs. Maya 2022 comes with an ACES config but just to iron out problems and making sure our settings are in sync here I’d recommend downloading the latest version of the official one and setting that as your OCIO config in Windows > Settings/Preferences > Preferences > Settings > Color Management over in Maya (nice labels Autodesk lol) and Edit > Preferences > Color Management over in Natron.

In Maya’s colour management settings the rendering space should be ACES - ACEScg and the display space should be ACES.

Now that these configs are synced to the regular standard ACES config you should notice your output transform options are a little different. Pick the one for your monitor, it’s probably sRGB if you’re on Windows or Linux… If you don’t know you should really find this out before doing anything else!

In Arnold’s render settings files should be written out as EXRs and Color Space should be set to “Raw”.

In Natron make sure the read node is set to ACEScg as both the File Colorspace and Output Colorspace (it’s not in your screenshot!). In your OCIO Display node the Input Colorspace should be set to ACEScg, the view transform (which should be configured for your monitor as mentioned above) should be set to the same one that you use in Maya (or any other OCIO enabled application).

Remember that when using the OCIODisplay node you need to set Natron’s built-in viewer transform (located beside the exposure & gamma sliders) to Linear(none) because Natron’s display transform settings are rather limited AFAIK and this only supports sRGB & REC709, once that’s all sorted it should give you no issues!

As always, if I’ve made any errors here please let me know and I’ll correct them :slight_smile:

As a bonus feature request / gripe, I’d love to see more robust integration of OCIODisplay into the viewer, the user experience of having to always place the node above the viewer in the graph for anything other than linearized images with 709 primaries → sRGB is kind of clunky.

Hank i agree with your workflow but with maya2022 you have three color transforms to match.

Rendering Space
Display Space
View Space

Here’s what those settings specifically should (most likely) look like for you when everything is set up using the instructions above:

I can explain the rationale behind each of these if you’d like, but these three transforms are actually the defaults when loading the actual ACES config… How convenient!

The important setting to note here (other than the view transform) is the “Apply Output Transform to Render” box which should be checked off. This is because we’ve set our rendering space to ACEScg and in our render settings we’ve told Arnold to dump that raw output right into the EXR and not apply any transformations so that we have all that data to work with over in Natron. If you’re only using ACES for your 3D rendering space and conforming to some other gamut for comp (don’t really know why you’d do this) this is the setting you’d change to make that happen.

The apply transform to playblast box is checked on so those will be rendered with the sRGB transform from the viewer, this way playblasts will look correct when they’re rendered to video files.

I trust the maya default on this one. Cause its from the same team they did OCIO 2.

Why should my display set to ACES?

Here is some more info about the setting in this Colorpicker Video from one of the Maya developers. Maybe it does help us to understand whats goin on.

Hmm looks like Natron cant load the maya OCIO 2 config file.

If you’re trying to work with ACES proper use the ACES configs from Colour Science, not the built in Maya ACES configs. It’s not really a matter of “trust” but rest assured that Thomas Mansencal (pipeline lead @ Weta) knows what he’s doing. The Arnold docs reference this config as well. This document does mention that new users are probably good with the default transforms, I disagree with this method as the whole point of OCIO is for users to manage their own unified colour pipeline settings independently of any single software package. For users that are looking to render in and not use ACES for the rest of their pipeline (or who are completely new to the scene and don’t understand colour management at all) this default config is fine, they can simply use the render transform method as mentioned above, that’s why it’s included… Also the software literally wouldn’t be colour managed without a config, they have to include something.

As for Natron compatibility, you’re correct in that it will not work with OCIO 2 specific features (Like the display transform box in Maya!) It’s almost like there are reasons behind these instructions or something…

In any case, I’ll reiterate again… go download the industry standard ACES config which includes far more output options that you will likely want when exporting your comps or final renders out of your NLE. It’s ALSO updated more frequently Follow the steps above, you’ll have a working ACES pipeline. It should be that simple?

ADDITIONALLY follow that repo closely for the ACES 1.3 update which will hopefully make its way over there sooner rather than later. They have fixed some pretty serious bugs in the latest update which I’ve been loosely following but haven’t tested myself yet.

1 Like

ACES 1.3 is running fine. I try to upgrade the pipeline to 1.4 but there is only the one from Maya compiled. Cause Autodesk is doing OCIO 2.

As we stuck here i wait until there is a solution.

The reason id like to go that route is cause most Artists here do not understand anything about color management. We need a out of the box solution without touching settings in maya.