My take on RawTherapee



It’s a complete revolution for(A)RT…

You can also do radial masks and/or gradients in a similar way:


So I tried compiling ART.

I installed the dependecies first by running

sudo apt update
sudo apt install build-essential cmake curl git libcanberra-gtk3-dev libexiv2-dev libexpat-dev libfftw3-dev libglibmm-2.4-dev libgtk-3-dev libgtkmm-3.0-dev libiptcdata0-dev libjpeg-dev liblcms2-dev liblensfun-dev libpng-dev librsvg2-dev libsigc++-2.0-dev libtiff5-dev zlib1g-dev

It installed everything fine, then I followed @Morgan_Hardwood’s instruction but no dice.

zerounu@computor9000:~$ ./build-art

Program name: art
Build type: release
Build without updating: false

Cloning into '/home/zerounu/programs/code-art'...
remote: Counting objects: 73993, done.
remote: Compressing objects: 100% (2423/2423), done.
remote: Total 73993 (delta 1768), reused 0 (delta 0)
error: RPC failed; curl 56 GnuTLS recv error (-110): The TLS connection was non-properly terminated.
Receiving objects: 100% (73993/73993), 135.25 MiB | 398.00 KiB/s, done.
Resolving deltas: 100% (58617/58617), done.

Adobe released Range mask ( Color + Luminosity) to Lightroom in 2017
According to many of the pro users , this was the most important update ever.

@zerosapte you have some TLS issue, try again on a good internet connection.

@paperdigits That’s strange, I tried it twice, using a wired connection and I don’t have access to anything better than this.

Does Speedtest even use HTTPS?

You might have a proxy or something somewhere that is breaking HTTPS.

Although it almost looks like the clone recovered from that TLS failure??? Does it happen every time or is it just intermittent/transient?

I don’t know about speed test and https. I only tried building ART twice, same exact error both times.

This could help:

In the life of SW, It may happen you have to break backward compatibility to permit major improvements.
ART could be viewed as a prefiguration of RT major version 6,
the legacy version 5 benefiting only of maintenance fixes for some period.

Version: 5.0-r1-gtk3-4244-g6b976fd7f
Branch: alberto-dev
Commit: 6b976fd7f
Commit date: 2019-09-05
Compiler: gcc 9.2.0
Processor: SSE4
System: Windows
Bit depth: 64 bits
Gtkmm: V3.24.1
Lensfun: V0.3.95.0
Build type: release
Build flags:  -m64 -mwin32 -msse2 -mfpmath=sse -mthreads -Wno-aggressive-loop-optimizations -Wno-parentheses -std=c++11 -mtune=generic -msse4 -Werror=unused-label -Wall -Wuninitialized -Wno-deprecated-declarations -Wno-unused-result -fopenmp -Werror=unknown-pragmas  -DNDEBUG  -O3 -ftree-vectorize
Link flags: -m64  -mthreads  -static-libgcc   -mtune=generic -msse4  -s  -O3  -fno-use-linker-plugin
OpenMP support: ON
MMAP support: ON


  • I have compilation warnings . If you are interested, provide where to file an issue.
  • Could you put an initial tag (0.0 for instance).
  • Is it possible to use tcmalloc on windows? How to?
1 Like

Afaik that’s not possible. Using jemalloc is possible though, but it gave no major improvements on windows (for RT, not tested on ART) in my tests.

Edit: to try jemalloc on Windows do this in msys2 command line

First get jemalloc

pacman -S mingw-w64-x86_64-jemalloc

Then start RT using rawtherapee

I think this is waaay too much speculation. RT has its own goals and roadmap, it has never been my intention to derail it!

I have compilation warnings . If you are interested, provide where to file an issue.

thanks! I’ve just enabled the issue tracker on bitbucket


Exactly, though I am sure there will be an intersection between RT and ART concerning new features, ideas, solutions… :wink:

Sorry if you felt involved in my remark about the future of RT and I didn’t suspect you to want to derail RT.
But it is unavoidable, in the life of an application to have to take a new start and break compatibility to go ahead.
It was my own thought and wish that all RT dev gather around the same SW development as they are not so numerous.

As it is not a commercial SW, I should say that each dev has its own goal and roadmap. By chance, some times they can agree on them :joy:

I disagree. Imho the consense between RT devs mostly was and still is very good. That doesn’t mean there was always a consense, but imho that would be impossible…

I know most of the RT devs in person, and some other devs at least know some other devs in person, that helps a lot!

Edit: Let’s name some RT devs by A, B, C, D, E, F

A met B, C and D in person. B met A , C, D and E in person. C met A, B and E in person, B and F will meet at Saturday.

Who is Who ?

Sounds like a chain mail or social media quiz. The letters could represent various members of a secret open society. :shushing_face:

@zerosapte try this:

rm -rv ~/programs/code-art
git clone ~/programs/code-art
1 Like

Any chance to support .CR3 format?
It’s more than a year now, not even a single raw editor on Linux supports that format.
Canon DPP and Lightroom all don’t work on Linux.

Not even 1 raw editor on Linux. Interesting. Not even 1!

that’s because there’s no open source cr3 decoder available yet. the next version of libraw is supposed to have one. when that gets released, I’m sure everyone will catch up.
in the meantime, the Adobe dng converter works fine under wine

1 Like