OM-1 Support in Darktable

Hello from France, as “paco”, we are the owner of an OM-1 and disappointed that it is not yet recognized in the new version of Darktable 4.0. I have read the post well and it is far too technical with regard to my IT level. If the procedure described could be reduced to an executable file under windows, it would be great for everyone.
thanks for your job.
our discussion on the Darktable France forum: boitier OM-1 sur DT v4.0

@jose_c — unfortunately I don’t know how to make it less technical. Maybe someone can compile that branch for windows (I can’t) and post the executable somewhere for downloads…

The darktable project is super short on windows developers.

Windows users are highly encouraged to jump in and help out however possible.

I followed sugarbravo’s instructions and it works fine to open my OM-1 files. So that it great, thsnks!
But I have one question, is this the 4.0 version of Darktable or the previous one?
When I check the “about” in the program it says unknown on version.

see dt unknown-version? ["solved" -- sort of] - #16 by pehar

Thank you!
I tried following the instruction with the “safe directory” row added to the sequence from Sugarbravo. But it still states version unknown. I can compile the list of commands that I used.

1 Like

git clone
cd darktable
git checkout om-1
git submodule update --init
mkdir build
cd build
sudo git config --global --add …
cmake -DCMAKE_INSTALL_PREFIX=/opt/darktable …
make -j
sudo make install

I also tried

sudo git config --global --add /home/user/darktable/master
sudo cmake --build "/home/user/darktable/master/build" --target install -- -j12

But the result remains the same.

Hej Viktor!

I copied your steps and tested. Works fine. Says version is 3.9.

But why three periods after the Cmake? Two are much better.

Claes i Lund

Thank you Claes,
Then I will try again, maybee something went wrong. I guess I need to delete the already downloaded and installed files first.
It should be two periods. I think that this was auto corrected from two to three :slight_smile:

I just made a branch with full OM-1 support based on darktable release-4.0.0 tag. Building it on Linux:

git clone
cd darktable
git checkout release-4.0.0-om1
git submodule init
git submodule update
mkdir build
cd build
cmake -DCMAKE_INSTALL_PREFIX=/opt/darktable/ ..
make -j
sudo make install
/opt/darktable/bin/darktable --version
this is darktable 4.0.om1

I tried to run your script on a Mac. cmake can’t find curl.

-- Could NOT find CURL: Found unsuitable version "7.54.0", but required is at least "7.56" (found /usr/lib/libcurl.dylib, )
-- Cannot found recent CURL version (>= 7.56) to build piwigo.
-- The following REQUIRED packages have not been found:
 * CURL (required version >= 7.56)
# which curl
# curl -V
curl 7.64.1 (x86_64-apple-darwin19.0) libcurl/7.64.1 (SecureTransport) LibreSSL/2.8.3 zlib/1.2.11 nghttp2/1.39.2
Release-Date: 2019-03-27
Protocols: dict file ftp ftps gopher http https imap imaps ldap ldaps pop3 pop3s rtsp smb smbs smtp smtps telnet tftp 
Features: AsynchDNS GSS-API HTTP2 HTTPS-proxy IPv6 Kerberos Largefile libz MultiSSL NTLM NTLM_WB SPNEGO SSL UnixSockets

It appears that cmake is looking for a curl library, whereas I only seem to have an executable. Homebrew (MacOS package manager) doesn’t know anything about “libcurl”.

Any ideas on how to fix this?

Thanks for any help you can offer!

I’m on Ubuntu Linux, so I can’t help with Homebrew.
You have libcurl installed, but it is an oudated version.
libcurl is the name of a file, not a package. On Linux there is a tool called apt-list which is able to search the package name(s) where file(s) containing libcurl are present. I suspect Homebrew offers a similar function.
If you were able to determine the name of the package, the next step would be to check if there is a more recent version available.

Edit: possibly this can help : homebrew - How to find package for installed file in Brew? - Stack Overflow

This might be a more general question “how to get all the prerequisites for building darktable on macOS?” Someone in this forum or on darktable-dev, darktable-user mailing lists should be able to help.

1 Like

how to get all the prerequisites for building darktable on macOS?

I simply ran your script, and carefully read cmake’s errors and warnings. I then used Homebrew to install stuff that cmake said it couldn’t find.

I was pleasantly surprised to find that /usr/bin/apt exists on MacOS. Then I read the man page, and discovered it’s an “annotation processing tool,” not a package manager. :frowning:

I did locate libcurl.dylib and found a number of applications (including the Topaz suite) that included libcurl.dylib in their installation package. otool -L does not note any version number for them, but they are bigger and newer than the /usr/lib/libcurl.dylib that cmake complains about.

I copied one of those libcurl.dylib files into ~/lib, and put that at the head of $LD_LIBRARY_PATH and re-ran cmake, but it did not change the complaint about /usr/lib/libcurl.dylib. It appears cmake is ignoring $LD_LIBRARY_PATH?

I’m not sure what to do at this point.

For those of you that are using windows, you can download an installer from the following link.


Thank you! Thank you!

thank you very much, you make me happy today. :-))

Hello Victor,

Did you make the same job with the latest version because OM1 is not reconized with it ?

thank you.

Thanks for all the effort!

Is it possible to integrate the OM-1 branch in DT 4.1.0? My DB has been updated already for this version and the om-1 branch for 4.0 does not open it because it is too new.

I hope OM-1 support will be included in 4.2 release in December.

For now I use a separate .config/darktable/ for 4.0.om1 and images from OM-1.

1 Like