PhotoFlow News and Updates

photoflow
news

(Carmelo Dr Raw) #229

I have introduced few fixes/improvements lately, particularly in the UI:

That’s all for the moment.


#230

That’s helpful.

PS Also, thanks for fixing the gamma. I didn’t realize that something was wrong until I used another raw processor.

PPS Could you make it so that export remembers its last settings? That would be nice.


#231

What afre :point_left::genie: said and thank you :hibiscus: and a question:

If Floating tools controls dialogues is checked, is it possible to have each control in a separate window, also masks? I never use PhF in fullscreen mode so my idea is to open all using controls and be able to modify them without having to browse, open and close, or scroll. POC

Also a totally minor visual thing


(Carmelo Dr Raw) #232

Yes, it should be possible and relatively easy… like some option that says “keep all dialogs open”?


#233

Perfetto :man_teacher:


#234

Reset arrow buttons have disappeared (photoflow-w64-20180409).

image

PS Is there a reason for CA correction to be auto by default as opposed to profiled+auto?


(Carmelo Dr Raw) #235

This is implemented in the latest version from today:

They are now back!

From my experience, I find the auto method usually more reliable and accurate than the correction given by lensfun (called profiled). As profiled+auto gives priority to lensfun, I decided to set auto as the default… but this can be certainly discussed.


#236

Just tested it >> S U P E R C O O L !!! << Big thank you :seedling:

12577c8c68c3587

Source: https://pngtree.com/freepng/colorful-background-sheep_1039059.html


#237

Just wanted to know the reason behind the change. I will take your word that it is better that way :slight_smile:. In fact, I can’t tell the difference and haven’t made extensive comparisons. What I am waiting for is post distortion correction auto-cropping :wink:, when you feel like addressing it :sunny:.


#238

Hi guys, may be you can help me with an issue with the recent versions of Photoflow. I run Photoflow on both a MacBook Pro (late 2011) and on a Mac Pro (early 2008). Both are running OS X 10.11.6. On the MacBook no problems, last tested today with version 20180416_0819, however on the Mac Pro I can not run any version since 20180201_2052, the last one that runs fine.

The first lines of the problem report are here:

Process: photoflow [16770]
Path: /Users/USER/Desktop/photoflow.app/Contents/MacOS/photoflow
Identifier: photoflow.org
Version: ???
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: photoflow [16770]
User ID: 502

Date/Time: 2018-04-17 09:25:11.965 +0200
OS Version: Mac OS X 10.11.6 (15G20015)
Report Version: 11
Anonymous UUID: 24652804-CF7F-9F63-D081-7C67EFCDDE0A

Sleep/Wake UUID: D759D8E5-4AC4-4339-B503-E03D6BC3751A

Time Awake Since Boot: 49000 seconds
Time Since Wake: 750 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_INSTRUCTION (SIGILL)
Exception Codes: 0x0000000000000001, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 liblensfun.0.3.2.dylib 0x000000010f19605f lfDatabase::Load(char const*, char const*, unsigned long) + 123
1 liblensfun.0.3.2.dylib 0x000000010f195ef4 lfDatabase::Load(char const*) + 68
2 photoflow 0x000000010c803a20 rtengine::LFDatabase::LoadDirectory(char const*) + 192
3 photoflow 0x000000010c8038a8 rtengine::LFDatabase::init(Glib::ustring const&) + 216
4 photoflow 0x000000010c650db9 PF::PhotoFlow::PhotoFlow() + 2793
5 photoflow 0x000000010c651858 PF::PhotoFlow::Instance() + 40
6 photoflow 0x000000010c62da41 PF::ICCStore::ICCStore() + 1137
7 photoflow 0x000000010c62ed88 PF::ICCStore::Instance() + 40
8 photoflow 0x000000010c50d37b main + 219
9 libdyld.dylib 0x00007fff9204d5ad start + 1

Thread 0 crashed with X86 Thread State (64-bit):
rax: 0x0000000000000000 rbx: 0x00007fb561505a90 rcx: 0x000000010ec13fcc rdx: 0x00007fb561506080
rdi: 0x00007fb56146aec0 rsi: 0x0000000000000000 rbp: 0x00007fff536ff1e0 rsp: 0x00007fff536ff0a0
r8: 0x0000000000000000 r9: 0x000000000000000b r10: 0x000000010ec16f01 r11: 0x000000010eb4d736
r12: 0x0000000000000c07 r13: 0x00007fb562069400 r14: 0x00007fb561505b10 r15: 0x00007fb5615062a0
rip: 0x000000010f19605f rfl: 0x0000000000010246 cr2: 0x000000010f196000

Logical CPU: 0
Error Code: 0x00000000
Trap Number: 6

Any simple suggestion on what to do, if anything can be done? I am not a computer guy !

Thank you for any help and for developing these great tools.


(Carmelo Dr Raw) #239

I suspect that the LenFun library that is bundled in the OSX package was targeted for a CPU model newer than what you have on your 2008 machine. I made quite some changes in the LensFun integration at the beginning of the year, and that might be a bad side-effect of this work. I’m having a look.


#240

Great, thank you for the answer and for all the work with PhotoFlow


#241

In a 10.11.6 2 core early 2009 iMac I can reproduce @zurdo 's ( like Malviviendo’s main character >> 9’20" ) findings. Also as he states, 20180201_2052 works.

Calling rtengine::LFDatabase::init("/Users/max/Downloads/photoflow.app/Contents/Resources/share/photoflow//lensfun/version_1/")
Loading lensfun database from ‘/Users/max/Downloads/photoflow.app/Contents/Resources/share/photoflow//lensfun/version_1/’…Illegal instruction: 4
logout


(Carmelo Dr Raw) #242

@zurdo @chroma_ghost could you please test the latest OSX package (https://github.com/aferrero2707/PhotoFlow/releases/download/continuous/photoflow-osx-20180418_1905-git-stable-19d64f74e935fd868ad0685b2c64f5ae36a2f588.zip) with your pre-2010 machines? I have patched homebrew such that it compiles with a conservative CPU target instead of the default -march=native.

By the way, I take advantage of this to remind that the PhF OSX packages are built entirely on Travis CI virtual machines, including all the dependencies. They are then automatically uploaded to GitHub. That means that at no point the packages or intermediate binary files transit on some private computer that could be potentially infected. This should give virtually zero risk of viruses, unless either Travis or GitHub are somehow compromised…


#243

photoflow-osx-20180418_1905-git-stable-19d64f74e935fd868ad0685b2c64f5ae36a2f588
opens, behaves and exports as expected, both in 10.11.6 and 10.13.4 == :level_slider: L :ear_of_rice: GT :ok_hand: M :penguin:

 

This should give virtually zero risk of viruses, unless either Travis or GitHub are somehow compromised

throwing away the condoms :grin: let’s make babies, I mean edits


(Carmelo Dr Raw) #244

Believe me, I already filled my quota… :upside_down:


#245

Yes. Opens and works on both, the MacBook Pro and the “old” Mac Pro. Anecdotically, just noticed that the icon is the one of PhotoFlow 0.2.8. Great, thank you again for the fast response and actions taken and I will keep testing and using the future new PhotoFlow versions


(Carmelo Dr Raw) #246

I have just implemented an auto-cropping option for the lens distortions correction.

I have tried it on few lens models and it seems to work correctly in all cases, but I’d like to have some additional feedback (pinging @afre on this item).

The feature is currently only available in the RAW developer module, I will extend it to the stand-alone lens correction module once I have some confirmations that it works properly.

Here is a screenshot:


#247

Thanks. I won’t have any specific comments until I do a few more PlayRaws. In the meantime, I noticed that many distortion corrections end up reducing the top and bottom edges by 1px only. It may have to do with the recent raws I worked on, but roughly 6 months ago the corrections were more dramatic. Might be nothing…


(Shreedhar Inamdar) #248

hello @Carmelo_DrRaw. I have decided to move out of my comfort zone (RT, GIMP) and try the Photoflow software. Just downloaded the 0.2.8 windows version (Win 10 64bit) from your blog and loaded the photo taken by old manual SMC Takumar 200mm f/4 lens on EOS 6d. The lens correction module correctly finds the camera but seem to think that I have used Canon’s EF 300mm f/2.8 IS II USM + EF 2.0 Extender III. When I check all corrections box, it does a little something. Of course, I understand that this is a very difficult lens to find. But thought I will let you know.
Also, is it the latest version?