Problems with Darktable and Mac OSX Catalina (solved with dt

Hi, anyone facing problems with Mac OSX Catalina and Darktable ?

Opening a file in Lighttable gives errormessage : failed to read camera white balance information from (filename)
Afterwards the file becomes a ‘skull’

Trying to import folders (which are on a external HD (with all rights) : could not read the contents of (name HD)
Error opening directory 'volumes/(name HD) : operation not permitted

Trying to import files which are stored on the internal HD of my Mac gives the same error.

Some weird behaviour of Darktable and some crashes.

Any clue ? Appreciate your help since I’m no techie guy :wink:

If these are general problems, be warned if you want to upgrade your Mac to Catalina.


Further information : the Darktable database is stored on my HD. It’s still there after updating to Mac OSX Catalina.
Trying to open a photo in dt richt click open in… gives this error :
darktabe - error locking database
an error has occured while trying to open the database from
the database lock file contains a pid that seems to be alive in your system : 2126

So I found somewhere on a Ubuntu-forum that removing data.db.lock and library.db.lock could help, but unfortunately it didn’t.

upgraded to catalina last night.
darktable and gimp both have same problem.
still searching everywhere for solution.

1 Like

Rule of thumb. Always wait for the point release before upgrading. Unfortunately, macOS releases aren’t as solid as they used to be. From the news, Catalina is especially bad for breaking installations.

PS @candyman Welcome to the forum!

This means that darktable may still be running on your system. Make sure it isn’t running, then delete the database lock files.

I am not a Mac user, but Catalina is supposed to have a bunch of changes.

Are the image files stored on an NFS share? People are reporting problems with Catalina + NFS shares.

(Another source of problems is that Catalina will not run 32-bit software. So no Scribus, etc.)

+1 for waiting at least till the point release before upgrading MacOS!

I noticed an enormous amount of complaints from people that upgraded to Catalina; Audacity users reported the same issues. Other projects affected too.

Hi, did this but no solution. Each time I restart darktable the systeem creates new lockfiles…

Hi, no NFS but a simple external HD.

Hi Candyman and welcome here. Do you face the same problems as I have : not able to open files in darktable ?
Hope someone comes with a solution. Been working the last few months on a bigger project and edited a bunch of pictures with dt. Without a solution hours of work is lost.

Quick & dirty workaround:

  • install VirtualBox
  • install a recent Linux distribution in a virtual machine (DT 2.6.2 is at least available in ARCH/Manjaro and in Ubuntu Bionic/Cosmic/Disco through Pascal’s PPA)
  • run darktable inside the Linux virtual machine.

I have no idea if one still gets decent GPU acceleration in this case, but at least this should keep you going until better days will come…

What file system is on your HDD? Mac Os has no default write support for a lot of them, this may cause problems …

Hi Daniel, thank you for your reply. What do you mean by ‘what file system on the external HDD’. This hasn’t been changed since updating to Catalina AFAIK. Sorry for the dumb question :slight_smile:

Hi, meanwhile I found a solution for my current project. I Installed dt on another Mac that is still on Mojave, copied dt’s library-files to it and exported the edited files from the past months out of dt. Relieved that my work is not lost.

Gives us some time waiting for a solution (read a next Catalina update).

If someone has another solution I’ll (and I presume other Mac-users as well) be glad to hear.
Thanks everyone !

1 Like

I have the same problem with accessing a share on Freenas. It seems to be a problem of permissions. Can somebody tell me if this works for them ?

Go to -> System Preferences -> Security and Privacy -> Privacy -> Full Disk Access
Add Darktable to the list of Apps that can access

I am not able to manually add Darktable to the list of Apps in Files and Folders in the same menu. I see that Amazon Prime Photos has access to Network Volumes. So that gets me thinking that perhaps Darktable needs to get an update to enable such a feature requesting for permission to access Files and Folders on Catalina.


I have been able to access the network shares by running darktable from the command line. Maybe this is a temporary workaround.

Open Terminal and run darktable from the command line



it works from terminal!!!
all previous edits are intact.:rofl:

Hi, thank you for the information.
I was able to give darktable Full Disk Access. However this didn’t solve the problem.

BUT : your workaround opening dt from terminal did work for me too and gives me back all my edits. Super !!! Thanks a lot !!!
As a temporary solution, I can live with it.

I hope that there will come a permanent solution. Maybe with a future update for OSX and/or dt.
Meanwhile : keep up the good work.


I’d suspect that the current DT needs to be rebuilt on a machine running Catalina. There are not a lot of people who build for Mac, so we will likely need to wait a bit.

If you can access fine the HDD from Finder (and I mean here read and write) than you can ignore my comment. Otherwise please check how your HDD is formatted. If you use NTFS, Mac OS does not have official write support, so you can only read files. This might create problems for software that needs also write access.

Thanks , after updating to Catalina, running darktable from command line is working. Looking forward to update on this issue.