Question about WB presets in ART 9b5c34d07

Just updated ART to latest build / commit - to 9b5c34d07

But still: I don’t see the new WB mentioned in commit 557bfc6 . Did I maybe do something wrong?

After I messed it up badly, I deleted ART, and re-did:

wget -O build-art
chmod +x build-art

… And ART version is now 9b5c34d07

what are you expecting to see? Sorry but I don’t understand… can you elaborate? Thanks!

Yes, Thank you,
It is said on ART bitbucket for commit 557bfc6
That there are now WB presets:

But in my ART it’s not showing (and it’s freshly built now, 9b5c34d, after I messed it up with bad processing profile and it kept crashing, so I deleted it entirely and re-compiled)

I think this commit updates WB presets for the Phase One IQ180. If you don’t have this camera, you will not see those updated presets.

Oh…! I see now!
Thank you very much @sguyader

I have another two questions please:

  1. When I’m updating (re-compiling) - should I be worried about different settings reverting to default? like custom processing profiles and in the future when I dare to try - LUT’s ? Should I keep them backed up or is it ok to update when they are in their default locations?

  2. Is there a way to force ART to open with default processing profile, for events such as what happened to me, that I had a faulty profile and ART kept trying to open with “last saved” - so kept crashing. I tried to remove the profile so that it might revert to default, but I assume the settings were “in memory” somewhere.
    Do you know what should I do in such case in the future?
    I mean: What is the procedure - to force ART to use default processing profile? or maybe some “start in safe-mode” for ART…?
    Thank you in advanced :pray:


if you see a crash, a bug report would be appreciated. That might increase the chances that the same crash won’t happen again in a future version of the software… :slight_smile:


Yeah… I know, but I had a weird issue and all I wanted was to get back to normal.
What happened was this:
I saved (first time) a processing profile. Also backed it up in another location.
I tried it to see that it’s working, and it did.
I decided it’s time to update ART (Also first time since I started using it), and updated, to also check if the new custom pp would get “ran-over”. It did not. But with new ART version, somehow under “Sensor with Bayer Matrix” - “Chromatic Aberration Correction” - was “Active”, for the custom profile.
All the pictures were opened being almost totally GREEN…

I switched it off and re-saved the profile, then when ART started - it couldn’t load the profile for some reason, and kept crashing, though I tried “to be faster” and quickly change to default, I couldn’t. I tried to delete the profile, in hope ART would revert to default - but the profile was in memory I assume, as “last-used” or something… and ART kept crashing with it, so I had to delete and re-did the build.

I know this is not the proper way to document the event, that this is just my “user-case”. I’m also not certain it was a “bug” - though I have no idea how Chromatic Aberration Correction turned itself on - I never used this feature… ever (yet) and don’t know what it does.
So that’s why I ask about “safe-mode” or “force default processing profile”, for the future.

Thinking about it again:
I assume if I had applied another profile, let’s say - the default - on the “File Browser” window, maybe it would have positioned itself as “last used”. I assume that yes.
On the File Browser - What is the difference between “apply” and “partially apply” - profiles?

You can specify the profile in preferences:

For mine, I have it chosen dynamically at load time:


So every raw file gets the first default baseline profile, then if in-camera cropping is enabled, ART loads the correct crop profile in addition. Plus there’s one for Google phones.

Yes, instruct ART to open a raw with the default profile, Prefs - tab Image processing - Default for raw > choose Default.

Did you try “partially apply”? It will show a dialog where you can select what particular settings to apply.

Also, sometimes clearing the cache helps.

Thank you very very much @lphilpot , @paulmatth , @tankist02 , and @sguyader
I will do better thanks to you guys :pray: MUCH appreciated!
And thank you @agriggio , for your ART! :purple_heart:

Looking through wbpresets.json I don’t see my camera anywhere (Canon T8i / 850D). What’s the process for generating the proper data and subsequently, getting a new camera added?


Going from memory, there’s a script in the tools dir to do this. You just need a raw file from the camera. But I might remember wrong… (Not at the computer right now)

I found the Python script ( and wbpresets.json and copied both locally. I have Python installed (on Windows 11) and tried various incantations of the script but none of the error messages I got really made sense. The “help” isn’t very helpful without prior understanding… :slight_smile:

C:\Users\XXXX\Downloads>python -h
usage: [-h] -u UPDATE [-f] filename

positional arguments:

  -h, --help            show this help message and exit
  -u UPDATE, --update UPDATE
                        wb presets to update
  -f, --force           overwrite existing presets

I have a Linux VM so I could try there, but until I at least get close with the syntax there’s really no point. Python should be Python regardless (except maybe for quoting, newlines, etc.).

There are no comments in the script and neither Googling nor searching RawPedia turned up anything. Oh well, no biggie…

The script is just run it on a raw, and save the output to $HOME/.config/ART/wbpresets.json. if you have previous ones that you want to keep, use the -u parameter. You need to have exiftool installed and in $PATH


1 Like

I’m on Windows so I created C:\Users\xxxx\AppData\Local\ART\wbpresets.json from the output.

Does the preset show up as a UI option somewhere or is it just applied internally when raw EXIF indicates a camera match?


You should get a menu like this:
Screenshot from 2024-01-27 18-12-39

Hmmm… I’m not getting that:


That’s all I see. Everything else looks good to me, unless I’m missing something:

 Volume in drive C is Acer
 Volume Serial Number is E093-B4E9

 Directory of C:\Users\XXXX\AppData\Local\ART

2024-01-27  12:43    <DIR>          .
2024-01-27  10:58    <DIR>          ..
2024-01-13  20:13    <DIR>          batch
2023-10-04  17:04    <DIR>          cache
2024-01-03  12:29    <DIR>          ctlscripts
2023-12-27  14:27    <DIR>          ctlscripts.backup
2024-01-13  22:51             2,375 dynamicprofile.cfg
2024-01-27  10:58             8,944 options
2023-10-04  17:15    <DIR>          profiles
2024-01-27  10:58                 0 session
2024-01-27  10:58                 0 session.last
2023-01-04  20:31    <DIR>          sessions
2023-10-04  17:09    <DIR>          usercommands
2023-10-04  17:18    <DIR>          userfiles
2024-01-27  10:40               645 wbpresets.json
               5 File(s)         11,964 bytes
              10 Dir(s)  244,117,630,976 bytes free

C:\Users\XXXX\AppData\Local\ART>cat wbpresets.json
// updated on Sat Jan 27 10:38:05 2024:

//    "make_model" : "CANON EOS REBEL T8I",
    "make_model" : "Canon EOS Rebel T8i",
    "presets" : [
      { "name" : "daylight", "multipliers" : [ 1.865234375, 1, 1.6201171875 ] },
      { "name" : "shade", "multipliers" : [ 2.1376953125, 1, 1.400390625 ] },
      { "name" : "cloudy", "multipliers" : [ 1.98828125, 1, 1.505859375 ] },
      { "name" : "tungsten", "multipliers" : [ 1.328125, 1, 2.3486328125 ] },
      { "name" : "cool white fluorescent", "multipliers" : [ 1.5634765625, 1, 2.2021484375 ] },
      { "name" : "flash", "multipliers" : [ 2.0439453125, 1, 1.486328125 ] }


I thought It might be a case-sensitivity thing, so I edited the JSON to match exiftool’s output (note the replaced line in the output above):

C:\Users\XXXX\Downloads>exiftool 850D.CR3 | egrep -i "Model Name|Make"
Make                            : Canon
Camera Model Name               : Canon EOS Rebel T8i

That matches what ART shows in metadata (I actually copied it from ART). I also tried “Canon EOS 850D” but that didn’t work either. The JSON format looks just like the installed file.

But even after restarting ART again I still don’t see the camera options.

Certainly not the end of the world, but curious nonetheless.


LATER UPDATE - For what it’s worth I also put the file (chmod-ed 750) into $HOME/.config/ART in a Xubuntu VM with ART 1.21 and I get no menu there, either. Weird.